Login

Esqueci minha senha

lateral
Estatísticas
Temos 29300 usuários registrados
O último usuário registrado atende pelo nome de w00t3d

Os nossos membros postaram um total de 37318 mensagens em 5569 assuntos

auto cadastro do MAC

Página 2 de 2 Anterior  1, 2

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

auto cadastro do MAC

Mensagem por Convidado em Dom 23 Out - 0:04

Relembrando a primeira mensagem :

Ola galera alguem tem o script de auto cadastro de MAC para servidor ppoe, o geronimo comento numa video aula dele sobre este script, alguem te ai para compartilhar o mesmo.

Convidado
Convidado


Voltar ao Topo Ir em baixo


Re: auto cadastro do MAC

Mensagem por Gerônimo em Sex 18 Nov - 7:31

PRONEET escreveu:Gerônimo ... to com outro problema, tenho adicionado o script de controle dos pais, e quando adicionei o script de auto cadastro mac o script de controle dos pais parou de funcionar...Smile o que pode ter havido ? ou funfa um ou outro...?
Funciona perfeitamente os dois juntos voce tem que verificar o agendaento e observar os nomes dos clientes no script para funcionar.

__________________________________________________
A VIDA SO É DIGNA DE SER VIVIDA SE VOCÊ FIZER ALGO PELA VIDA EM VIDA.
MUDE A VIDA DE UMA CRIANÇA APADRINHE COM APENAS R$ 50,00 ACESSE [Você precisa estar registrado e conectado para ver este link.]

Gerônimo
Power User
Power User

Mensagens : 684
Pontos : 1454
Reputação : 722
Data de inscrição : 29/05/2010
Idade : 42
Localização Localização : Brasil

http://www.overnix.com/

Voltar ao Topo Ir em baixo

Re: auto cadastro do MAC

Mensagem por ZBTECK em Sex 18 Nov - 10:28

É isso ai, pode ser que os agendamentos estejam muito proximos (ou coincidindo), ai apenas o primeiro é executado e ao termnar, já passou o horário do outro.


__________________________________________________
Contato Skype zbteck_ltda

ZBTECK
Power User
Power User

Mensagens : 930
Pontos : 1117
Reputação : 186
Data de inscrição : 11/04/2011
Idade : 28
Localização Localização : São Paulo

Voltar ao Topo Ir em baixo

Re: auto cadastro do MAC

Mensagem por LKInformatica em Sex 18 Nov - 15:13

Hum... vou verificar isso;)

LKInformatica
User
User

Mensagens : 159
Pontos : 256
Reputação : 9
Data de inscrição : 21/08/2011
Localização Localização : Recife-PE

http://www.lkinformaticaonline.webnode.com.br

Voltar ao Topo Ir em baixo

Re: auto cadastro do MAC

Mensagem por william em Seg 19 Dez - 14:00

muito bom

william
Advance user
Advance user

Mensagens : 441
Pontos : 613
Reputação : 9
Data de inscrição : 28/08/2011
Idade : 39
Localização Localização : carapicuiba

Voltar ao Topo Ir em baixo

Re: auto cadastro do MAC

Mensagem por leodeal em Sex 23 Dez - 22:00

Olá Boa noite,amigo não estou conseguindo fazer pode me ajudar?
System>scheduule.
Em start date: a data do dia?
start: hora q vai começar?
interval: o intervalo de tempo?
delay: ???

on event: coloco o codigo abaixo?

:foreach h in=[/ip hotspot active find] do={
:global address [/ ip hotspot active get $h address];
:global user [/ip hotspot active get $h user];
:global mac [/ip hotspot active get $h mac-address];
/ip hotspot user set $user mac=$mac address=$address;
:foreach x in=[/ip dhcp-server lease find] do={/ip dhcp-server lease make-static $x};
}

Em policy: marco quais caixa?
Ajude-me por favor.

leodeal
Iniciante
Iniciante

Mensagens : 35
Pontos : 61
Reputação : 0
Data de inscrição : 15/09/2011
Idade : 33
Localização Localização : salvador

Voltar ao Topo Ir em baixo

Re: auto cadastro do MAC

Mensagem por Erimar em Seg 2 Jan - 15:14

ola eu estou com uma duvida muito grande
pes quero saber se é so copiar e colocar la ?
ou se tem que configuralo ?
e como eu faço para configurar ele ?

Gerônimo escreveu:Segue os scripts so criar o agendamento recomendo que coloque para rodar de 3 em 3 minutos,

SCRIPT AUTO MAC PARA HOTSPOT PARA MIKROTIK 3X A CIMA
Código:
############################## ############
# Objetivo: No hotspot ele pega ip + mac #
# do cliente e coloca o ip dele fixo #
# para que o ip do cliente nunca mude #
# com o dhcp. #
# Pesologia: Use a cada 3 MINUTOS #
############################## ############
:foreach h in=[/ip hotspot active find] do={
:global address [/ ip hotspot active get $h address];
:global user [/ip hotspot active get $h user];
:global mac [/ip hotspot active get $h mac-address];
/ip hotspot user set $user mac=$mac address=$address;
:foreach x in=[/ip dhcp-server lease find] do={/ip dhcp-server lease make-static $x};
}
### fim Script ############################## ###############
SCRIPT AUTO MAC PARA PPPOE MIKROTIK 3X A CIMA
Código:
############################## ####################
# Nome: AutoMac_PPPoe #
# Objetivo: Capturar IP + Mac do cliente e #
# deixa-lo fixo para que não mude. #
# Agendamento: Use a cada 3 minutos #
############################## ####################
:foreach x in=[/ppp active find] do={
:global address [/ppp active get $x address];
:global user [/ppp active get $x name];
:global mac [/ppp active get $x caller-id];
/ppp secret set $user caller-id=$mac remote-address=$address;
 }
# :foreach h in=[/ppp active find] do={
# :global name [/ppp active get $h value-name=name];
# :global mac [/ppp active get $h value-name=caller-id];
# /ppp secret set $name caller-id=$mac
#}

Erimar
Baby
Baby

Mensagens : 2
Pontos : 2
Reputação : 0
Data de inscrição : 02/01/2012
Idade : 26
Localização Localização : Paracuru-Ce

Voltar ao Topo Ir em baixo

Re: auto cadastro do MAC

Mensagem por ZBTECK em Seg 2 Jan - 18:42

Erimar escreveu:ola eu estou com uma duvida muito grande
pes quero saber se é so copiar e colocar la ?
Não.

Erimar escreveu:ou se tem que configuralo ?
e como eu faço para configurar ele ?
Vá em System > Scripts e clique no +
Em Name coloque o nome do script (AutoMac_PPPoe por exemplo)
Então copie um dos codigos acima citado, o de hotspot ou PPPoE e cole em Source e de Ok.

Depois crie o agendamento em System > Scheduler clicando no +, de um nome, o intervalo de execução (3 minutos por ex) e em On Event coloque o nome do seu script (dado no ítem anterior). Marque todas as Policys e OK.

ZBTECK
Power User
Power User

Mensagens : 930
Pontos : 1117
Reputação : 186
Data de inscrição : 11/04/2011
Idade : 28
Localização Localização : São Paulo

Voltar ao Topo Ir em baixo

Re: auto cadastro do MAC

Mensagem por leodeal em Ter 3 Jan - 16:30

Ola zbteck, Boa tarde.
Ainda ñ conseguir.
Deixa eu passar minha duvidas vamos lá:
Fuiz em SYSTEM > SCRIPTS e cliquei no +

Coloquei o nome - Auto mac

Em OWER: Está admin ** Pode deixar padrão ou colocar outro nome?

Em policy - ** Deixei padrão com todos ativado.

Em SOURCE - Ai está a duvida coloco o codigo todo como está exemplo 1:

############################## ############
# Objetivo: No hotspot ele pega ip + mac #
# do cliente e coloca o ip dele fixo #
# para que o ip do cliente nunca mude #
# com o dhcp. #
# Pesologia: Use a cada 3 MINUTOS #
############################## ############
:foreach h in=[/ip hotspot active find] do={
:global address [/ ip hotspot active get $h address];
:global user [/ip hotspot active get $h user];
:global mac [/ip hotspot active get $h mac-address];
/ip hotspot user set $user mac=$mac address=$address;
:foreach x in=[/ip dhcp-server lease find] do={/ip dhcp-server lease make-static $x};

OU ASSIM

:foreach h in=[/ip hotspot active find] do={
:global address [/ ip hotspot active get $h address];
:global user [/ip hotspot active get $h user];
:global mac [/ip hotspot active get $h mac-address];
/ip hotspot user set $user mac=$mac address=$address;
:foreach x in=[/ip dhcp-server lease find] do={/ip dhcp-server lease make-static $x};

Em SYSTEM > SCHEDULER

EM Nome - auto mac

EM DATE - COLOCO A DO DIA ? OU EM BRANCO?

START TIME- COLOCO A HORA QUE COMECEI A CONFIGURAÇÃO? OU EM BRANCO?

DELAY- COLOCO O QUE?

EM EVENT -- ESSA E OUTRA DUVIDA COLOCO AOS MESMO CÓDIGO DO SOURCE OU SCRIPT AUTO MAC PARA" PPPOE " MIKROTIK 3X A CIMA?
OU
SCRIPT AUTO MAC PARA HOTSPOT PARA" MIKROTIK "3X A CIMA

leodeal
Iniciante
Iniciante

Mensagens : 35
Pontos : 61
Reputação : 0
Data de inscrição : 15/09/2011
Idade : 33
Localização Localização : salvador

Voltar ao Topo Ir em baixo

Re: auto cadastro do MAC

Mensagem por ZBTECK em Ter 3 Jan - 17:42

leodeal escreveu:Coloquei o nome - Auto mac
Procure colocar nomes sem espaço em branco para evitar problemas. Use "_". No caso acima ficaria Auto_mac

leodeal escreveu:Em OWER: Está admin ** Pode deixar padrão ou colocar outro nome?
Deixe padrão.

leodeal escreveu:Em policy - ** Deixei padrão com todos ativado.
Ok

leodeal escreveu:Em SOURCE - [color=red]Ai está a duvida coloco o codigo todo...
Coloque tudo - 1 (recomendável) (ou só o código em si - 2). As linhas iniciadas com # são comentários (não serão executadas). Servem para detalhar o código e seus parâmetros.

leodeal escreveu:Em SYSTEM > SCHEDULER

EM Nome - auto mac
Procure colocar um nome que identifique melhor a operação realizada (Atrela_IP_Mac por ex:)

leodeal escreveu:EM DATE - COLOCO A DO DIA ? OU EM BRANCO?

START TIME- COLOCO A HORA QUE COMECEI A CONFIGURAÇÃO? OU EM BRANCO?

DELAY- COLOCO O QUE?
Neste caso, pode deixar tudo como está "00:00:00". Apenas mude Interval para 00:03:00 (3 minutos como sugerido)

leodeal escreveu:EM EVENT -- ESSA E OUTRA DUVIDA COLOCO AOS MESMO CÓDIGO DO SOURCE OU SCRIPT AUTO MAC PARA" PPPOE " MIKROTIK 3X A CIMA?
Voce deve colocar o nome do script que será executado (Auto mac ou como sugeri Auto_mac).

ZBTECK
Power User
Power User

Mensagens : 930
Pontos : 1117
Reputação : 186
Data de inscrição : 11/04/2011
Idade : 28
Localização Localização : São Paulo

Voltar ao Topo Ir em baixo

Re: auto cadastro do MAC

Mensagem por leodeal em Qua 4 Jan - 6:23

ZBTECk Obrigadão pela ajuda.Funcionando!

leodeal
Iniciante
Iniciante

Mensagens : 35
Pontos : 61
Reputação : 0
Data de inscrição : 15/09/2011
Idade : 33
Localização Localização : salvador

Voltar ao Topo Ir em baixo

Re: auto cadastro do MAC

Mensagem por int21 em Ter 20 Nov - 12:08

A quem postou o script:

Tirar a autoria é no minimo discaração e pedância, tenha a ombridade de dizer que não foi vc quem fez e dê os créditos aquem de direito.

Com isso quem desenvolveu tem mais ânimo pra continuar a ajudar as comunidades.

Link oficial: [Você precisa estar registrado e conectado para ver este link.]

int21
Iniciante
Iniciante

Mensagens : 45
Pontos : 63
Reputação : 12
Data de inscrição : 09/11/2011
Idade : 46
Localização Localização : bahia

http://int21.wordpress.com

Voltar ao Topo Ir em baixo

Re: auto cadastro do MAC

Mensagem por getech informatica em Dom 2 Dez - 11:22

tem q copiar e colar o script fiz mas nao deu certo pode me ajuda ai amigos

getech informatica
Baby
Baby

Mensagens : 8
Pontos : 10
Reputação : 0
Data de inscrição : 17/11/2011
Idade : 35
Localização Localização : vitorino freire

Voltar ao Topo Ir em baixo

Re: auto cadastro do MAC

Mensagem por thiago.al em Sab 28 Jun - 12:15

tem algum scrip que so pegue apenas os mac dos clientes?

thiago.al
Iniciante
Iniciante

Mensagens : 43
Pontos : 69
Reputação : 0
Data de inscrição : 10/01/2012
Idade : 28
Localização Localização : maceió

Voltar ao Topo Ir em baixo

Re: auto cadastro do MAC

Mensagem por thiago.al em Sab 28 Jun - 12:40

para quem ta precisando apenas pegar só o mac dos clientes sem o ip segue o script modificado.

:foreach h in=[/ip hotspot active find] do={
:global address [/ ip hotspot active get $h address];
:global user [/ip hotspot active get $h user];
:global mac [/ip hotspot active get $h mac];
/ip hotspot user set $user mac=$mac
:foreach x in=[/ip dhcp-server lease find] do={/ip dhcp-server lease make-static $x};
}

thiago.al
Iniciante
Iniciante

Mensagens : 43
Pontos : 69
Reputação : 0
Data de inscrição : 10/01/2012
Idade : 28
Localização Localização : maceió

Voltar ao Topo Ir em baixo

Re: auto cadastro do MAC

Mensagem por Conteúdo patrocinado Hoje à(s) 18:59


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Página 2 de 2 Anterior  1, 2

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum