Login

Esqueci minha senha

lateral
Estatísticas
Temos 29301 usuários registrados
O último usuário registrado atende pelo nome de isaiasfreitas

Os nossos membros postaram um total de 37318 mensagens em 5569 assuntos

Script No-IP Nao Atualiza - RESOLVIDO

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Script No-IP Nao Atualiza - RESOLVIDO

Mensagem por Gilmuor em Ter 20 Dez - 13:07

Boa tarde a todos do forum, estou com um probleminha que esta me consumindo, queria saber de voces, se ja se depararam com este problema, preciso que um script no mikrotik atualize constantemente, utilizo o seguinte:

Flags: I - invalid
0 name="Script Cameras" owner="net"
policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,
api
last-started=dec/19/2011 10:47:34 run-count=2
source=
:global ddnsuser "XXXXX@XXX.com"
:global ddnspass "XXX"
:global ddnshost "XXXX.malware-site.www"
:global ddnsinterface "PPPoE - Link"

:global ddnssystem ("mt-" . [/system package get [/system package find na>
ddnsip [ /ip address get [/ip address find interface=$ddnsinterfa>
:global ddnslastip

:if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "D>

:if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.>

:if ([ :typeof $ddnsip ] = "nothing" ) do={

:log info ("DDNS: No ip address present on " . $ddnsinterface . ", please>

} else={

:if ($ddnsip != $ddnslastip) do={

:log info "DDNS: Sending UPDATE!"
:log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddn>
:global ddnslastip $ddnsip

} else={

:log info "DDNS: No changes necessary."

}

}

# END OF SCRIPT

e no Schuduler assim:

/system scheduler
add comment="Atualizar IP DDNS" disabled=no interval=5m name=DDNS on-event=\
"/system script run DDNS" policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
start-date=dec/19/2011 start-time=17:31:44


Última edição por Gilmuor em Sab 31 Dez - 18:09, editado 1 vez(es)

Gilmuor
Baby
Baby

Mensagens : 16
Pontos : 28
Reputação : 0
Data de inscrição : 25/09/2011
Idade : 35
Localização Localização : PERNAMBUCO

Voltar ao Topo Ir em baixo

Re: Script No-IP Nao Atualiza - RESOLVIDO

Mensagem por Gerônimo em Ter 20 Dez - 13:15

ao invez do no-ip se cadastre no [Você precisa estar registrado e conectado para ver este link.] e testa ai

__________________________________________________
A VIDA SO É DIGNA DE SER VIVIDA SE VOCÊ FIZER ALGO PELA VIDA EM VIDA.
MUDE A VIDA DE UMA CRIANÇA APADRINHE COM APENAS R$ 50,00 ACESSE [Você precisa estar registrado e conectado para ver este link.]

Gerônimo
Power User
Power User

Mensagens : 684
Pontos : 1454
Reputação : 722
Data de inscrição : 29/05/2010
Idade : 42
Localização Localização : Brasil

http://www.overnix.com/

Voltar ao Topo Ir em baixo

Re: Script No-IP Nao Atualiza - RESOLVIDO

Mensagem por Gilmuor em Ter 20 Dez - 13:23

Gerônimo escreveu:ao invez do no-ip se cadastre no [Você precisa estar registrado e conectado para ver este link.] e testa ai


Certo, mas o problema que o cliente ja esta usando as cameras, ai toda vez tenho q ficar entrando no site do no-ip para colocar o IP manualmente, outra coisa, este script que estou usando, esta correto vc tem outro q eu possa testar?

Gilmuor
Baby
Baby

Mensagens : 16
Pontos : 28
Reputação : 0
Data de inscrição : 25/09/2011
Idade : 35
Localização Localização : PERNAMBUCO

Voltar ao Topo Ir em baixo

Re: Script No-IP Nao Atualiza - RESOLVIDO

Mensagem por Gerônimo em Ter 20 Dez - 14:04

[Você precisa estar registrado e conectado para ver este link.]

__________________________________________________
A VIDA SO É DIGNA DE SER VIVIDA SE VOCÊ FIZER ALGO PELA VIDA EM VIDA.
MUDE A VIDA DE UMA CRIANÇA APADRINHE COM APENAS R$ 50,00 ACESSE [Você precisa estar registrado e conectado para ver este link.]

Gerônimo
Power User
Power User

Mensagens : 684
Pontos : 1454
Reputação : 722
Data de inscrição : 29/05/2010
Idade : 42
Localização Localização : Brasil

http://www.overnix.com/

Voltar ao Topo Ir em baixo

Re: Script No-IP Nao Atualiza - RESOLVIDO

Mensagem por Gilmuor em Sab 31 Dez - 18:10

Gerônimo escreveu:[Você precisa estar registrado e conectado para ver este link.]

Obrigado Geronimo, feliz ano novo a todos do forum!

Gilmuor
Baby
Baby

Mensagens : 16
Pontos : 28
Reputação : 0
Data de inscrição : 25/09/2011
Idade : 35
Localização Localização : PERNAMBUCO

Voltar ao Topo Ir em baixo

Re: Script No-IP Nao Atualiza - RESOLVIDO

Mensagem por Conteúdo patrocinado Hoje à(s) 22:50


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum