Conectar-se

Esqueci minha senha

lateral
Estatísticas
Temos 30345 usuários registrados
O último usuário registrado atende pelo nome de edjorge

Os nossos membros postaram um total de 37737 mensagens em 5673 assuntos

Roteamento + NAT + Web-server (Ajuda)

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Roteamento + NAT + Web-server (Ajuda)

Mensagem por hoberdan em Sex 23 Dez - 9:36

Bom dia pessoal,

Me deparei com uma situação e estou precisando muito da ajuda da comunidade para resolver.
Tenho um link /29 5 Ips válidos.

Atualmente estou utilizando somente 2 destes ips, ambos configurados na mesma interface (Link1)
Na outra interface (Rede) tenho um ip privado da classe 192.168.090/24 que me serve como gateway da rede interna.
Tenho tambem uma terceira interface (Web-server) com classe 172.18.1.0/24 onde existe somente meu servidor web que responde na porta 80.

Segue minha address list abaixo para melhor entendimento:

address Network Interface

189.91.197.170 189.91.197.168 Link1
189.91.197.171 189.91.197.168 Link1
192.168.0.90 192.168.0.0 Rede
172.18.1.1 172.18.1.0 Web-server


Como configurar o mikrotik para que os clientes da interface Rede (192.168.0.0/24) e da interface Web-server (172.18.1.0/24) possam navegar na internet "somente" pelo IP 189.91.197.170 ?

Como fazer para que as requisições da porta 80 vindas "de fora" (internet) referentes ao ip 189.91.197.171 (dominio do meu site) sejam roteadas para o ip 172.18.1.2 ?

Como fazer para que as requisições vindas da Rede (192.168.0.0/24) para o IP 189.91.197.171 (dominio do meu site) sejam direcionadas direto para o ip 172.18.1.2 da interface Web-server ?


Agradeço muito se alguem puder me ajudar.

hoberdan
Baby
Baby

Mensagens : 15
Pontos : 23
Reputação : 2
Data de inscrição : 23/12/2011
Idade : 26
Localização Localização : SC

Voltar ao Topo Ir em baixo

Re: Roteamento + NAT + Web-server (Ajuda)

Mensagem por hammer em Sex 23 Dez - 10:00

Bem amigo, para acesso entre as redes 192 e 172 não precisa de nat, apenas rota. como ambas são no mesmo server não precisa

Redirect
/ip firewall nat
add action=dst-nat chain=dstnat comment="Acesso Externo Webserver" \
disabled=no dst-port=80 protocol=tcp to-addresses=172.18.1.2 to-ports=80

Agora o NAT, amigo, O que eu pensei, foi você criar uma bridge com a interface do Link1 e adicionar este ip na bridge e coloca-lo como seu NAT.

Creio que vai resolver.

hammer
User
User

Mensagens : 170
Pontos : 222
Reputação : 38
Data de inscrição : 27/04/2011
Idade : 42
Localização Localização : BSB

Voltar ao Topo Ir em baixo

Re: Roteamento + NAT + Web-server (Ajuda)

Mensagem por hoberdan em Sex 23 Dez - 10:14

Obrigado pela ajuda hammer, como ficariam as rotas nesse caso ? Tentei criar da seguinte maneira:

Dst. Address Gateway
192.168.0.0/0 189.91.197.170

Mas a navegação não funciona pois o gateway é 189.91.197.169
Se configurar conforme abaixo:

Dst. Address Gateway
0.0.0.0/0 189.91.197.169

A navegação sai tanto pelo IP 189.91.197.170 quanto pelo 189.91.197.171 o que eu não quero que aconteça.

Uso web-proxy isso pode influênciar ?



hoberdan
Baby
Baby

Mensagens : 15
Pontos : 23
Reputação : 2
Data de inscrição : 23/12/2011
Idade : 26
Localização Localização : SC

Voltar ao Topo Ir em baixo

Re: Roteamento + NAT + Web-server (Ajuda)

Mensagem por hammer em Sex 23 Dez - 10:17

Vamos lá, você não vai precisar de rotas, pois isso, já é padrão, por você estar na mesma rede.
Para a Navegação, faz como eu te falei, cria uma bridge, e coloca este ip na bridge, e informa esta interface na regra do NAT.
E para acesso externo é apenas isso.

hammer
User
User

Mensagens : 170
Pontos : 222
Reputação : 38
Data de inscrição : 27/04/2011
Idade : 42
Localização Localização : BSB

Voltar ao Topo Ir em baixo

Re: Roteamento + NAT + Web-server (Ajuda)

Mensagem por hoberdan em Sex 23 Dez - 10:45

Obrigado mais uma vez, desculpa minha ignorância.. mas nunca trabalhei com bridge e não conheço seu funcionamento.. Como devo proceder para criar essa regra conforme sugeriu ?

Muito agradecido se puder me auxiliar.

hoberdan
Baby
Baby

Mensagens : 15
Pontos : 23
Reputação : 2
Data de inscrição : 23/12/2011
Idade : 26
Localização Localização : SC

Voltar ao Topo Ir em baixo

Re: Roteamento + NAT + Web-server (Ajuda)

Mensagem por hammer em Sex 23 Dez - 10:50

Bem, vai em bridge, e clica em criar no mais. depois de criada, vai em ports e add a interface Link1
Depois de feito isso, basta adicionar o IP como de costume.

hammer
User
User

Mensagens : 170
Pontos : 222
Reputação : 38
Data de inscrição : 27/04/2011
Idade : 42
Localização Localização : BSB

Voltar ao Topo Ir em baixo

Re: Roteamento + NAT + Web-server (Ajuda)

Mensagem por hoberdan em Sex 23 Dez - 14:52

Novamente muito obrigado hammer, consegui criar a bridge conforme me instruiu, mas a navegação continua pelos dois ips.

Coloquei na Bridge o Ip do Site 189.91.197.171

Nat está assim:

/ip firewall nat
add action=masquerade chain=srcnat \
Src.Address=192.168.0.0/24 out.Interface= Link1 \
comment="Mascaramento da rede" disabled=no

add action=masquerade chain=srcnat \
Src.Address=172.18.1.0/24 out.Interface= Link1 \
comment="Mascaramento da rede" disabled=no

Obs.: No meu entendimento as duas regras acima permitem acesso a internet através da interface Link1 que está com ip 189.91.197.170 Certo ?

add action=redirect chain=dstnat comment="Navegação para proxy" \
disabled=no dst-port=80 protocol=tcp Src.Address=192.168.0.0/24 \
In.Interface=Rede to-ports=3128

add action=redirect chain=dstnat comment="Navegação para proxy" \
disabled=no dst-port=80 protocol=tcp Src.Address=172.18.1.0/24 \
In.Interface=Web-server to-ports=3128

Obs.: Duas regras acima direcionam a navegação das redes 192 e 172 para a porta 3128 que é do web-proxy.

Está correto o jeito que estou fazendo ?

add action=dst-nat chain=dstnat comment="Acesso Externo Webserver" \
disabled=no dst-port=80 protocol=tcp to-addresses=172.18.1.2 \
to-ports=80

Obs.: Regra acima permite acesso a página de fora está funcionando corretamente

E para fazer com que as requisições vindas da interface Rede (192.168.0.0/24) com destino a meu site (189.91.197.171) sejam encaminhadas direto para o ip 172.18.1.2 da interface Web-server, para que não seja necessário acessar a internet ?

hoberdan
Baby
Baby

Mensagens : 15
Pontos : 23
Reputação : 2
Data de inscrição : 23/12/2011
Idade : 26
Localização Localização : SC

Voltar ao Topo Ir em baixo

Re: Roteamento + NAT + Web-server (Ajuda)

Mensagem por hammer em Sex 23 Dez - 14:53

Não amigo em out.Interface vc tem que colocar a Interface da bridge.

E na bridge vc tem que colocar este IP 189.91.197.170 e tirar do Link1

Amigo, quem está na sua rede 192. tem que acessar seu site, pelo ip, 172. não pelo ip da internet.

hammer
User
User

Mensagens : 170
Pontos : 222
Reputação : 38
Data de inscrição : 27/04/2011
Idade : 42
Localização Localização : BSB

Voltar ao Topo Ir em baixo

Re: Roteamento + NAT + Web-server (Ajuda)

Mensagem por hoberdan em Sex 23 Dez - 15:00

Certo, Na bridge eu coloco o Ip que quero usar para navegar e mascared as redes 192 e 178 por ele. Isso fara com que o ip 189.91.197.171 não seja usado para navegar ?

Link1 eu mantenho somente o Ip do Site é isso ?

hoberdan
Baby
Baby

Mensagens : 15
Pontos : 23
Reputação : 2
Data de inscrição : 23/12/2011
Idade : 26
Localização Localização : SC

Voltar ao Topo Ir em baixo

Re: Roteamento + NAT + Web-server (Ajuda)

Mensagem por hammer em Sex 23 Dez - 15:16

Sim, isso mesmo, deixe em Link1 apenas o ip para acesso página web
E coloque o IP do NAT em bridge

hammer
User
User

Mensagens : 170
Pontos : 222
Reputação : 38
Data de inscrição : 27/04/2011
Idade : 42
Localização Localização : BSB

Voltar ao Topo Ir em baixo

Re: Roteamento + NAT + Web-server (Ajuda)

Mensagem por hammer em Sex 23 Dez - 16:12

Deu certo amigo?

hammer
User
User

Mensagens : 170
Pontos : 222
Reputação : 38
Data de inscrição : 27/04/2011
Idade : 42
Localização Localização : BSB

Voltar ao Topo Ir em baixo

Re: Roteamento + NAT + Web-server (Ajuda)

Mensagem por hoberdan em Sex 23 Dez - 17:38

Muitissimo obrigado Hammer..

Consegui fazer com que a navegação saia pela Bridge com o ip desejado (189.91.197.170)

Se eu desativar a bridge, a navegação sai novamente pelo ip 189.91.197.171 o que eu não queria, tem como bloquear isso ?

Outra divergência, quando a bridge está ativa, as regras de bloqueio do web-proxy não funcionam como resolver isso ?

hoberdan
Baby
Baby

Mensagens : 15
Pontos : 23
Reputação : 2
Data de inscrição : 23/12/2011
Idade : 26
Localização Localização : SC

Voltar ao Topo Ir em baixo

Re: Roteamento + NAT + Web-server (Ajuda)

Mensagem por hoberdan em Sex 23 Dez - 17:40

Aparentemente o proxy está bloqueando somente o acesso ao dominio do meu site..ou seja o Ip da interface Link1

hoberdan
Baby
Baby

Mensagens : 15
Pontos : 23
Reputação : 2
Data de inscrição : 23/12/2011
Idade : 26
Localização Localização : SC

Voltar ao Topo Ir em baixo

Re: Roteamento + NAT + Web-server (Ajuda)

Mensagem por hammer em Sex 23 Dez - 18:29

Amigo, teria como me enviar as suas regras para eu poder dar uma olhada?
Se quando você desabilita a bridge, será que você não tem outra regra de NAT. ou as vezes, a regra pode assimir o ip da interface da bridge. Não sei ao certo.

Te passei meu contato em MP.

Amigo, posso te dar uma opnião, no seu caso, eu colocaria um Firewall de borda.
Colocaria este IP 170, como IP do meu firewall. fazendo NAT.
E faria um NAT 1:1 do outro ip apontando para a sua DMZ.
Isso é o que eu faria.
Deixaria seu mikrotik, apenas como concetrador.

hammer
User
User

Mensagens : 170
Pontos : 222
Reputação : 38
Data de inscrição : 27/04/2011
Idade : 42
Localização Localização : BSB

Voltar ao Topo Ir em baixo

Re: Roteamento + NAT + Web-server (Ajuda)

Mensagem por hoberdan em Sab 24 Dez - 13:04

Graças a boa vontade e paciência do colega hammer, conseguimos acertar as configurações e ajustar tudo conforme a necessidade..

Muito agradecido a você hammer.

Um forte abraço e Feliz Natal.

hoberdan
Baby
Baby

Mensagens : 15
Pontos : 23
Reputação : 2
Data de inscrição : 23/12/2011
Idade : 26
Localização Localização : SC

Voltar ao Topo Ir em baixo

Re: Roteamento + NAT + Web-server (Ajuda)

Mensagem por hammer em Sab 24 Dez - 18:47

Obrigado amigo, e pode contar sempre que precisar.

hammer
User
User

Mensagens : 170
Pontos : 222
Reputação : 38
Data de inscrição : 27/04/2011
Idade : 42
Localização Localização : BSB

Voltar ao Topo Ir em baixo

Re: Roteamento + NAT + Web-server (Ajuda)

Mensagem por hammer em Sab 24 Dez - 20:15

Amigo, Marca os post como RESOLVIDO

hammer
User
User

Mensagens : 170
Pontos : 222
Reputação : 38
Data de inscrição : 27/04/2011
Idade : 42
Localização Localização : BSB

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum