Login

Esqueci minha senha

lateral
Estatísticas
Temos 29312 usuários registrados
O último usuário registrado atende pelo nome de adriano.galvao

Os nossos membros postaram um total de 37322 mensagens em 5571 assuntos

Melhorar meu serviço Youtube

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Melhorar meu serviço Youtube

Mensagem por aferreira em Qui 10 Mar - 20:11

Pessoal eestou tentando implantar as regras na baixo com finalidade me melhor o serviço do youtube e depois adaptalas para o orkut.

Minha duvidas são as seguintes:

*Com relação ao cacheFull ela ficariam em que ordem de prioridade? Acima ou abaixo?
*Eu uso o thunder 3.1 postado pelo Mauro, depois que testei a regra os videos parece que deixaram de ser cacheado no proxy.

Aos cologas mais experiantes poderiam dar alguma dica.

/ip firewall mangle

add action=mark-connection chain=output comment="MARCA-CONN-YOUTUBE" content=youtube.com disabled=no new-connection-mark=YOUTUBE passthrough=yes

add action=mark-packet chain=output comment="MARCA-PKT-YOUTUBE" connection-mark=YOUTUBE disabled=no new-packet-mark=YOUTUBE-PCKT passthrough=yes

/queue tree

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=1M name=YOUTUBE packet-mark=YOUTUBE-PCKT parent=global-out priority=8 queue=default

aferreira
Iniciante
Iniciante

Mensagens : 64
Pontos : 86
Reputação : 1
Data de inscrição : 27/12/2010

Voltar ao Topo Ir em baixo

Re: Melhorar meu serviço Youtube

Mensagem por dsdigital em Qui 10 Mar - 20:42

se nao min engona e regra de cache full nao de thunder parcero desabilita para ver

__________________________________________________
VocÊ Ja Penso e Ter Servidor DNS. Pro seu próprio provedor?

Acompanha configuração de Servidores.

Mikrotik. Ppoe hospot. Etc.

Verdadeiro load balance pcc Com apenas nat No balance. E rotas sumarizadas.

Servidor multimídia.

Servidor dns unbound você Com seu próprio servidor DNS. Economizando Que cliente Busque Fora da Rede. o Dns.

Contato: [Você precisa estar registrado e conectado para ver este link.]

dsdigital
Power User
Power User

Mensagens : 862
Pontos : 1129
Reputação : 154
Data de inscrição : 27/11/2010
Idade : 24
Localização Localização : ?

Voltar ao Topo Ir em baixo

Re: Melhorar meu serviço Youtube

Mensagem por aferreira em Qui 10 Mar - 21:50

Você não entendeu, as regras ate funcionam, porém parecem não passar pelo ThunderCache.

E com relação ao mangle as regras de prioridade ficariam acima ou abaixo do cache full?

aferreira
Iniciante
Iniciante

Mensagens : 64
Pontos : 86
Reputação : 1
Data de inscrição : 27/12/2010

Voltar ao Topo Ir em baixo

Re: Melhorar meu serviço Youtube

Mensagem por dsdigital em Qui 10 Mar - 22:42

a do thunder primeiro

__________________________________________________
VocÊ Ja Penso e Ter Servidor DNS. Pro seu próprio provedor?

Acompanha configuração de Servidores.

Mikrotik. Ppoe hospot. Etc.

Verdadeiro load balance pcc Com apenas nat No balance. E rotas sumarizadas.

Servidor multimídia.

Servidor dns unbound você Com seu próprio servidor DNS. Economizando Que cliente Busque Fora da Rede. o Dns.

Contato: [Você precisa estar registrado e conectado para ver este link.]

dsdigital
Power User
Power User

Mensagens : 862
Pontos : 1129
Reputação : 154
Data de inscrição : 27/11/2010
Idade : 24
Localização Localização : ?

Voltar ao Topo Ir em baixo

Re: Melhorar meu serviço Youtube

Mensagem por aferreira em Sex 11 Mar - 11:48

Blz vou implatar e observar os resultados

aferreira
Iniciante
Iniciante

Mensagens : 64
Pontos : 86
Reputação : 1
Data de inscrição : 27/12/2010

Voltar ao Topo Ir em baixo

Re: Melhorar meu serviço Youtube

Mensagem por aferreira em Qua 23 Mar - 23:15

Código:
/ ip firewall mangle

add chain=prerouting protocol=tcp connection-bytes=1-5120000 dst-address-list=Youtube action=mark-connection \
new-connection-mark=Youtube passthrough=yes comment="Youtube" disabled=no
add chain=prerouting connection-mark=Youtube action=mark-packet new-packet-mark=Youtube passthrough=yes comment="" \
disabled=no

/ queue tree
add name="Youtube" parent=global-out packet-mark=Youtube limit-at=0 queue=pcq-download priority=8 max-limit=3000000 \
burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes

/ ip firewall mangle

add chain=prerouting in-interface=Local protocol=tcp dst-port=80 \
content=youtube action=add-dst-to-address-list address-list=Youtube \
address-list-timeout=4w2d comment="Youtube" disabled=no

Implantei estas regras postadas pelo Luiz na MK Brasil, e funcionam melhor que as minhas, porém o problema é o mesmo. Eles deixam de sair full pelo Thunder.
Coloquei um topico para o Luiz e ele me disse que para o cliente usar a regra e depois acessar o mesmo videos e sair Full pelo Thunder terei que adicionar nas regras de marcação na mangle do youtube(Squid-Connection) a exeção das conexões que vem do cache Thunder.

Tentei, tentei e nada... To precisando de uma ajuda

aferreira
Iniciante
Iniciante

Mensagens : 64
Pontos : 86
Reputação : 1
Data de inscrição : 27/12/2010

Voltar ao Topo Ir em baixo

Re: Melhorar meu serviço Youtube

Mensagem por dsdigital em Qui 24 Mar - 9:23

vc tem thunder o importaten e regas do thunder e do squid que marca a velocidade que vai sair os arquivo remova a regra e deixe so do squid thunder.

__________________________________________________
VocÊ Ja Penso e Ter Servidor DNS. Pro seu próprio provedor?

Acompanha configuração de Servidores.

Mikrotik. Ppoe hospot. Etc.

Verdadeiro load balance pcc Com apenas nat No balance. E rotas sumarizadas.

Servidor multimídia.

Servidor dns unbound você Com seu próprio servidor DNS. Economizando Que cliente Busque Fora da Rede. o Dns.

Contato: [Você precisa estar registrado e conectado para ver este link.]

dsdigital
Power User
Power User

Mensagens : 862
Pontos : 1129
Reputação : 154
Data de inscrição : 27/11/2010
Idade : 24
Localização Localização : ?

Voltar ao Topo Ir em baixo

Re: Melhorar meu serviço Youtube

Mensagem por aferreira em Qui 24 Mar - 10:09

Código:
/ip firewall mangle

add action=mark-connection chain=postrouting comment="THUNDER CACHE FULL =====\
==========================================================================\
=======================" content="X-Cache: HIT from Thunder" disabled=no \
new-connection-mark=thunder-connection passthrough=yes protocol=tcp \
src-address=192.150.10.2
add action=mark-packet chain=postrouting comment="" connection-mark=\
thunder-connection disabled=no new-packet-mark=thunder-packs passthrough=\
yes
add action=mark-connection chain=postrouting comment="TOS 12==================\
==========================================================================\
=========================" disabled=no dscp=12 new-connection-mark=\
proxy-hits passthrough=yes protocol=tcp src-address=192.150.10.2
add action=mark-packet chain=postrouting comment="" connection-mark=\
proxy-hits disabled=no new-packet-mark=proxy-squid passthrough=yes

/queue tree

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=8M name="T -cache_hits" packet-mark=proxy-squid parent=\
global-out priority=4 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=8M name=ThunderCache packet-mark=thunder-packs parent=\
global-out priority=4 queue=default
[/code]

Neste caso você refere-se as regras da / queue tree ou da /mangle?

Pois estas são as refra do meu ThunderFull extraidas daqui mesmo do forum

aferreira
Iniciante
Iniciante

Mensagens : 64
Pontos : 86
Reputação : 1
Data de inscrição : 27/12/2010

Voltar ao Topo Ir em baixo

Re: Melhorar meu serviço Youtube

Mensagem por dsdigital em Seg 4 Abr - 19:41

rapaz vc so vai deixa do thunder entendeu

__________________________________________________
VocÊ Ja Penso e Ter Servidor DNS. Pro seu próprio provedor?

Acompanha configuração de Servidores.

Mikrotik. Ppoe hospot. Etc.

Verdadeiro load balance pcc Com apenas nat No balance. E rotas sumarizadas.

Servidor multimídia.

Servidor dns unbound você Com seu próprio servidor DNS. Economizando Que cliente Busque Fora da Rede. o Dns.

Contato: [Você precisa estar registrado e conectado para ver este link.]

dsdigital
Power User
Power User

Mensagens : 862
Pontos : 1129
Reputação : 154
Data de inscrição : 27/11/2010
Idade : 24
Localização Localização : ?

Voltar ao Topo Ir em baixo

Re: Melhorar meu serviço Youtube

Mensagem por Gerônimo em Seg 4 Abr - 20:08

Amigo tenta estas regras e posta op resultado ok
Código:
 /ip firewall mangle
add action=mark-connection chain=postrouting comment=\
    "Proxy - Linux Squid Full - Marca Conexao - X-Cache MK3.xx" content=\
    "X-Cache: HIT" disabled=no new-connection-mark=Linux_X-Cache_Conn-HIT \
    passthrough=yes protocol=tcp src-address=192.150.10.2 src-port=5128
add action=mark-packet chain=postrouting comment="" connection-mark=\
    Linux_X-Cache_Conn-HIT disabled=no new-packet-mark=\
    Linux_X-Cache-Packet-HIT passthrough=yes
add action=mark-connection chain=postrouting comment=\
    "Proxy - Linux Squid Full - Marca Conexao - DSCP MK3.xx" disabled=no \
    dscp=12 new-connection-mark=Linux_DSCP_Conn-HIT passthrough=yes
add action=mark-packet chain=postrouting comment="" connection-mark=\
    Linux_DSCP_Conn-HIT disabled=no new-packet-mark=Linux_DSCP-Packet-HIT \
    passthrough=yes
add action=mark-connection chain=postrouting comment="Thunder Cache" \
    content="X-Cache: HIT from Thunder" disabled=no new-connection-mark=\
    LinuxThunder-Conn-HIT passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting comment="" connection-mark=\
    LinuxThunder-Conn-HIT disabled=no new-packet-mark=\
    LinuxThunder-Packet-HIT passthrough=yes
add action=mark-connection chain=postrouting comment="Thunder Cache" \
    disabled=no dst-address=192.150.10.2 dst-port=80 new-connection-mark=\
    LinuxThunderWeb-Conn-HIT passthrough=yes protocol=tcp
add action=mark-packet chain=postrouting comment="" connection-mark=\
    LinuxThunderWeb-Conn-HIT disabled=no new-packet-mark=\
    LinuxThunderWeb-Packet-HIT passthrough=yes protocol=tcp


/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=5M name=Tc3.1 packet-mark="Linux_X-Cache-Packet-HIT,Linux_DSC\
    P-Packet-HIT,LinuxThunder-Packet-HIT,LinuxThunderWeb-Packet-HIT" \
    parent=global-out priority=4 queue=default


/ip firewall filter
add action=accept chain=forward comment="Aceita thunder" disabled=no \
    src-address=192.150.10.0/30

So adequar as suas necessidades

__________________________________________________
A VIDA SO É DIGNA DE SER VIVIDA SE VOCÊ FIZER ALGO PELA VIDA EM VIDA.
MUDE A VIDA DE UMA CRIANÇA APADRINHE COM APENAS R$ 50,00 ACESSE [Você precisa estar registrado e conectado para ver este link.]

Gerônimo
Power User
Power User

Mensagens : 684
Pontos : 1454
Reputação : 722
Data de inscrição : 29/05/2010
Idade : 42
Localização Localização : Brasil

http://www.overnix.com/

Voltar ao Topo Ir em baixo

Re: Melhorar meu serviço Youtube

Mensagem por Conteúdo patrocinado Hoje à(s) 15:26


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum