Login

Esqueci minha senha

lateral
Estatísticas
Temos 29294 usuários registrados
O último usuário registrado atende pelo nome de gilbertocb

Os nossos membros postaram um total de 37317 mensagens em 5569 assuntos

[Resolvido]Não consigo acessar remotamente o Load Ballance

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

[Resolvido]Não consigo acessar remotamente o Load Ballance

Mensagem por floris em Ter 7 Fev - 9:17

Ontem (06/02/12), deixei me ballance funcionando e até agora as mil maravilhas, fiz o redirecionamento para o meu servidor pela porta 4040 e ele eu consigo acessar, mas a RB que roda o load ballance não estou conseguindo.

No meu load só tenho uma regra de redirecionamento que é a que está funcionando para o servidor, será que preciso criar outra regra no próprio load ballance para acessar ele mesmo remotamente.

----------------

Simplificando:

Servidor: infonet-ac.ddns.mobi:4040, eu consigo acessar

Load Ballance: infonet-ac.ddns.mobi, não consigo

Alguém tem a dica?

floris
Advance user
Advance user

Mensagens : 302
Pontos : 459
Reputação : 69
Data de inscrição : 30/12/2010
Idade : 34
Localização Localização : Salvador

Voltar ao Topo Ir em baixo

Re: [Resolvido]Não consigo acessar remotamente o Load Ballance

Mensagem por cristiano.micros em Ter 7 Fev - 10:04

o script ddns está configurado no balance ou no servidor de altenticação ?

__________________________________________________
A cópia é um dos métodos de aprendizado mas quem só copia não aprende study

Trevizam Network Consultoria

Parceiro BM Software | Consultoria e Revenda Thundercache PRO

visite nossa pagina [Você precisa estar registrado e conectado para ver este link.]

[Você precisa estar registrado e conectado para ver este link.]

[Você precisa estar registrado e conectado para ver este link.]

11 96380-8759 (VIVO) 11 98606-5675 (TIM)

cristiano.micros
Power User
Power User

Mensagens : 1185
Pontos : 1440
Reputação : 233
Data de inscrição : 27/11/2010
Idade : 27
Localização Localização : suzano

http://www.trevizamnetwork.com.br

Voltar ao Topo Ir em baixo

Re: [Resolvido]Não consigo acessar remotamente o Load Ballance

Mensagem por floris em Ter 7 Fev - 10:10

cristiano.micros escreveu:o script ddns está configurado no balance ou no servidor de altenticação ?

Mas são dois links dedicados e 2ADSLs

Estou tentando através dos IPs: 187.12.6.42 e 187.12.6.226 (que são fixos / dedicados), mas mesmo assim teria que ter script? Lembrando que para acessar o meu servidor eu consigo.

floris
Advance user
Advance user

Mensagens : 302
Pontos : 459
Reputação : 69
Data de inscrição : 30/12/2010
Idade : 34
Localização Localização : Salvador

Voltar ao Topo Ir em baixo

Re: [Resolvido]Não consigo acessar remotamente o Load Ballance

Mensagem por cristiano.micros em Ter 7 Fev - 10:16

ata
como vc ta fazendo a regra de dstnat para o outro servidor posta pra poder analizar

__________________________________________________
A cópia é um dos métodos de aprendizado mas quem só copia não aprende study

Trevizam Network Consultoria

Parceiro BM Software | Consultoria e Revenda Thundercache PRO

visite nossa pagina [Você precisa estar registrado e conectado para ver este link.]

[Você precisa estar registrado e conectado para ver este link.]

[Você precisa estar registrado e conectado para ver este link.]

11 96380-8759 (VIVO) 11 98606-5675 (TIM)

cristiano.micros
Power User
Power User

Mensagens : 1185
Pontos : 1440
Reputação : 233
Data de inscrição : 27/11/2010
Idade : 27
Localização Localização : suzano

http://www.trevizamnetwork.com.br

Voltar ao Topo Ir em baixo

Re: [Resolvido]Não consigo acessar remotamente o Load Ballance

Mensagem por floris em Ter 7 Fev - 14:21

cristiano.micros escreveu:ata
como vc ta fazendo a regra de dstnat para o outro servidor posta pra poder analizar
Código:
/ip firewall mangle
add action=accept chain=prerouting comment=\
   

------------------------------------------------------------

-------- \
    disabled=no dst-address=192.168.88.0/30 src-

address=192.168.88.0/30
add action=accept chain=prerouting disabled=no dst-

address=187.12.6.32/28 \
    src-address=192.168.88.0/30
add action=accept chain=prerouting disabled=no dst-

address=187.12.6.224/28 \
    src-address=192.168.88.0/30
add action=mark-connection chain=prerouting comment=\
   

------------------------------------------------------

-------- \
    connection-mark=no-mark disabled=no in-interface=pppoe-

out1 \
    new-connection-mark=ADSL1_conn passthrough=yes
add action=mark-connection chain=prerouting connection-

mark=no-mark disabled=\
    no in-interface=pppoe-out2 new-connection-

mark=ADSL2_conn passthrough=yes
add action=mark-connection chain=prerouting connection-

mark=no-mark disabled=\
    no in-interface=LD1 new-connection-mark=LD1_conn

passthrough=yes
add action=mark-connection chain=prerouting connection-

mark=no-mark disabled=\
    no in-interface=LD2 new-connection-mark=LD2_conn

passthrough=yes
add action=jump chain=prerouting comment=\
   

------------------------------------------------------------

-------- \
    connection-mark=no-mark disabled=no in-interface=Local

jump-target=\
    policy_router
add action=mark-routing chain=prerouting comment=\
   

------------------------------------------------------------

-------- \
    connection-mark=ADSL1_conn disabled=no new-routing-

mark=ADSL1_trafic \
    passthrough=yes src-address=192.168.88.0/30
add action=mark-routing chain=prerouting connection-

mark=ADSL2_conn disabled=\
    no new-routing-mark=ADSL2_trafic passthrough=yes src-

address=\
    192.168.88.0/30
add action=mark-routing chain=prerouting connection-

mark=LD1_conn disabled=no \
    new-routing-mark=LD1_trafic passthrough=yes src-

address=192.168.88.0/30
add action=mark-routing chain=prerouting connection-

mark=LD2_conn disabled=no \
    new-routing-mark=LD2_trafic passthrough=yes src-

address=192.168.88.0/30
add action=mark-routing chain=output comment=\
   

------------------------------------------------------------

-------- \
    connection-mark=ADSL1_conn disabled=no new-routing-

mark=ADSL1_trafic \
    passthrough=yes
add action=mark-routing chain=output connection-

mark=ADSL2_conn disabled=no \
    new-routing-mark=ADSL2_trafic passthrough=yes
add action=mark-routing chain=output connection-

mark=LD1_conn \
    connection-state=new disabled=no new-routing-

mark=LD1_trafic passthrough=\
    yes
add action=mark-routing chain=output connection-

mark=LD2_conn \
    connection-state=new disabled=no new-routing-

mark=LD2_trafic passthrough=\
    yes
add action=mark-connection chain=policy_router comment=\
   

------------------------------------------------------------

-------- \
    disabled=no dst-address-type=!local new-connection-

mark=ADSL1_conn \
    passthrough=yes per-connection-classifier=both-

addresses:4/0
add action=mark-connection chain=policy_router disabled=no

dst-address-type=\
    !local new-connection-mark=ADSL2_conn passthrough=yes \
    per-connection-classifier=both-addresses:4/1
add action=mark-connection chain=policy_router disabled=no

dst-address-type=\
    !local new-connection-mark=LD1_conn passthrough=yes \
    per-connection-classifier=both-addresses:4/2
add action=mark-connection chain=policy_router disabled=no

dst-address-type=\
    !local new-connection-mark=LD2_conn passthrough=yes \
    per-connection-classifier=both-addresses:4/3
/ip firewall nat
add action=masquerade chain=srcnat disabled=no out-

interface=pppoe-out1
add action=masquerade chain=srcnat disabled=no out-

interface=pppoe-out2
add action=masquerade chain=srcnat disabled=no out-

interface=LD1
add action=masquerade chain=srcnat disabled=no out-

interface=LD2
add action=dst-nat chain=dstnat comment="redirect servidor"

disabled=no \
    dst-port=4040 protocol=tcp to-addresses=192.168.88.2

to-ports=8291
ip route
add disabled=no distance=1 dst-address=0.0.0.0/0

gateway=pppoe-out1 \
    routing-mark=ADSL1_trafic scope=30 target-scope=10
add disabled=no distance=1 dst-address=0.0.0.0/0

gateway=pppoe-out2 \
    routing-mark=ADSL2_trafic scope=30 target-scope=10
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=LD2

routing-mark=\
    LD2_trafic scope=30 target-scope=10
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=LD1

routing-mark=\
    LD1_trafic scope=30 target-scope=10
add disabled=no distance=2 dst-address=0.0.0.0/0

gateway=pppoe-out1 scope=30 \
    target-scope=10
add disabled=no distance=3 dst-address=0.0.0.0/0

gateway=pppoe-out2 scope=30 \
    target-scope=10
add disabled=no distance=4 dst-address=0.0.0.0/0 gateway=LD1

scope=30 \
    target-scope=10
add disabled=no distance=5 dst-address=0.0.0.0/0 gateway=LD2

scope=30 \
    target-scope=10

/ip firewall connection tracking
set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-

close-timeout=10s \
    tcp-close-wait-timeout=10s tcp-established-timeout=1d \
    tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s \
    tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s

tcp-syncookie=no \
    tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-

timeout=10s
/ip firewall mangle
add action=accept chain=prerouting comment=\
   

------------------------------------------------------------

-------- \
    disabled=no dst-address=192.168.88.0/30 src-

address=192.168.88.0/30
add action=accept chain=prerouting disabled=no dst-

address=187.12.6.32/28 \
    src-address=192.168.88.0/30
add action=accept chain=prerouting disabled=no dst-

address=187.12.6.224/28 \
    src-address=192.168.88.0/30
add action=mark-connection chain=prerouting comment=\
   

------------------------------------------------------------

-------- \
    connection-mark=no-mark disabled=no in-interface=pppoe-

out1 \
    new-connection-mark=ADSL1_conn passthrough=yes
add action=mark-connection chain=prerouting connection-

mark=no-mark disabled=\
    no in-interface=pppoe-out2 new-connection-

mark=ADSL2_conn passthrough=yes
add action=mark-connection chain=prerouting connection-

mark=no-mark disabled=\
    no in-interface=LD1 new-connection-mark=LD1_conn

passthrough=yes
add action=mark-connection chain=prerouting connection-

mark=no-mark disabled=\
    no in-interface=LD2 new-connection-mark=LD2_conn

passthrough=yes
add action=jump chain=prerouting comment=\
   

------------------------------------------------------------

-------- \
    connection-mark=no-mark disabled=no in-interface=Local

jump-target=\
    policy_router
add action=mark-routing chain=prerouting comment=\
   

------------------------------------------------------------

-------- \
    connection-mark=ADSL1_conn disabled=no new-routing-

mark=ADSL1_trafic \
    passthrough=yes src-address=192.168.88.0/30
add action=mark-routing chain=prerouting connection-

mark=ADSL2_conn disabled=\
    no new-routing-mark=ADSL2_trafic passthrough=yes src-

address=\
    192.168.88.0/30
add action=mark-routing chain=prerouting connection-

mark=LD1_conn disabled=no \
    new-routing-mark=LD1_trafic passthrough=yes src-

address=192.168.88.0/30
add action=mark-routing chain=prerouting connection-

mark=LD2_conn disabled=no \
    new-routing-mark=LD2_trafic passthrough=yes src-

address=192.168.88.0/30
add action=mark-routing chain=output comment=\
   

------------------------------------------------------------

-------- \
    connection-mark=ADSL1_conn disabled=no new-routing-

mark=ADSL1_trafic \
    passthrough=yes
add action=mark-routing chain=output connection-

mark=ADSL2_conn disabled=no \
    new-routing-mark=ADSL2_trafic passthrough=yes
add action=mark-routing chain=output connection-

mark=LD1_conn \
    connection-state=new disabled=no new-routing-

mark=LD1_trafic passthrough=\
    yes
add action=mark-routing chain=output connection-

mark=LD2_conn \
    connection-state=new disabled=no new-routing-

mark=LD2_trafic passthrough=\
    yes
add action=mark-connection chain=policy_router comment=\
   

------------------------------------------------------------

-------- \
    disabled=no dst-address-type=!local new-connection-

mark=ADSL1_conn \
    passthrough=yes per-connection-classifier=both-

addresses:4/0
add action=mark-connection chain=policy_router disabled=no

dst-address-type=\
    !local new-connection-mark=ADSL2_conn passthrough=yes \
    per-connection-classifier=both-addresses:4/1
add action=mark-connection chain=policy_router disabled=no

dst-address-type=\
    !local new-connection-mark=LD1_conn passthrough=yes \
    per-connection-classifier=both-addresses:4/2
add action=mark-connection chain=policy_router disabled=no

dst-address-type=\
    !local new-connection-mark=LD2_conn passthrough=yes \
    per-connection-classifier=both-addresses:4/3
/ip firewall nat
add action=masquerade chain=srcnat disabled=no out-

interface=pppoe-out1
add action=masquerade chain=srcnat disabled=no out-

interface=pppoe-out2
add action=masquerade chain=srcnat disabled=no out-

interface=LD1
add action=masquerade chain=srcnat disabled=no out-

interface=LD2
add action=dst-nat chain=dstnat comment="redirect servidor"

disabled=no \
    dst-port=4040 protocol=tcp to-addresses=192.168.88.2

to-ports=8291

/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0

gateway=pppoe-out1 \
    routing-mark=ADSL1_trafic scope=30 target-scope=10
add disabled=no distance=1 dst-address=0.0.0.0/0

gateway=pppoe-out2 \
    routing-mark=ADSL2_trafic scope=30 target-scope=10
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=LD2

routing-mark=\
    LD2_trafic scope=30 target-scope=10
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=LD1

routing-mark=\
    LD1_trafic scope=30 target-scope=10
add disabled=no distance=2 dst-address=0.0.0.0/0

gateway=pppoe-out1 scope=30 \
    target-scope=10
add disabled=no distance=3 dst-address=0.0.0.0/0

gateway=pppoe-out2 scope=30 \
    target-scope=10
add disabled=no distance=4 dst-address=0.0.0.0/0 gateway=LD1

scope=30 \
    target-scope=10
add disabled=no distance=5 dst-address=0.0.0.0/0 gateway=LD2

scope=30 \
    target-scope=10
/interface pppoe-client
add ac-name="" add-default-route=no

allow=pap,chap,mschap1,mschap2 \
    dial-on-demand=no disabled=no interface=ADSL1 max-

mru=1480 max-mtu=1480 \
    mrru=disabled name=pppoe-out1 password=oi

profile=default service-name="" \
    use-peer-dns=no user=oi@oi.com.br
add ac-name="" add-default-route=no

allow=pap,chap,mschap1,mschap2 \
    dial-on-demand=no disabled=no interface=ADSL2 max-

mru=1480 max-mtu=1480 \
    mrru=disabled name=pppoe-out2 password=oi

profile=default service-name="" \
    use-peer-dns=no user=oi@oi.com.br


Última edição por ZBTECK em Ter 7 Fev - 14:51, editado 1 vez(es) (Razão : Fechar code)

floris
Advance user
Advance user

Mensagens : 302
Pontos : 459
Reputação : 69
Data de inscrição : 30/12/2010
Idade : 34
Localização Localização : Salvador

Voltar ao Topo Ir em baixo

Problema Resolvido

Mensagem por floris em Ter 7 Fev - 20:56

Eu consegui resolver.

floris
Advance user
Advance user

Mensagens : 302
Pontos : 459
Reputação : 69
Data de inscrição : 30/12/2010
Idade : 34
Localização Localização : Salvador

Voltar ao Topo Ir em baixo

Re: [Resolvido]Não consigo acessar remotamente o Load Ballance

Mensagem por ZBTECK em Ter 7 Fev - 22:12

floris escreveu:Eu consegui resolver.
Por favor, poste o que fez para resolver. Pode ajudar outras pessoas como mesmo problema.

ZBTECK
Power User
Power User

Mensagens : 930
Pontos : 1117
Reputação : 186
Data de inscrição : 11/04/2011
Idade : 28
Localização Localização : São Paulo

Voltar ao Topo Ir em baixo

Re: [Resolvido]Não consigo acessar remotamente o Load Ballance

Mensagem por floris em Qua 8 Fev - 9:28

ZBTECK escreveu:
floris escreveu:Eu consegui resolver.
Por favor, poste o que fez para resolver. Pode ajudar outras pessoas como mesmo problema.


Resolvi da seguinte maneira, mudei a ordem das rotas, onde em distance tinha 2, 3, 4, 5 para pppoe-out1 , pppoe-out2, LD1 e LD2 respectivamente, inverti a ordem, dando 2 para LD1, 3 para LD2, 4 para pppoe-out1 e 5 para pppoe-out2.

LD1 e LD2 são os links dedicados.

Já vi algumas pessoas passarem por isso, espero ter ajudado. Se gostou clique no +.


floris
Advance user
Advance user

Mensagens : 302
Pontos : 459
Reputação : 69
Data de inscrição : 30/12/2010
Idade : 34
Localização Localização : Salvador

Voltar ao Topo Ir em baixo

Re: [Resolvido]Não consigo acessar remotamente o Load Ballance

Mensagem por Conteúdo patrocinado Hoje à(s) 1:03


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum