Login

Esqueci minha senha

lateral
Estatísticas
Temos 29306 usuários registrados
O último usuário registrado atende pelo nome de Werike

Os nossos membros postaram um total de 37321 mensagens em 5570 assuntos

acesso remoto ao mikrotik versão 5.0

Página 1 de 2 1, 2  Seguinte

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

acesso remoto ao mikrotik versão 5.0

Mensagem por vlcunes em Sab 7 Abr - 23:54

Pessoal,

estou querendo ter acesso remomto ao mikrotik versão 5.0, porem o script utilizado nõao funciona. Descobrir que o mesmo muda de acordo a versão. Alguém usar a versão 5.o do mikrotik poderia me passar o script?

vlcunes
Iniciante
Iniciante

Mensagens : 77
Pontos : 129
Reputação : 0
Data de inscrição : 19/03/2012
Idade : 26
Localização Localização : barros reis

Voltar ao Topo Ir em baixo

Re:

Mensagem por floris em Dom 8 Abr - 0:26

Eu uso esse na versão 5.x

Código:
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# DEFINIÇÂO DA CONTA DDNS
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
:global ddnsuser "nome de usuário do ddns"
:global ddnspass "senha"
:global ddnshost "seuhost.ddns.info"
:global ddnsinterface "pppoe-out1"
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# FNAL DA DEFINIÇÃO
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

:global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
:global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
:global ddnslastip
:if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: No interface named $ddnsinterface, please check configuration." }
:if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }
:if ([ :typeof $ddnsip ] = "nothing" ) do={
:log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
} else={
  :if ($ddnsip != $ddnslastip) do={
    :log info "O DDNS foi atualizado com sucesso!"
    :log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip
  } else={
    :log info "Não foi preciso atualizar o DDNS."
  }
}
# FINAL DO SCRIPT

Altere esses dados do código acima de acordo com sua conta ddns.

floris
Advance user
Advance user

Mensagens : 302
Pontos : 459
Reputação : 69
Data de inscrição : 30/12/2010
Idade : 34
Localização Localização : Salvador

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por floris em Dom 8 Abr - 0:28

Os dados para serem alterados:
:global ddnsuser "nome de usuário do ddns"
:global ddnspass "senha"
:global ddnshost "seuhost.ddns.info"
:global ddnsinterface "pppoe-out1"


Se ajudei, clique no mais.

floris
Advance user
Advance user

Mensagens : 302
Pontos : 459
Reputação : 69
Data de inscrição : 30/12/2010
Idade : 34
Localização Localização : Salvador

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por vlcunes em Dom 8 Abr - 9:31

vcs usavam outra versão e atualizou, foi isso?

vlcunes
Iniciante
Iniciante

Mensagens : 77
Pontos : 129
Reputação : 0
Data de inscrição : 19/03/2012
Idade : 26
Localização Localização : barros reis

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por vlcunes em Dom 8 Abr - 9:42

vou testar e retorno.

vlcunes
Iniciante
Iniciante

Mensagens : 77
Pontos : 129
Reputação : 0
Data de inscrição : 19/03/2012
Idade : 26
Localização Localização : barros reis

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por vlcunes em Qua 11 Abr - 9:07

Com esse script funciona, porém não atualiza. Se eu precisar reiniciar o server eu perco a conexão via ddns.

vlcunes
Iniciante
Iniciante

Mensagens : 77
Pontos : 129
Reputação : 0
Data de inscrição : 19/03/2012
Idade : 26
Localização Localização : barros reis

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por floris em Qua 11 Abr - 9:20

vlcunes escreveu:Com esse script funciona, porém não atualiza. Se eu precisar reiniciar o server eu perco a conexão via ddns.

Olá amigo, atualiza sim. Veja o script em funcionamento.

Acesse um pequeno provedor com esse script em funcionamento.

floris.ddns.info
Login: teste
Senha: 123

Verifique no log que ele atualiza normalmente.

floris
Advance user
Advance user

Mensagens : 302
Pontos : 459
Reputação : 69
Data de inscrição : 30/12/2010
Idade : 34
Localização Localização : Salvador

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por cristiano.micros em Qua 11 Abr - 10:39

mais tem que fazer o agendamento da regra para atualizar

__________________________________________________
A cópia é um dos métodos de aprendizado mas quem só copia não aprende study

Trevizam Network Consultoria

Parceiro BM Software | Consultoria e Revenda Thundercache PRO

visite nossa pagina [Você precisa estar registrado e conectado para ver este link.]

[Você precisa estar registrado e conectado para ver este link.]

[Você precisa estar registrado e conectado para ver este link.]

11 96380-8759 (VIVO) 11 98606-5675 (TIM)

cristiano.micros
Power User
Power User

Mensagens : 1185
Pontos : 1440
Reputação : 233
Data de inscrição : 27/11/2010
Idade : 27
Localização Localização : suzano

http://www.trevizamnetwork.com.br

Voltar ao Topo Ir em baixo

re: Agendamento

Mensagem por floris em Qua 11 Abr - 11:24

Para atualização automática do "DDNS":

Vá em System/Scheduler e clique no sinal de +.

Deixe como na imagem abaixo.



Onde vê ddns em On Event tem que ser o nome que vc deu para o script criado em /System/Script

Abraço!

floris
Advance user
Advance user

Mensagens : 302
Pontos : 459
Reputação : 69
Data de inscrição : 30/12/2010
Idade : 34
Localização Localização : Salvador

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por vlcunes em Qua 11 Abr - 12:16

Pessoal, problema resolvido.

vlcunes
Iniciante
Iniciante

Mensagens : 77
Pontos : 129
Reputação : 0
Data de inscrição : 19/03/2012
Idade : 26
Localização Localização : barros reis

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por vlcunes em Qua 11 Abr - 12:55

Floris, esse seu mikrotik você faz cache? ou colocou outro programa para isso?

vlcunes
Iniciante
Iniciante

Mensagens : 77
Pontos : 129
Reputação : 0
Data de inscrição : 19/03/2012
Idade : 26
Localização Localização : barros reis

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por floris em Qua 11 Abr - 13:00

vlcunes escreveu:Floris, esse seu mikrotik você faz cache? ou colocou outro programa para isso?

Nessa que eu te passei eu não faço, utilizo uma RB750gl e pela quantidade de usuários cadastrado não compensa investi em uma máquina boa, além de ter que deixar ligado consumindo energia. Para provedores de no máximo de trinta clientes eu aconselho a pegar um ou dois links de 15 megas, ás vezes fica até melhor.

Abraço!

floris
Advance user
Advance user

Mensagens : 302
Pontos : 459
Reputação : 69
Data de inscrição : 30/12/2010
Idade : 34
Localização Localização : Salvador

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por vlcunes em Qua 11 Abr - 13:25

manda ai seu msn.

vlcunes
Iniciante
Iniciante

Mensagens : 77
Pontos : 129
Reputação : 0
Data de inscrição : 19/03/2012
Idade : 26
Localização Localização : barros reis

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por floris em Qua 11 Abr - 13:32

vlcunes escreveu:manda ai seu msn.

[Você precisa estar registrado e conectado para ver este link.]

floris
Advance user
Advance user

Mensagens : 302
Pontos : 459
Reputação : 69
Data de inscrição : 30/12/2010
Idade : 34
Localização Localização : Salvador

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por vlcunes em Qua 11 Abr - 13:43

Já add.

vlcunes
Iniciante
Iniciante

Mensagens : 77
Pontos : 129
Reputação : 0
Data de inscrição : 19/03/2012
Idade : 26
Localização Localização : barros reis

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por vlcunes em Qua 11 Abr - 17:29

Nesse mikrotik que me passou você não configura regras no firewall filter rules pq?



vlcunes
Iniciante
Iniciante

Mensagens : 77
Pontos : 129
Reputação : 0
Data de inscrição : 19/03/2012
Idade : 26
Localização Localização : barros reis

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por claudinhohw Network em Qua 11 Abr - 19:04

amigo seu modem tem que ficar em brgide se estiver e só fazer os seguintes passos abaixo!

primeiro entre no site [Você precisa estar registrado e conectado para ver este link.]

segundo mude o scprit abaixo para suas configurações:

dê o nome do script de "ddns"

Código:
/tool dns-update name=seu.ddns address=127.0.0.255 key-name=seu-user key="senha-aki"

cole esse script abaixo em new terminal

Código:
/system scheduler
add disabled=no interval=30s name=ddns on-event="/system script run ddns" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    start-time=startup

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik

claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2541
Pontos : 3168
Reputação : 570
Data de inscrição : 28/08/2010
Idade : 32
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por floris em Qua 11 Abr - 19:42

claudinhohw escreveu:amigo seu modem tem que ficar em brgide se estiver e só fazer os seguintes passos abaixo!

primeiro entre no site [Você precisa estar registrado e conectado para ver este link.]

segundo mude o scprit abaixo para suas configurações:

dê o nome do script de "ddns"

Código:
/tool dns-update name=seu.ddns address=127.0.0.255 key-name=seu-user key="senha-aki"

cole esse script abaixo em new terminal

Código:
/system scheduler
add disabled=no interval=30s name=ddns on-event="/system script run ddns" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
start-time=startup



Claudinho, esse script que eu passei também serve para modem roteado. E esse que vc passou também já testei em modem bridge e funcionou perfeitamente.

A única observação é opção do dmz no modem que tem q ser redirecionado por servidor, como vc falou.

floris
Advance user
Advance user

Mensagens : 302
Pontos : 459
Reputação : 69
Data de inscrição : 30/12/2010
Idade : 34
Localização Localização : Salvador

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por floris em Qui 12 Abr - 0:28

vlcunes escreveu:Nesse mikrotik que me passou você não configura regras no firewall filter rules pq?



Não há necessidade.

floris
Advance user
Advance user

Mensagens : 302
Pontos : 459
Reputação : 69
Data de inscrição : 30/12/2010
Idade : 34
Localização Localização : Salvador

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por morais2707 em Qui 12 Abr - 8:03

amigos sem quando faço o scritp e tudo, ele roda bacana, mais depois de uns dias ele não funciona mais, onde tá o problema.

acho q pode ser algo com servidor de horário, detalhe meu mikrotik é o 3.20

__________________________________________________


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Teresina_Piauí (86) 99456-5121
SKYPE: assistec.pi / email: [Você precisa estar registrado e conectado para ver este link.]
Facebook: [Você precisa estar registrado e conectado para ver este link.]

Serviços:
*Configuração em Mikrotik
*Sistema de Cache>
     °Thunder Cache
     °Brazil FW



[Você precisa estar registrado e conectado para ver este link.]

****Page seu serviço agora no cartão de crédito com PayPal****

morais2707
Power User
Power User

Mensagens : 1404
Pontos : 1806
Reputação : 248
Data de inscrição : 02/01/2012
Idade : 35
Localização Localização : TERESINA-PIAUI

Voltar ao Topo Ir em baixo

re:

Mensagem por floris em Qui 12 Abr - 8:40

Teste esse que eu usava a muito tempo na versão 3.30.

Código:
# Define User Variables
:global ddnsuser "[b]seu login[/b]"
:global ddnspass "[b]sua senha[/b]"
:global ddnshost "[b]xxxx.ddns.info[/b]"
 
# Define Global Variables
:global ddnsip
:global ddnslastip
:if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }
 
:global ddnsinterface
:global ddnssystem ("mt-" . [/system package get system version] )
 
# Define Local Variables
:local int
 
# Loop thru interfaces and look for ones containing
# default gateways without routing-marks
:foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={
  :if ([:typeof [/ip route get $int routing-mark ]] != str ) do={
    :global ddnsinterface [/ip route get $int interface]
  }
}
 
# Grab the current IP address on that interface.
:global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]
 
# Did we get an IP address to compare?
:if ([ :typeof $ddnsip ] = nil ) do={
  :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
} else={
 
  :if ($ddnsip != $ddnslastip) do={
 
    :log info "DDNS: Sending UPDATE!"
    :log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip
 
  } else={
    :log info "DDNS: No update required."
  }
 
}
 
# End of script

floris
Advance user
Advance user

Mensagens : 302
Pontos : 459
Reputação : 69
Data de inscrição : 30/12/2010
Idade : 34
Localização Localização : Salvador

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por Convidado em Qui 12 Abr - 13:41

acompanhando...

Convidado
Convidado


Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por regialvessousa em Sab 21 Abr - 18:46

Galera estou com um rb750 e ñ consigo acessar remotamente de jeito nenhum
só consigo ver a interface do meu moden em que estou errando

regialvessousa
Iniciante
Iniciante

Mensagens : 63
Pontos : 82
Reputação : 1
Data de inscrição : 25/01/2012
Idade : 32
Localização Localização : brasilia

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por regialvessousa em Dom 22 Abr - 8:41

Galera meu estava dando erro no changeip pois criei um DDNS no NO-IP e funcionou blza.

regialvessousa
Iniciante
Iniciante

Mensagens : 63
Pontos : 82
Reputação : 1
Data de inscrição : 25/01/2012
Idade : 32
Localização Localização : brasilia

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por claudinhohw Network em Dom 22 Abr - 11:01

regialvessousa escreveu:Galera meu estava dando erro no changeip pois criei um DDNS no NO-IP e funcionou blza.
eu uso só changeip aki e nunca tive problemas vc ativou corretamente e configurou certinho?

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik

claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2541
Pontos : 3168
Reputação : 570
Data de inscrição : 28/08/2010
Idade : 32
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Re: acesso remoto ao mikrotik versão 5.0

Mensagem por Conteúdo patrocinado Hoje à(s) 20:11


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Página 1 de 2 1, 2  Seguinte

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum