Login

Esqueci minha senha

lateral
Estatísticas
Temos 29301 usuários registrados
O último usuário registrado atende pelo nome de isaiasfreitas

Os nossos membros postaram um total de 37318 mensagens em 5569 assuntos

Controle de ACK

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Controle de ACK

Mensagem por f1969 em Qua 30 Maio - 12:53

Galera, é o seguinte, tenho uma RB433AH que estava com a versão 3.25, então atualizei para a 5.16, mas percebi algumas mudanças, por exemplo o ACK, antes rodava um script para controlar o Acktimeout, mas na versão 5.16 mudou de Ack timeout para Distance, ou seja, o script não funciona mais, então gostaria de saber como faço para controlar o ACK na versão 5.16.

f1969
User
User

Mensagens : 129
Pontos : 151
Reputação : 10
Data de inscrição : 19/04/2011
Idade : 47
Localização Localização : Brasilia-DF

Voltar ao Topo Ir em baixo

Re: Controle de ACK

Mensagem por Convidad em Qua 30 Maio - 12:57

amigo isso e bugs vc tem quer tenta tira os bugs.

Convidad
Convidado


Voltar ao Topo Ir em baixo

Re: Controle de ACK

Mensagem por f1969 em Qua 30 Maio - 14:42

Danilo escreveu:amigo isso e bugs vc tem quer tenta tira os bugs.

Não entendi! como assim bug? O que percebi foi que da versão 2.25 para 5.16 mudou o nome de Ack timeout para Distance na aba advanced do cartão. então como o script era para ack e não para distance acho que é para não funcionar mesmo, portanto queria saber se há outro script ou forma de controlar a Distance que não recebe mais o nome de Ack.

f1969
User
User

Mensagens : 129
Pontos : 151
Reputação : 10
Data de inscrição : 19/04/2011
Idade : 47
Localização Localização : Brasilia-DF

Voltar ao Topo Ir em baixo

Re: Controle de ACK

Mensagem por cristiano.micros em Qua 30 Maio - 16:08

nao tem problema no script apenas o script deve ser para versoes 2x e 3x
acima disso deve que fazer alguma modificação

__________________________________________________
A cópia é um dos métodos de aprendizado mas quem só copia não aprende study

Trevizam Network Consultoria

Parceiro BM Software | Consultoria e Revenda Thundercache PRO

visite nossa pagina [Você precisa estar registrado e conectado para ver este link.]

[Você precisa estar registrado e conectado para ver este link.]

[Você precisa estar registrado e conectado para ver este link.]

11 96380-8759 (VIVO) 11 98606-5675 (TIM)

cristiano.micros
Power User
Power User

Mensagens : 1185
Pontos : 1440
Reputação : 233
Data de inscrição : 27/11/2010
Idade : 27
Localização Localização : suzano

http://www.trevizamnetwork.com.br

Voltar ao Topo Ir em baixo

Re: Controle de ACK

Mensagem por f1969 em Qua 30 Maio - 16:47

cristiano.micros escreveu:nao tem problema no script apenas o script deve ser para versoes 2x e 3x
acima disso deve que fazer alguma modificação

Eu estou tentanto descobrir quais seriam estas modificações! Porque realmente o script é para Ack e não para Distance, que acredito que seja a mesma coisa.

f1969
User
User

Mensagens : 129
Pontos : 151
Reputação : 10
Data de inscrição : 19/04/2011
Idade : 47
Localização Localização : Brasilia-DF

Voltar ao Topo Ir em baixo

Re: Controle de ACK

Mensagem por cristiano.micros em Qua 30 Maio - 17:08

tenta esse aqui
[Você precisa estar registrado e conectado para ver este link.]
ja usei na versao 4x funcionou perfeito

__________________________________________________
A cópia é um dos métodos de aprendizado mas quem só copia não aprende study

Trevizam Network Consultoria

Parceiro BM Software | Consultoria e Revenda Thundercache PRO

visite nossa pagina [Você precisa estar registrado e conectado para ver este link.]

[Você precisa estar registrado e conectado para ver este link.]

[Você precisa estar registrado e conectado para ver este link.]

11 96380-8759 (VIVO) 11 98606-5675 (TIM)

cristiano.micros
Power User
Power User

Mensagens : 1185
Pontos : 1440
Reputação : 233
Data de inscrição : 27/11/2010
Idade : 27
Localização Localização : suzano

http://www.trevizamnetwork.com.br

Voltar ao Topo Ir em baixo

Re: Controle de ACK

Mensagem por f1969 em Qua 30 Maio - 17:29

cristiano.micros escreveu:tenta esse aqui
[Você precisa estar registrado e conectado para ver este link.]
ja usei na versao 4x funcionou perfeito

Então! este script citado acima é o que eu usava na versão 3.25, mas como disse atualizei a RB para a versão 5.16 que agora o nome não é mais ack e sim distance.

f1969
User
User

Mensagens : 129
Pontos : 151
Reputação : 10
Data de inscrição : 19/04/2011
Idade : 47
Localização Localização : Brasilia-DF

Voltar ao Topo Ir em baixo

Re: Controle de ACK

Mensagem por misterdjim em Seg 4 Jun - 15:12

uso a vesão 5.x no meu e to usando este script

só copiar e colar no new terminal. setado para ack 60

/system script
add name=ACK policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\
#Script ACK-Check v0.1\r\
\n#\r\
\n#Lista as estacoes que estao com ACK acima do limite com opcao para desc\
onecta-las\r\
\n#\r\
\n# Autor: Alexandre Jeronimo Correa \r\
\n# 20/11/2009 - 01:03am\r\
\n#\r\
\n#Instrucoes de uso:\r\
\n# -- Adicionar o codigo completo em SYSTEM >> SCRIPTS\r\
\n# -- Por padrao o script nao vai derrubar nenhuma estacao, rode o sc\
ript padrao antes de\r\
\n# configurar a variavel cut para 1, tendo certeza que o script e\
sta OK.\r\
\n# -- O script pode ser executado pelo botao \"run script\" ou via li\
nha de comando.\r\
\n# \"/ system script run \r\
\n# -- O script so funciona em interfaces que o modo de operacao seja \
AP-BRIDGE\r\
\n# -- Testado nas versoes 3.25 at\E9 3.30\r\
\n#\r\
\n#Informacoes:\r\
\n#\r\
\n#Variavel ack -> deve ter o valor do ack MAXIMO permitido.\r\
\n#Variavel cut -> deve ser 0 ou 1, 0 somente mostra, 1 mostra e desconec\
ta a estacao.\r\
\n##################################################################\r\
\n#Configuracoes das variaveis\r\
\n:local ack 60;\r\
\n:local cut 1;\r\
\n\r\
\n############ Script - NAO ALTERAR #####################################\
\r\
\n:local mac \"\";\r\
\n:local uack \"\";\r\
\n:local removido \"\";\r\
\n:log warning (\"[ackchk] Procurando clientes com ACK maior que \" . \$ac\
k);\r\
\n#pega a lista de interfaces AP wireless ativas, e que tenham ack dinamic\
o\r\
\n:foreach i in=[ / interface wireless find mode=\"ap-bridge\" ack-timeout\
=\"dynamic\" running] do={\r\
\n :local intname [ / interface wireless get \$i name ];\r\
\n :log warning (\" Interface: \" . \$intname);\r\
\n :foreach x in=[/interface wireless registration-table find int\
erface=\$intname] do={\r\
\n :set uack [/interface wireless registration-table ge\
t \$x ack-timeout];\r\
\n :set removido \"\";\r\
\n :if (\$uack > \$ack) do={\r\
\n :set mac [ / interface wireless registration-ta\
ble get \$x mac-address]; \r\
\n :if (\$cut = 1) do= {\r\
\n :set removido \" removido...\";\r\
\n / interface wireless registration-table re\
move \$x;\r\
\n };\r\
\n :log warning (\" mac: \" . \$mac . \"@\" . \
\$intname . \" [\" . \$uack . \"]\" . \$removido);\r\
\n }; \r\
\n };\r\
\n};\r\
\n############ FIM #####################################\



depois cole este tbm.

/system scheduler
add comment="" disabled=no interval=2s name=ACK on-event=ACK policy=\
reboot,read,write,policy,test,password,sniff,sensitive start-date=\
jan/01/1970 start-time=00:00:00


depois vai em log e confira ele rodando.


misterdjim
Iniciante
Iniciante

Mensagens : 35
Pontos : 43
Reputação : 0
Data de inscrição : 09/08/2011
Idade : 33
Localização Localização : guaratuba

Voltar ao Topo Ir em baixo

Re: Controle de ACK

Mensagem por Conteúdo patrocinado Hoje à(s) 22:56


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum