Login

Esqueci minha senha

lateral
Estatísticas
Temos 29291 usuários registrados
O último usuário registrado atende pelo nome de Miranda

Os nossos membros postaram um total de 37315 mensagens em 5569 assuntos

Script Para Envio de Email

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Script Para Envio de Email

Mensagem por ltolsilv em Qui 7 Jun - 18:24

Bom galera, Um salve a todos!

É o seguinte, gostaria de saber se existe uma maneira de o mikrotik
enviar email automaticamente quando um cliente nao cadastrado se
conectar a rede, Tipo assim...

Quando uma pessoa conecta na rede, mas ainda não está cadastrado, ele
cai no lease do DHCP e na TABELA ARP automaticamente, Porém como ainda
não é cliente ele não vai navegar.

Por isso gostaria de ter um script para que quando um lease ou arp for
adicionado automaticamente, me fosse enviado um email pelo mikrotik.

Um grande abraço! Very Happy

ltolsilv
Baby
Baby

Mensagens : 8
Pontos : 14
Reputação : 0
Data de inscrição : 30/05/2012
Idade : 38
Localização Localização : VITORIA

Voltar ao Topo Ir em baixo

Re: Script Para Envio de Email

Mensagem por GuilhermeCba em Sex 8 Jun - 4:46

isso eh uma ideia legal, estou acompanhando para fazer o mesmo ! sem qrer me introzar no assunto, caso nao tenha a opção de mandar e-mail, seria possivel pelo menos um poupap ? abraços !

GuilhermeCba
User
User

Mensagens : 148
Pontos : 213
Reputação : 7
Data de inscrição : 08/05/2012
Idade : 27
Localização Localização : Cuiabá

Voltar ao Topo Ir em baixo

Re: Script Para Envio de Email

Mensagem por ludu_64 em Sex 8 Jun - 8:02

Acompanhando.... Basketball

ludu_64
Baby
Baby

Mensagens : 18
Pontos : 30
Reputação : 4
Data de inscrição : 23/03/2012
Idade : 32
Localização Localização : Belém - PA

Voltar ao Topo Ir em baixo

Re: Script Para Envio de Email

Mensagem por kassinho em Sex 25 Set - 11:35

alguém com o script de email para becap da rb

kassinho
Baby
Baby

Mensagens : 8
Pontos : 16
Reputação : 0
Data de inscrição : 25/04/2012
Idade : 27
Localização Localização : palmares

Voltar ao Topo Ir em baixo

Re: Script Para Envio de Email

Mensagem por evitoria em Qua 11 Maio - 16:51

configurando o envio de emails:


no WINBOX:

menu

/tool>email>

Server: smtp.gmail.com
Port: 587
From: seu_email_no_gmail@gmail.com
User: seu_email_no_gmail@gmail.com
Password: ********** (sua senha no gmail=)

Clique no botao "Apply" e imediatamente a URL smtp.gmail.com é resolvida trocada para o IP certo.

Escrevendo um script para gerar o arquivo log-mikrotik.txt
no WINBOX

menu

/system>scripts

adicione um script chamado "salvar-log"

Name: salvar-log

Source: (código fonte)

/log print file=log-mikrotik.txt


_______________________________________

Escrevendo um script para gerar o arquivo backup-mikrotik.backup

do mesmo jeito com o seguinte código fonte:

Name: salvar-backup

Source:

/system backup save name=backup-mikrotik.backup


_______________________________________


Agora é preciso criar mais 2 scripts, um para enviar o log e outro para enviar o backup por email



Name: enviar-log

Source:

:log info message="enviando log por email"
:global data [/system clock get date]
:global hora [/system clock get time]
/tool e-mail send to="email_de_destino01@dominio.com" subject="log-mikrotik $data $hora" file=log-mikrotik.txt tls=yes


_______________________________________

Name: enviar-backup

Source:

:log info message="enviando backup por email"
:global data [/system clock get date]
:global hora [/system clock get time]
/tool e-mail send to="email_de_destino01@dominio.com" subject="backup-mikrotik $data $hora" file=backup-mikrotik.backup tls=yes



_______________________________________


Configurando o envio automático dos logs/backups

no WINBOX

/system>scheduler

agora é só agendar os 4 scripts de acordo com a necessidade, geralmente uso backup a cada 24 horas e logs a cada 6 horas como nas regras abaixo:

/system scheduler add comment="" disabled=no interval=1d name=enviar-backup-automatico \
on-event=enviar-backup policy=\
reboot,read,write,policy,test,password,sniff,sensitive start-date=\
jan/01/1970 start-time=23:10:00
/system scheduler add comment="" disabled=no interval=1d name=salvar-backup-automatico \
on-event=salvar-backup policy=\
reboot,read,write,policy,test,password,sniff,sensitive start-date=\
jan/01/1970 start-time=23:00:00
/system scheduler add comment="" disabled=no interval=6h name=salvar-log-automatico on-event=\
salvar-log policy=reboot,read,write,policy,test,password,sniff,sensitive \
start-date=jan/01/1970 start-time=00:00:00
/system scheduler add comment="" disabled=no interval=6h name=enviar-log-automatico on-event=\
enviar-log policy=reboot,read,write,policy,test,password,sniff,sensitive \
start-date=jan/01/1970 start-time=00:10:00

evitoria
Baby
Baby

Mensagens : 17
Pontos : 29
Reputação : 4
Data de inscrição : 15/09/2011
Idade : 46
Localização Localização : junqueiro -alagoas

http://www.coffnetinternet.com.br

Voltar ao Topo Ir em baixo

Re: Script Para Envio de Email

Mensagem por Conteúdo patrocinado Hoje à(s) 7:13


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum