Login

Esqueci minha senha

lateral
Estatísticas
Temos 29286 usuários registrados
O último usuário registrado atende pelo nome de Foxcomp

Os nossos membros postaram um total de 37315 mensagens em 5569 assuntos

Cache paralelo entre um MK e um BFW

Página 4 de 4 Anterior  1, 2, 3, 4

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Cache paralelo entre um MK e um BFW

Mensagem por paulosjbv em Sab 18 Ago - 17:33

Relembrando a primeira mensagem :

Boa tarde pessoal

Como conssegui colocar um MK e um BFW funcionando belezinha em cascata vou postar aqui o que fiz para quem não ta consseguindo ok



- instale o BFW em um PC com 2 placas de rede
- ligue o PC na placa de rede do BFW e faça as configurações desejadas
- no BFW ainda va em ->configurações ->dns ->configurações coloque um dns de sua preferência(aqui uso 8.8.8.8 e 208.67.220.220) e deixe marcado a opção “Permitir acesso externo aos servidores de resolução de nomes” salve.
- va em ->configurações ->dhcp ->configurações e desative o dhcp salve
- configurações ->portas ->acesso externo e deixe ativado para acesso externo as opções “22-ssh,3128-squid,8181-webmin, adicione mais um acesso externo porta 3129 protocolo todos coloque um nome de sua preferncia”
- configurações -> conexões -> lógica na opção “internet” clique em editar e deixe o tipo de conexão como estático, preencha os campos com sua preferência (aqui usso assim: ip 192.168.201.2 mascara 255.255.255.0 gateway 192.168.201.1) salve
- configurações -> salvar configuraçoes .
- desligue o BFW e retire a placa de rede (geralmente eth0)
- ligue novamente e conecte um cacbo de rede na placa que restou e ligue em uma porta no MK.



Agora no MK
-coloque nome nas suas interfaces (para deixar tudo organizado)
- coloque ip nas interfaces (na interface que vai ligar o BFW deixe assim: 192.168.201.1/30 setado na interface do BFW)
- crie a rota para internet
- va no terminal e adicione essas regras:

/ip firewall filter
add action=accept chain=forward comment="Aceita BFW" disabled=no \
src-address=192.168.201.0/30

/ip firewall nat
add action=dst-nat chain=dstnat comment="Redirect BFW Cache" disabled=yes \
dst-port=80 protocol=tcp src-address=”coloque o ip da placa de seus clientes” to-addresses=\
192.168.201.2 to-ports=3129

/ip firewall mangle
add action=mark-connection chain=postrouting comment="BFW CACHE FULL =====\
==========================================================================\
=======================" content="X-Cache: HIT from BFW Cache" disabled=no \
new-connection-mark=bfw-connection passthrough=yes protocol=tcp \
src-address=192.168.201.2
add action=mark-packet chain=postrouting comment="" connection-mark=\
bfwcache-connection disabled=no new-packet-mark=bfwcache-packs passthrough=\
yes
add action=mark-connection chain=postrouting comment="TOS 12==================\
==========================================================================\
=========================" disabled=no dscp=12 new-connection-mark=\
proxy-hits passthrough=yes protocol=tcp src-address=192.168.201.2
add action=mark-packet chain=postrouting comment="" connection-mark=\
proxy-hits disabled=no new-packet-mark=proxy-squid passthrough=yes

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=100M name="T -cache_hits" packet-mark=proxy-squid parent=\
global-out priority=4 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=100M name=BFW Cache packet-mark=bfwcache-packs parent=\
global-out priority=4 queue=default

/ip firewall address-list
add address=69.147.95.0/24 comment="\"\"\"\"YAHOO MAIL\"\"\"\"" disabled=no \
list=nobalance
add address=209.191.106.0/24 comment="\"\"\"\"YAHOO MAIL\"\"\"\"" disabled=no \
list=nobalance
add address=74.6.228.0/24 comment="\"\"\"\"YAHOO MAIL\"\"\"\"" disabled=no \
list=nobalance
add address=98.136.131.0/24 comment="\"\"\"\"YAHOO MAIL\"\"\"\"" disabled=no \
list=nobalance
add address=200.143.37.0/24 comment="\"\"\"\"WEBMOTORS\"\"\"\"" disabled=no \
list=nobalance
add address=65.54.0.0/16 comment=MSN1 disabled=no list=nobalance
add address=207.46.0.0/16 comment=MSN2 disabled=no list=nobalance
add address=64.4.0.0/16 comment=MSN3 disabled=no list=nobalance
add address=200.143.0.0/16 comment=Pagdigital disabled=no list=nobalance
add address=201.88.0.0/16 comment=f2b disabled=no list=nobalance
add address=200.201.0.0/16 comment="caixa economica" disabled=no list=\
nobalance
add address=170.66.0.0/16 comment="bb do brasil" disabled=no list=nobalance
add address=200.155.0.0/16 comment=bradesco disabled=no list=nobalance
add address=200.196.0.0/16 comment=itau disabled=no list=nobalance
add address=200.208.0.0/16 comment=sudameris disabled=no list=nobalance
add address=200.220.0.0/16 comment=santander disabled=no list=nobalance
add address=201.63.0.0/16 comment="wwws bradesco" disabled=no list=nobalance
add address=65.55.0.0/16 comment=MSN4 disabled=no list=nobalance
add address=74.52.0.0/16 comment="caixa economica" disabled=no list=nobalance
add address=174.133.0.0/16 comment="caixa economica" disabled=no list=\
nobalance
add address=200.219.137.0/24 comment="" disabled=no list=nobalance
add address=200.252.8.0/24 comment="" disabled=no list=nobalance
add address=201.2.207.0/24 comment="" disabled=no list=nobalance
add address=200.196.226.0/24 comment="" disabled=no list=nobalance
add address=201.24.72.0/24 comment="" disabled=no list=nobalance
add address=78.46.46.139 comment="" disabled=no list=nobalance

/ip firewall nat
add action=accept chain=dstnat comment=\
"\"\"\"\"\"\"Sites FORA DO PROXY\"\"\"\"\"\"" disabled=no \
dst-address-list=nobalance dst-port=80 protocol=tcp

pronto se tudo deu certo abra um navegador e digite o endereço ip do BFW (192.168.201.2:8181) você terá acesso ao webmin do servidor de cachê.
Agora faça o teste você tem um servidor MK controlando a sua rede e um servidor BFW fazendo cachê paralelo.

Agradeço ao Chicao por ter me ajudado e ao Geronimo por ter postado o vídeo cachê full
É isso ai flw pessoal

paulosjbv
Iniciante
Iniciante

Mensagens : 74
Pontos : 85
Reputação : 3
Data de inscrição : 30/06/2012
Idade : 38
Localização Localização : aguai

Voltar ao Topo Ir em baixo


Re: Cache paralelo entre um MK e um BFW

Mensagem por vilc em Sex 21 Jun - 20:42

O bfw cache ele tem alguns plug...ins q cacheia, a rela, acho q com mysar

vilc
Advance user
Advance user

Mensagens : 276
Pontos : 398
Reputação : 10
Data de inscrição : 30/04/2012
Idade : 34
Localização Localização : Rio de Janeiro

Voltar ao Topo Ir em baixo

Re: Cache paralelo entre um MK e um BFW

Mensagem por infomania em Sex 21 Jun - 21:11

Instalei o BFW cache mas nao notei nada de diferente! E os relatórios, sites acessados, esta aparecendo só com o ip da interface da RB que esta ligado cabo de rede do BFW. POrq só aparece o ip da RB no relatório de acesso? Sites...

infomania
Iniciante
Iniciante

Mensagens : 34
Pontos : 36
Reputação : 0
Data de inscrição : 09/07/2011
Idade : 33
Localização Localização : Brasil

Voltar ao Topo Ir em baixo

Re: Cache paralelo entre um MK e um BFW

Mensagem por vilc em Sex 21 Jun - 21:16

Essa parte ainda nao mexi, eu usava ele antes de usar o mk, deve ter q fazer alguma configuração no mk.

vilc
Advance user
Advance user

Mensagens : 276
Pontos : 398
Reputação : 10
Data de inscrição : 30/04/2012
Idade : 34
Localização Localização : Rio de Janeiro

Voltar ao Topo Ir em baixo

Re: Cache paralelo entre um MK e um BFW

Mensagem por infomania em Sex 21 Jun - 22:05

Bom.... só preciso dos logs agora! Gostaria de uma ajudinha! Vou continuar pesquisando tbm... rsrsrsrs

infomania
Iniciante
Iniciante

Mensagens : 34
Pontos : 36
Reputação : 0
Data de inscrição : 09/07/2011
Idade : 33
Localização Localização : Brasil

Voltar ao Topo Ir em baixo

Re: Cache paralelo entre um MK e um BFW

Mensagem por vilc em Sex 21 Jun - 22:11

Tem um script para monitorar o cache, pois se o bw desligar a internet continua funcionando, amanha eu posto, pois estou usando celular....

vilc
Advance user
Advance user

Mensagens : 276
Pontos : 398
Reputação : 10
Data de inscrição : 30/04/2012
Idade : 34
Localização Localização : Rio de Janeiro

Voltar ao Topo Ir em baixo

Re: Cache paralelo entre um MK e um BFW

Mensagem por infomania em Sex 21 Jun - 22:53

BLZ...! Mas eu quero monitorar os clientes, ver oque eles acessam! Sites acessados! Tem como???

infomania
Iniciante
Iniciante

Mensagens : 34
Pontos : 36
Reputação : 0
Data de inscrição : 09/07/2011
Idade : 33
Localização Localização : Brasil

Voltar ao Topo Ir em baixo

Re: Cache paralelo entre um MK e um BFW

Mensagem por infomania em Sab 22 Jun - 0:01

Procurei no facebook, ja que o pessoal migrou pra la! Mas nao achei nada de BFW. E Mikrotik tem bastante! Eu gostaria de reunir o pessoal la tbm. OK? http://www.facebook.com/groups/195372460621845/

infomania
Iniciante
Iniciante

Mensagens : 34
Pontos : 36
Reputação : 0
Data de inscrição : 09/07/2011
Idade : 33
Localização Localização : Brasil

Voltar ao Topo Ir em baixo

Re: Cache paralelo entre um MK e um BFW

Mensagem por vilc em Sab 22 Jun - 9:46

vilc escreveu:Tem um script para monitorar o cache, pois se o bw desligar a internet continua funcionando, amanha eu posto, pois estou usando celular....
para monitorar o cache quando o BFW desligar: vai em tools- netwatch-
clica no + em Host=192.168.10.2
interval= 00:00:10
timeout= 1000

em UP coloca:
/ip firewall nat enable [find comment="Redirect BFW Cache"]

em Down coloca:
/ip firewall nat disable [find comment="Redirect BFW Cache"]
log error "SERVIDOR BrazilFW ESTAR SEM LINK"

em coment coloca: Monitora Redirect BFW Cache

OBS: no firewal a regra de redirecionamento deixa o coment= Redirect BFW Cache.

vilc
Advance user
Advance user

Mensagens : 276
Pontos : 398
Reputação : 10
Data de inscrição : 30/04/2012
Idade : 34
Localização Localização : Rio de Janeiro

Voltar ao Topo Ir em baixo

Re: Cache paralelo entre um MK e um BFW

Mensagem por speed.infor.net em Sab 22 Jun - 15:06

amigo ta cacheando videos do youtube , da globo etc ? teria como vc colocar uns prints ai pra gente da uma olhada ,, obrigado

speed.infor.net
User
User

Mensagens : 181
Pontos : 271
Reputação : 32
Data de inscrição : 30/09/2012
Idade : 34
Localização Localização : gov valadares

Voltar ao Topo Ir em baixo

Re: Cache paralelo entre um MK e um BFW

Mensagem por infomania em Sab 22 Jun - 15:51

Videos não pega nada! Aqui só funciona pra arquivos quando voce baixa, e vai baixa novamente o mesmo arquivo, aí ja pega no cache, e como coloquei 6mega, esta baixando a 360k a 480k - pois minha rede é 2.4 e só passa até 4900k - hehehehe. E quando tem mais gente baixando do cache os arquivos ja baixados, eu baixo um arquivo do cache a 200 a 320k.

infomania
Iniciante
Iniciante

Mensagens : 34
Pontos : 36
Reputação : 0
Data de inscrição : 09/07/2011
Idade : 33
Localização Localização : Brasil

Voltar ao Topo Ir em baixo

Re: Cache paralelo entre um MK e um BFW

Mensagem por infomania em Sab 22 Jun - 15:52

[Você precisa estar registrado e conectado para ver este link.] - No Mikrotik isso???

infomania
Iniciante
Iniciante

Mensagens : 34
Pontos : 36
Reputação : 0
Data de inscrição : 09/07/2011
Idade : 33
Localização Localização : Brasil

Voltar ao Topo Ir em baixo

Re: Cache paralelo entre um MK e um BFW

Mensagem por infomania em Sab 22 Jun - 16:02

Olhem ai uns prints, do BFW e MK. http://www.4shared.com/rar/VRFRTHGK/Print-BFW.html

infomania
Iniciante
Iniciante

Mensagens : 34
Pontos : 36
Reputação : 0
Data de inscrição : 09/07/2011
Idade : 33
Localização Localização : Brasil

Voltar ao Topo Ir em baixo

Re: Cache paralelo entre um MK e um BFW

Mensagem por mkbfree em Ter 29 Out - 10:43

WILLIAM ANDRADE escreveu:Qual o processo de fazer em paralelo? coloquei a regra citada acima por [Você precisa estar registrado e conectado para ver este link.] e não deu certo.  Os usuarios ficam sem internet. O que deve esta fazedo de errado? Me ajudem.
O mesmo acontece comigo amigo, e o pior que o pessoal do forum do BFW também não da nem uma ajuda.

mkbfree
Iniciante
Iniciante

Mensagens : 61
Pontos : 73
Reputação : 6
Data de inscrição : 26/01/2011
Idade : 42
Localização Localização : Brazil

http://www.conectiva-mikrotik.webnode.com.br

Voltar ao Topo Ir em baixo

Re: Cache paralelo entre um MK e um BFW

Mensagem por superninja007 em Ter 5 Nov - 10:55

paulosjbv escreveu:Boa tarde pessoal

Como conssegui colocar um MK e um BFW funcionando belezinha em cascata vou postar aqui o que fiz para quem não ta consseguindo ok



- instale o BFW em um PC com 2 placas de rede
- ligue o PC na placa de rede do BFW e faça as configurações desejadas
- no BFW ainda va em ->configurações ->dns ->configurações coloque um dns de sua preferência(aqui uso 8.8.8.8 e 208.67.220.220) e deixe marcado a opção “Permitir acesso externo aos servidores de resolução de nomes” salve.
- va em ->configurações ->dhcp ->configurações e desative o dhcp salve
- configurações ->portas ->acesso externo e deixe ativado para acesso externo as opções “22-ssh,3128-squid,8181-webmin, adicione mais um acesso externo porta 3129 protocolo todos coloque um nome de sua preferncia”
- configurações -> conexões -> lógica na opção “internet” clique em editar e deixe o tipo de conexão como estático, preencha os campos com sua preferência (aqui usso assim: ip 192.168.201.2 mascara 255.255.255.0 gateway 192.168.201.1) salve
- configurações -> salvar configuraçoes .
- desligue o BFW e retire a placa de rede (geralmente eth0)
- ligue novamente e conecte um cacbo de rede na placa que restou e ligue em uma porta no MK.



Agora no MK
-coloque nome nas suas interfaces (para deixar tudo organizado)
- coloque ip nas interfaces (na interface que vai ligar o BFW deixe assim: 192.168.201.1/30 setado na interface do BFW)
- crie a rota para internet
- va no terminal e adicione essas regras:

/ip firewall filter
add action=accept chain=forward comment="Aceita BFW" disabled=no \
   src-address=192.168.201.0/30

/ip firewall nat
add action=dst-nat chain=dstnat comment="Redirect BFW Cache" disabled=yes \
   dst-port=80 protocol=tcp src-address=”coloque o ip da placa de seus clientes” to-addresses=\
   192.168.201.2 to-ports=3129

/ip firewall mangle
add action=mark-connection chain=postrouting comment="BFW CACHE FULL =====\
   ==========================================================================\
   =======================" content="X-Cache: HIT from BFW Cache" disabled=no \
   new-connection-mark=bfw-connection passthrough=yes protocol=tcp \
   src-address=192.168.201.2
add action=mark-packet chain=postrouting comment="" connection-mark=\
   bfwcache-connection disabled=no new-packet-mark=bfwcache-packs passthrough=\
   yes
add action=mark-connection chain=postrouting comment="TOS 12==================\
   ==========================================================================\
   =========================" disabled=no dscp=12 new-connection-mark=\
   proxy-hits passthrough=yes protocol=tcp src-address=192.168.201.2
add action=mark-packet chain=postrouting comment="" connection-mark=\
   proxy-hits disabled=no new-packet-mark=proxy-squid passthrough=yes

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
   max-limit=100M name="T -cache_hits" packet-mark=proxy-squid parent=\
   global-out priority=4 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
   max-limit=100M name=BFW Cache packet-mark=bfwcache-packs parent=\
   global-out priority=4 queue=default

/ip firewall address-list
add address=69.147.95.0/24 comment="\"\"\"\"YAHOO MAIL\"\"\"\"" disabled=no \
   list=nobalance
add address=209.191.106.0/24 comment="\"\"\"\"YAHOO MAIL\"\"\"\"" disabled=no \
   list=nobalance
add address=74.6.228.0/24 comment="\"\"\"\"YAHOO MAIL\"\"\"\"" disabled=no \
   list=nobalance
add address=98.136.131.0/24 comment="\"\"\"\"YAHOO MAIL\"\"\"\"" disabled=no \
   list=nobalance
add address=200.143.37.0/24 comment="\"\"\"\"WEBMOTORS\"\"\"\"" disabled=no \
   list=nobalance
add address=65.54.0.0/16 comment=MSN1 disabled=no list=nobalance
add address=207.46.0.0/16 comment=MSN2 disabled=no list=nobalance
add address=64.4.0.0/16 comment=MSN3 disabled=no list=nobalance
add address=200.143.0.0/16 comment=Pagdigital disabled=no list=nobalance
add address=201.88.0.0/16 comment=f2b disabled=no list=nobalance
add address=200.201.0.0/16 comment="caixa economica" disabled=no list=\
   nobalance
add address=170.66.0.0/16 comment="bb do brasil" disabled=no list=nobalance
add address=200.155.0.0/16 comment=bradesco disabled=no list=nobalance
add address=200.196.0.0/16 comment=itau disabled=no list=nobalance
add address=200.208.0.0/16 comment=sudameris disabled=no list=nobalance
add address=200.220.0.0/16 comment=santander disabled=no list=nobalance
add address=201.63.0.0/16 comment="wwws bradesco" disabled=no list=nobalance
add address=65.55.0.0/16 comment=MSN4 disabled=no list=nobalance
add address=74.52.0.0/16 comment="caixa economica" disabled=no list=nobalance
add address=174.133.0.0/16 comment="caixa economica" disabled=no list=\
   nobalance
add address=200.219.137.0/24 comment="" disabled=no list=nobalance
add address=200.252.8.0/24 comment="" disabled=no list=nobalance
add address=201.2.207.0/24 comment="" disabled=no list=nobalance
add address=200.196.226.0/24 comment="" disabled=no list=nobalance
add address=201.24.72.0/24 comment="" disabled=no list=nobalance
add address=78.46.46.139 comment="" disabled=no list=nobalance

/ip firewall nat
add action=accept chain=dstnat comment=\
   "\"\"\"\"\"\"Sites FORA DO PROXY\"\"\"\"\"\"" disabled=no \
   dst-address-list=nobalance dst-port=80 protocol=tcp

pronto se tudo deu certo abra um navegador e digite o endereço ip do BFW (192.168.201.2:8181) você terá acesso ao webmin do servidor de cachê.
Agora faça o teste você tem um servidor MK controlando a sua rede e um servidor BFW fazendo cachê paralelo.

Agradeço ao Chicao por ter me ajudado e ao Geronimo por ter postado o vídeo cachê full
 É isso ai flw pessoal


Isso não é cascata, isso é paralelo 

superninja007
Baby
Baby

Mensagens : 3
Pontos : 3
Reputação : 0
Data de inscrição : 02/12/2012
Idade : 30
Localização Localização : casa

Voltar ao Topo Ir em baixo

Re: Cache paralelo entre um MK e um BFW

Mensagem por spo102 em Seg 19 Maio - 19:07

esse regras aqui são pra versão do mikrotik 6.12


mk versao 6.x

/ip firewall nat
add action=masquerade chain=srcnat comment="nat link" out-interface=link src-address=192.168.136.0/24
add action=masquerade chain=srcnat comment="nat bfw" out-interface=link src-address=192.168.25.0/30
add action=dst-nat chain=dstnat comment="redirecionar para o proxy" dst-address-list=!sem_proxy dst-port=80 protocol=tcp src-address-list=proxy to-addresses=192.168.25.2 to-ports=3129

/ip firewall mangle
add action=mark-connection chain=postrouting comment="proxy hits" content="X-Cache: HIT" new-connection-mark=proxy-hit
add action=mark-packet chain=postrouting connection-mark=proxy-hit new-packet-mark=proxy-hits
add action=mark-connection chain=postrouting comment="proxy tos12" dscp=12 new-connection-mark=tos-12 protocol=tcp
add action=mark-packet chain=postrouting connection-mark=tos-12 new-packet-mark=proxy-tos12

/ip firewall address-list
add address=192.168.136.0/24 comment=clientes list=proxy
add address=192.168.25.2 comment=proxy list=sem_proxy
add address=54.207.52.0/24 comment=raidcall disabled=yes list=sem_proxy

/queue type
add kind=pcq name=cachefull pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=20M pcq-src-address6-mask=64

/queue simple
add name=cachefull packet-marks=proxy-tos12 queue=cachefull/cachefull target=""


mk versao 5.x

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=2M name="Proxy" packet-marks=proxy-tos12 parent=global-out priority=4 queue=default

spo102
Iniciante
Iniciante

Mensagens : 42
Pontos : 52
Reputação : 4
Data de inscrição : 09/04/2011
Idade : 37
Localização Localização : pernambuco

Voltar ao Topo Ir em baixo

Re: Cache paralelo entre um MK e um BFW

Mensagem por jardelpxn em Seg 16 Jun - 15:13

Configurei tudo de acordo, mas quando vou acessar o BFW, e verifico a internet na interface pela qual o cabo esta conectado, apresenta a seguinte mensagem
"AGUARDANDO CONEXÃO" alguém já passou por isso?
minha topologia esta assim
[Você precisa estar registrado e conectado para ver este link.]

jardelpxn
Baby
Baby

Mensagens : 1
Pontos : 1
Reputação : 0
Data de inscrição : 22/07/2011
Idade : 29
Localização Localização : Campina Grande

Voltar ao Topo Ir em baixo

Re: Cache paralelo entre um MK e um BFW

Mensagem por Conteúdo patrocinado Hoje à(s) 9:29


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Página 4 de 4 Anterior  1, 2, 3, 4

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum