Conectar-se

Esqueci minha senha

lateral
Estatísticas
Temos 30331 usuários registrados
O último usuário registrado atende pelo nome de deniscross

Os nossos membros postaram um total de 37735 mensagens em 5672 assuntos

[Resolvido]MIKROTIK + SCRIPT NO-IP

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

MIKROTIK + SCRIPT NO-IP

Mensagem por jefy.casteller em Sex 31 Ago - 13:07

Bom dia galera!
Seguinte estou precisando fazer o meu mikrotik rodar um script para o NO-IP ou seja, não tenho ip fixo porem tenho cadastro no site no-ip e estou usando porem uso o software e agora preciso de um Script atualizar meu IP-FIXO no HOST determinado

Minha rede roda assim:

MODEM EM DMZ ==> MIKROTIK ==> SWITCH ==> MICROS
192.168.1.1 com DMZ para 192.168.1.254 no MK ETHER1 192.168.1.254/24 e sai 10.1.1.1/24 NA ETHER5

JA VI UM SCRIPT E VOU POSTAR AQUI POREM ESTOU COM PROBLEMA NA porta de saida que o script péga:

# No-IP automatic Dynamic DNS update

#--------------- Change Values in this section to match your setup ------------------

# No-IP User account info
:local noipuser "Login do site"
:local noippass "Senha do site"

# Set the hostname or label of network to be updated.
# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
# To specify multiple hosts, separate them with commas.
:local noiphost "host.malware-site.www ou o definido"

# Change to the name of interface that gets the dynamic IP address
:local inetinterface "aqui esta o problema!"

#------------------------------------------------------------------------------------
# No more changes need

:global previousIP

:if ([/interface get $inetinterface value-name=running]) do={
# Get the current IP on the interface
:local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address]

# Strip the net mask off the IP address
:for i from=( [:len $currentIP] - 1) to=0 do={
:if ( [:pick $currentIP $i] = "/") do={
:set currentIP [:pick $currentIP 0 $i]
}
}

:if ($currentIP != $previousIP) do={
:log info "No-IP: Current IP $currentIP is not equal to previous IP, update needed"
:set previousIP $currentIP

# The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands.
:local url "http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP"
:local noiphostarray
:set noiphostarray [:toarray $noiphost]
:foreach host in=$noiphostarray do={
:log info "No-IP: Sending update for $host"
/tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt")
:log info "No-IP: Host $host updated on No-IP with IP $currentIP"
}
} else={
:log info "No-IP: Previous IP $previousIP is equal to current IP, no update needed"
}
} else={
:log info "No-IP: $inetinterface is not currently running, so therefore will not update."
}

jefy.casteller
Iniciante
Iniciante

Mensagens : 49
Pontos : 74
Reputação : 7
Data de inscrição : 30/06/2012
Idade : 30
Localização Localização : turvo

Voltar ao Topo Ir em baixo

Re: [Resolvido]MIKROTIK + SCRIPT NO-IP

Mensagem por ZBTECK em Sex 31 Ago - 20:33

jefy.casteller escreveu:...
:local inetinterface "aqui esta o problema!"...

Mude para:
:global inetinterface "coloque o nome da interface PPPoE"

ou mude todas as ocorrencias de "$inetinterface" para coloque o nome da interface PPPoE

ZBTECK
Power User
Power User

Mensagens : 930
Pontos : 1117
Reputação : 186
Data de inscrição : 11/04/2011
Idade : 29
Localização Localização : São Paulo

Voltar ao Topo Ir em baixo

Ainda nao funciona!

Mensagem por jefy.casteller em Ter 4 Set - 16:47

ZBTECK escreveu:
jefy.casteller escreveu:...
:local inetinterface "aqui esta o problema!"...

Mude para:
:global inetinterface "coloque o nome da interface PPPoE"

ou mude todas as ocorrencias de "$inetinterface" para coloque o nome da interface PPPoE


Bah amigo ainda não funciona!

jefy.casteller
Iniciante
Iniciante

Mensagens : 49
Pontos : 74
Reputação : 7
Data de inscrição : 30/06/2012
Idade : 30
Localização Localização : turvo

Voltar ao Topo Ir em baixo

Re: [Resolvido]MIKROTIK + SCRIPT NO-IP

Mensagem por ZBTECK em Ter 4 Set - 18:13

Qual o erro que ocorre? Testei aqui e funcionou!

Tem que ser o no-ip? Tente o changeip com o script abaixo (antes, faça cadastro no site):

/tool dns-update name=NOME DO HOST NO CHANGEIP address=127.0.0.255 key-name=NOME DO USUARIO key="SENHA"

ZBTECK
Power User
Power User

Mensagens : 930
Pontos : 1117
Reputação : 186
Data de inscrição : 11/04/2011
Idade : 29
Localização Localização : São Paulo

Voltar ao Topo Ir em baixo

RESOLVIDO

Mensagem por jefy.casteller em Ter 4 Set - 18:57

ZBTECK escreveu:Qual o erro que ocorre? Testei aqui e funcionou!

Tem que ser o no-ip? Tente o changeip com o script abaixo (antes, faça cadastro no site):

/tool dns-update name=NOME DO HOST NO CHANGEIP address=127.0.0.255 key-name=NOME DO USUARIO key="SENHA"

Meu amigo funcionou certinho eu até ja tinha visto esse script mas não tinha testado, agora fiz com o teu e deu perfeito.

Eu queria o NO-IP pois la tenho conta Paga!
Mais mesmo assim vlw em muito obrigado mesmo

jefy.casteller
Iniciante
Iniciante

Mensagens : 49
Pontos : 74
Reputação : 7
Data de inscrição : 30/06/2012
Idade : 30
Localização Localização : turvo

Voltar ao Topo Ir em baixo

MIKROTIK + CHANGE IP

Mensagem por jefy.casteller em Ter 4 Set - 19:08

Obrigado pela ajuda!

jefy.casteller
Iniciante
Iniciante

Mensagens : 49
Pontos : 74
Reputação : 7
Data de inscrição : 30/06/2012
Idade : 30
Localização Localização : turvo

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum