Conectar-se

Esqueci minha senha

lateral
Estatísticas
Temos 30345 usuários registrados
O último usuário registrado atende pelo nome de edjorge

Os nossos membros postaram um total de 37737 mensagens em 5673 assuntos

MK+SQUID3 [cache+proxy]

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

MK+SQUID3 [cache+proxy]

Mensagem por netomaster em Sex 7 Set - 14:19

Ola a todos recentemente resouvi montar um squid[cache+proxy]
Esta funcionando perfeitamente so que esta fazendo cache de todos os sites
so que estou na necesidade de declarar os sites que faram parte do cache alguem poderia dar uma maozinha aqui

ex: youtube.com google.com oul.com ig.com globo.com etc

segue meu squid.conf

## Squid.conf gerado por nitrox : [Você precisa estar registrado e conectado para ver este link.] -----------##
## Contato (73) 8807-1465 -----------------------##

# Diretorio de da liguagem da mensagen erro
error_directory /usr/share/squid3/errors/pt-br/

# Porta do Proxy
http_port 5128 intercept

# Nome do HOST
visible_hostname MagicNet

# Memoria reservada para o cache, coloque um valor de preferencia 40%
# do total da sua maquina, e não mais.
cache_mem 100 MB

# Máximo tamanho dos arquivo cache na memoria
maximum_object_size_in_memory 32 KB

# Máximo tamanho dos arquivo cache no hd
maximum_object_size 100 MB
minimum_object_size 0 KB

# Regra que começa a esvaziar / substituir arquivos no cache em 90%
cache_swap_low 90
cache_swap_high 95

# Indicação de localização da pasta de arquivos cache e em sequência valor
# total em MB de espaço no hd a ser usado pelo cache, numero de pastas, e
# numero de subpastas do cache.
cache_dir ufs /var/spool/squid3 50048 16 256

# Logs de acesso
access_log /var/log/squid3/access.log squid

# E-mail de exibiçao
cache_mgr [Você precisa estar registrado e conectado para ver este link.]

# Regras acl padrão
acl manager proto cache_object
acl localhost src 127.0.0.1/32

acl SSL_ports port 443 563
acl Safe_ports port 70 #protocolo gopher antigão
acl Safe_ports port 80 #HTTP Port
acl Safe_ports port 21 #SSHE FTP
acl Safe_ports port 443 563
acl Safe_ports port 210 #whais
acl Safe_ports port 280 #http-mgmt
acl Safe_ports port 488 #gss-http
acl Safe_ports port 591 #filemaker
acl Safe_ports port 777 #multi http
acl Safe_ports port 901 #acesso Swat
acl Safe_ports port 1024-65535 #todas as outras portas
acl purge method PURGE
acl CONNECT method CONNECT

# Permissões e bloqueios padrão
http_access allow manager localhost
http_access deny manager
http_access allow localhost
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports

# CACHE de Arquivos
acl downloads urlpath_regex "/etc/squid3/regras/downloads"
http_access allow downloads

# Aruivos Fora Do Cache
acl cache urlpath_regex "/etc/squid3/regras/semcache"?
no_cache deny cache

# Bloqueio de sites por URL
acl sites_proibidos url_regex -i "/etc/squid3/regras/sites_proibidos"
http_access deny sites_proibidos

# Permissão de acesso ao proxy, rede do Mikrotik
# Classe de rede ou classes separadas por espaços.
acl redelocal src 192.168.10.0/30, 192.168.2.0/24, 192.168.7.0/24
http_access allow localhost
http_access allow redelocal

# Bloquear todos outros acessos.
http_access deny all

# Intervalos de tempos que o proxy verificara os arquivos dos site acessado
# conferem com o do cache, o valor 4560 significa 04 dias
refresh_pattern ^ftp: 15 20% 4560
refresh_pattern ^gopher: 15 0% 4560
refresh_pattern . 15 20% 4560

# Mantendo objetos recentes e pequenos na memoria
memory_replacement_policy heap GDSF

# Ativando pools de memoria, evitando o Squid ficar realocando memoria toda
# hora que precisar, manter pools de 32MB
# memory_pools off
# memory_pools_limit 0


iformaçoes:
192.168.10.0/30 Rage Ip do cache
192.168.2.0/24 Range IP Porta WAM
192.168.7.0/24 Range IP Clientes

Alguem poderia mim ajudar ?

netomaster
Iniciante
Iniciante

Mensagens : 36
Pontos : 57
Reputação : 5
Data de inscrição : 02/01/2012
Idade : 30
Localização Localização : brasil

Voltar ao Topo Ir em baixo

Re: MK+SQUID3 [cache+proxy]

Mensagem por paulosjbv em Sab 8 Set - 9:46

"Esta funcionando perfeitamente so que esta fazendo cache de todos os sites
so que estou na necesidade de declarar os sites que faram parte do cache alguem poderia dar uma maozinha aqui"
nao entendi.
voçe quer declarar os sites que irao para o proxy? é isso?

paulosjbv
Iniciante
Iniciante

Mensagens : 74
Pontos : 85
Reputação : 3
Data de inscrição : 30/06/2012
Idade : 39
Localização Localização : aguai

Voltar ao Topo Ir em baixo

Re: MK+SQUID3 [cache+proxy]

Mensagem por netomaster em Sab 8 Set - 14:30

Isso mesmo

netomaster
Iniciante
Iniciante

Mensagens : 36
Pontos : 57
Reputação : 5
Data de inscrição : 02/01/2012
Idade : 30
Localização Localização : brasil

Voltar ao Topo Ir em baixo

Re: MK+SQUID3 [cache+proxy]

Mensagem por paulosjbv em Sab 8 Set - 14:45

mas o proxy ja faz todo o cache que passa por ele nao precisa declarar um site para ele fazer cache.
voçe pode é dizer ao proxy para nao fazer cache de um determinado site.
é isso?

paulosjbv
Iniciante
Iniciante

Mensagens : 74
Pontos : 85
Reputação : 3
Data de inscrição : 30/06/2012
Idade : 39
Localização Localização : aguai

Voltar ao Topo Ir em baixo

Re: MK+SQUID3 [cache+proxy]

Mensagem por netomaster em Sab 8 Set - 19:07

paulosjbv escreveu:mas o proxy ja faz todo o cache que passa por ele nao precisa declarar um site para ele fazer cache.
voçe pode é dizer ao proxy para nao fazer cache de um determinado site.
é isso?

Poderia ser assim também

Que ficaria todos no Proxy com exceção dos sites declarados

Tipo: gmail.com hotmail.com etc e sites de banco ...

netomaster
Iniciante
Iniciante

Mensagens : 36
Pontos : 57
Reputação : 5
Data de inscrição : 02/01/2012
Idade : 30
Localização Localização : brasil

Voltar ao Topo Ir em baixo

Re: MK+SQUID3 [cache+proxy]

Mensagem por paulosjbv em Dom 9 Set - 11:05

vamos la entao
va na pasta do squid e crie um arquivo de texto comum ex:sites-liberados
depois va no squid.conf e coloque estas regras
(acl site-liberados url_regex -i "local onde esta oarquivo que voçe criou"
http_access allow site-liberados)
agora é so ir neste arquivo e adicionar os sites que voçe quer que o proxy nao faça cache.

outra forma
(acl site-liberados dstdomain -i "local onde esta o arquivo que voçe criou"
no_cache deny site-liberados)
eu ja usei das 2 formas e funcionou ainda mais com sites de banco que geralmente nao fazemos cache

paulosjbv
Iniciante
Iniciante

Mensagens : 74
Pontos : 85
Reputação : 3
Data de inscrição : 30/06/2012
Idade : 39
Localização Localização : aguai

Voltar ao Topo Ir em baixo

Re: MK+SQUID3 [cache+proxy]

Mensagem por netomaster em Dom 9 Set - 12:57

Certinho so mais uma duvida minha sobre o queue e o mangle


Eu fis dessa forma


MANGLE

/ip firewall mangle
add action=mark-connection chain=output comment="CACHE FULL" content=\
"X-Cache: HIT" disabled=no new-connection-mark=conn_squid-up passthrough=\
yes protocol=tcp src-port=3128
add action=mark-packet chain=output connection-mark=conn_squid-up disabled=no \
new-packet-mark=pacotes_squid-up passthrough=yes
add action=mark-connection chain=prerouting disabled=no dst-port=3128 \
new-connection-mark=conn_squid-down passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting connection-mark=conn_squid-down \
disabled=no new-packet-mark=pacotes_squid-down passthrough=yes


Queue Tree

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=0 name="[CACHE-FULL] - Download" packet-mark=pacotes_squid-down \
parent=global-in priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=50M name="[CACHE-full] - Upload" packet-mark=pacotes_squid-up \
parent=global-out priority=1 queue=default

Esta cofig esta correta ?

netomaster
Iniciante
Iniciante

Mensagens : 36
Pontos : 57
Reputação : 5
Data de inscrição : 02/01/2012
Idade : 30
Localização Localização : brasil

Voltar ao Topo Ir em baixo

Re: MK+SQUID3 [cache+proxy]

Mensagem por paulosjbv em Dom 9 Set - 23:58

nao sei se essa sua config vai funcionar pois nao tive tempo de testar mas se for um redirecionamento para um cache paralelo eu utilizo assim:


###Redireciona Thunder Via Mangle e Regra Cache Full

/ip firewall mangle
add action=mark-routing chain=prerouting comment="REDIRECT THUNDERCACHE" \
disabled=no dst-address-list=!NO_CACHE dst-port=80 in-interface=!Thunder \
new-routing-mark=Thunder_router passthrough=no protocol=tcp src-address=\
192.168.10.0/24
add action=mark-packet chain=postrouting comment="CACHE FULL THUNDER 7" \
disabled=no dscp=18 new-packet-mark="cache full" passthrough=yes

### Habilita Limite CACHE FULL

/queue type
add kind=pcq name=Thunder pcq-classifier=dst-address pcq-limit=50 pcq-rate=0 \
pcq-total-limit=5000000
set default-small kind=pfifo name=default-small pfifo-limit=10

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=10M name="CACHE FULL" packet-mark="cache full" parent=\
global-out priority=8 queue=Thunder

paulosjbv
Iniciante
Iniciante

Mensagens : 74
Pontos : 85
Reputação : 3
Data de inscrição : 30/06/2012
Idade : 39
Localização Localização : aguai

Voltar ao Topo Ir em baixo

Re: MK+SQUID3 [cache+proxy]

Mensagem por netomaster em Seg 10 Set - 12:42

paulosjbv escreveu:nao sei se essa sua config vai funcionar pois nao tive tempo de testar mas se for um redirecionamento para um cache paralelo eu utilizo assim:


###Redireciona Thunder Via Mangle e Regra Cache Full

/ip firewall mangle
add action=mark-routing chain=prerouting comment="REDIRECT THUNDERCACHE" \
disabled=no dst-address-list=!NO_CACHE dst-port=80 in-interface=!Thunder \
new-routing-mark=Thunder_router passthrough=no protocol=tcp src-address=\
192.168.10.0/24
add action=mark-packet chain=postrouting comment="CACHE FULL THUNDER 7" \
disabled=no dscp=18 new-packet-mark="cache full" passthrough=yes

### Habilita Limite CACHE FULL

/queue type
add kind=pcq name=Thunder pcq-classifier=dst-address pcq-limit=50 pcq-rate=0 \
pcq-total-limit=5000000
set default-small kind=pfifo name=default-small pfifo-limit=10

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=10M name="CACHE FULL" packet-mark="cache full" parent=\
global-out priority=8 queue=Thunder

Mano o script acima nem Pegou nao tive comunicaçao com Squid nao
pederia manda add ei [Você precisa estar registrado e conectado para ver este link.]

netomaster
Iniciante
Iniciante

Mensagens : 36
Pontos : 57
Reputação : 5
Data de inscrição : 02/01/2012
Idade : 30
Localização Localização : brasil

Voltar ao Topo Ir em baixo

Re: MK+SQUID3 [cache+proxy]

Mensagem por paulosjbv em Seg 10 Set - 12:44

diga o que aconteceu deu erro? ou foi so a comunicaçao com o squid? com suas regras estava funcionando?

paulosjbv
Iniciante
Iniciante

Mensagens : 74
Pontos : 85
Reputação : 3
Data de inscrição : 30/06/2012
Idade : 39
Localização Localização : aguai

Voltar ao Topo Ir em baixo

Re: MK+SQUID3 [cache+proxy]

Mensagem por paulosjbv em Seg 10 Set - 12:47

essas regras nao sao para comunicaçao heim sao apenas para marcaçao de pacotes e limite de saida do seu cache verifique suas regras ai de filter e de nat

paulosjbv
Iniciante
Iniciante

Mensagens : 74
Pontos : 85
Reputação : 3
Data de inscrição : 30/06/2012
Idade : 39
Localização Localização : aguai

Voltar ao Topo Ir em baixo

Re: MK+SQUID3 [cache+proxy]

Mensagem por netomaster em Qua 12 Set - 0:54

Bom tive que refazer minha rede agora to com um problema uso hotspot so q esta limitando o proxy
poderia ajudar a resouver isso ?

montei minha estrutura em VMWare para testes

netomaster
Iniciante
Iniciante

Mensagens : 36
Pontos : 57
Reputação : 5
Data de inscrição : 02/01/2012
Idade : 30
Localização Localização : brasil

Voltar ao Topo Ir em baixo

Re: MK+SQUID3 [cache+proxy]

Mensagem por paulosjbv em Qua 12 Set - 2:05

muda na regra de redirecionamento em
CHAIN=coloque pre-hotspot e em extra hotspot coloque AUTH

paulosjbv
Iniciante
Iniciante

Mensagens : 74
Pontos : 85
Reputação : 3
Data de inscrição : 30/06/2012
Idade : 39
Localização Localização : aguai

Voltar ao Topo Ir em baixo

Re: MK+SQUID3 [cache+proxy]

Mensagem por netomaster em Qua 12 Set - 2:58

CHAIN=coloque pre-hotspot e em extra hotspot coloque AUTH
Continua no controle da banda

netomaster
Iniciante
Iniciante

Mensagens : 36
Pontos : 57
Reputação : 5
Data de inscrição : 02/01/2012
Idade : 30
Localização Localização : brasil

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum