Conectar-se

Esqueci minha senha

Estatísticas
Temos 31155 usuários registrados
O último usuário registrado atende pelo nome de INFORTECH001

Os nossos membros postaram um total de 38072 mensagens em 5746 assuntos

DUVIDA DO CHANGE IP

Ir em baixo

DUVIDA DO CHANGE IP

Mensagem por regialvessousa em Sab 6 Out - 15:16

Estou com dois Mk mikrotik
1ª e RB750 estou rondando o script de acesso remoto nela mais ñ pegar.
2ª e outro e um pc nele o script do acesso remoto funcionar OK.
dar uma olhadada no script e o mesmo, para os dois
minha duvida e o changeip so aceita um DDNS. valew pela força.

# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# DEFINIÇÂO DA CONTA DDNS
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
:global ddnsuser "MEU USUARIO"
:global ddnspass "MINHA SENHA"
:global ddnshost "AQUI SAO OS DDNS CRIADO PARA CADA MK"
:global ddnsinterface "MINHA INTERFACE"
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# FNAL DA DEFINIÇÃO
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

:global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
:global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
:global ddnslastip
:if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: No interface named $ddnsinterface, please check configuration." }
:if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }
:if ([ :typeof $ddnsip ] = "nothing" ) do={
:log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
} else={
:if ($ddnsip != $ddnslastip) do={
:log info "O DDNS foi atualizado com sucesso!"
:log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
:global ddnslastip $ddnsip
} else={
:log info "Não foi preciso atualizar o DDNS."
}
}
# FINAL DO SCRIPT
avatar
regialvessousa
Iniciante
Iniciante

Mensagens : 63
Pontos : 82
Reputação : 1
Data de inscrição : 25/01/2012
Idade : 33
Localização Localização : brasilia

Voltar ao Topo Ir em baixo

Re: DUVIDA DO CHANGE IP

Mensagem por ZBTECK em Sab 6 Out - 16:20

Se criou dois dominios no ChangeIP deveria atualizar ambos.
Pode ser que o script não funcione em determinada versão do mikrotik. Está com a mesma versão em ambos?

__________________________________________________
Contato Skype zbteck_ltda

ZBTECK
Power User
Power User

Mensagens : 930
Pontos : 1117
Reputação : 186
Data de inscrição : 11/04/2011
Idade : 30
Localização Localização : São Paulo

Voltar ao Topo Ir em baixo

Re: DUVIDA DO CHANGE IP

Mensagem por regialvessousa em Sab 6 Out - 17:10

sim criei dois dominio a versão deles são 5,17
avatar
regialvessousa
Iniciante
Iniciante

Mensagens : 63
Pontos : 82
Reputação : 1
Data de inscrição : 25/01/2012
Idade : 33
Localização Localização : brasilia

Voltar ao Topo Ir em baixo

Re: DUVIDA DO CHANGE IP

Mensagem por ZBTECK em Sab 6 Out - 17:25

Ambos são servidores?
O IP da RB atualiza lá no site do changeip ou da erro no script?


Já testou com o script abaixo (substitua negrito com seus dados):
Obs: Faça o schedule de ambos com boa diferença de tempo.

/tool dns-update name=DDNS address=127.0.0.255 key-name=NOME_DDNS key="SENHA_DDNS"

ZBTECK
Power User
Power User

Mensagens : 930
Pontos : 1117
Reputação : 186
Data de inscrição : 11/04/2011
Idade : 30
Localização Localização : São Paulo

Voltar ao Topo Ir em baixo

Re: DUVIDA DO CHANGE IP

Mensagem por regialvessousa em Dom 7 Out - 10:25

vou tenta assim que chegar em casa
avatar
regialvessousa
Iniciante
Iniciante

Mensagens : 63
Pontos : 82
Reputação : 1
Data de inscrição : 25/01/2012
Idade : 33
Localização Localização : brasilia

Voltar ao Topo Ir em baixo

Re: DUVIDA DO CHANGE IP

Mensagem por rtbasilio em Ter 16 Out - 12:49

amigo tenta esse script, pode ser que funcione..

Script

/tool dns-update name=DDNS address=127.0.0.255 key-name=LOGIN_CHANGEIP key=SENHA_CHANGEIP

e também faça o:

Schedule (com esse comando vc escolhe o intervalo repetir o script)

/system script run DDNS (lembrando DDNS é o nome do script...rsrs)


espero ter ajudado...
avatar
rtbasilio
Baby
Baby

Mensagens : 5
Pontos : 7
Reputação : 0
Data de inscrição : 26/08/2011
Idade : 38
Localização Localização : São Paulo

Voltar ao Topo Ir em baixo

Re: DUVIDA DO CHANGE IP

Mensagem por Rubens Bueno em Qui 28 Mar - 12:39

OLÁ PESSOAL! FIZ ESTES SCRIPTS NA MINHA RB 450 G V5.18 CONECTADO VIA PPPOE E NÃO FUNCIONOU.QUANDO VOU ACESSAR DÁ: invalid address - meu ddns. JA VERIFIQUEI O DOMINIO CRIADO NO CHANGE IP E CONSTA COMO ATIVO.

FIZ ASSIM:

/tool dns-update name=dominio criado no changeip address=127.0.0.255 key-name=login da rb key="senha da rb"

Rubens Bueno
Baby
Baby

Mensagens : 5
Pontos : 7
Reputação : 0
Data de inscrição : 27/03/2013
Idade : 30
Localização Localização : AGUAS LINDAS

Voltar ao Topo Ir em baixo

Re: DUVIDA DO CHANGE IP

Mensagem por infomania em Dom 18 Jun - 14:45

Eu uso changeip normal aqui a alguns anos. 
Clika ai no shedule, faz ele roda....atualizar. 
Confere seu ip no site MEUIP. E depois confere se o ip atualizou la dentro
do site changeip, no seu host. Que tbm da pra setar la seu ip.

infomania
Iniciante
Iniciante

Mensagens : 40
Pontos : 46
Reputação : 0
Data de inscrição : 09/07/2011
Idade : 35
Localização Localização : Brasil

Voltar ao Topo Ir em baixo

Re: DUVIDA DO CHANGE IP

Mensagem por claudinhohw Network em Seg 26 Jun - 20:19

com as novas versões do mikrotik vc não precisa usar nada basta ir em ip cloud e habilitar, ai vai aparecer seu ddns. ai e só usa-lo para acessar direcionar portas etc... ele só muda se vc trocar a rb. se não ele fica fixo em quanto vc usa-la.

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik
avatar
claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2766
Pontos : 3420
Reputação : 595
Data de inscrição : 28/08/2010
Idade : 33
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Re: DUVIDA DO CHANGE IP

Mensagem por Conteúdo patrocinado


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum