Conectar-se

Esqueci minha senha

lateral
Estatísticas
Temos 30563 usuários registrados
O último usuário registrado atende pelo nome de assocAIRR

Os nossos membros postaram um total de 37838 mensagens em 5692 assuntos

[TUTORIAL] Backup e Log por email..

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

[TUTORIAL] Backup e Log por email..

Mensagem por rtbasilio em Ter 19 Fev - 12:34

Venho fazer uma pequena contribuição para os amigos... pois, o pouco que aprendi aqui e ali... gostaria de compartilhar com galera... sou iniciante ainda, espero que, o que eu crei ajude alguns amigos do fórum...

Vamos lá... o tutorial é o seguinte vamos começar com acertar o fuso horário da sua região...

Vá em

System>NTP Client

Marque a opção Enable
Mode: Unicast
Primary NTP Server: 200.192.232.8
Secondary NTP Server: 200.160.0.8
Clique em Apply e Ok

Depois vá em

System>NTP Server
Marque a opção Multicast
Clique em Apply e Ok

Depois vá em

System>Clock

Time Zone Name: America/Sao_Paulo (no meu caso coloquei são paulo)
Clique em Apply e Ok

Depois hora de configurar e-mail...

Vá em

Tool>Email

Server: smtp.gmail.com ou coloque o ip do seu "smtp" no meu (caso meu caso coloque o gmail)
Port: 587 (no meu caso coloquei 587)
From: [Você precisa estar registrado e conectado para ver este link.]
User: [Você precisa estar registrado e conectado para ver este link.]
Password: sua senha do seu email

Agora vamos aos Scripts

Vá em

System>Scripts

Segue o primeiro script "fazer e enviar backup"

Marque todas as caixinhas de seleção

Depois vá em

Name: fazer-e-enviar-backup
Source: /system backup save name=backup-mikrotik.backup
:delay 8s
:global data [/system clock get date]
:global hora [/system clock get time]
/tool e-mail send to="EMAIL PARA QUAL SERA ENVIADO O BACKUP"
subject="Backup do Mikrotik NOME_DA_ESTAÇÃO dia: $data as
$hora" file="backup-mikrotik.backup" body="Backup
automatico do servidor Mikrotik-NOME_DA_ESTAÇÃO realizado as $hora de
$data."

clique em Apply e Ok

Vamos ao segundo script "fazer e enviar log"

Marque todas as caixinhas de seleção

Name:fazer-e-enviar-log
Source: /log print file=log-mikrotik.txt
:delay 2s
:global data [/system clock get date]
:global hora [/system clock get time]
/tool e-mail send to="EMAIL PARA QUAL SERA ENVIADO O LOG"
subject="Log do MK-NOME_DA_ESTAÇÃO dia: $data as $hora"
file="log-mikrotik.txt" body="Backup automatico do log do
servidor Mikrotik-NOME_DA_ESTAÇÃO realizado as $hora de $data."

Clique em Apply e Ok


Obs: coloquei NOME_DA_ESTAÇÃO,
porque se alguns dos amigo tiver + de um mk é só inserir o nome dela,
assim na hora do backup ou log, quando enviado por email, ficará facil
identificar qual mk foi feito o backup ou log...

Até agora fizemos os scripts, agora vamos fazer a automatização de de execução dos scripts... através do scheduler...

Vamos aos agendamentos automáticos para executar os scripts..

Vá em

System>Scheduler

Vamos ao primeiro schedule "Envio de backup via email"

Name:Envio de Backup por e-mail
Interval: 06:00:00 (esse é o intelavalo de envio do email, coloquei no exemplo cada 6 horas + os amigo podem alterar de acordo com a necessidade)
On Event: /system script run fazer-e-enviar-backup
Marque todas as caixinhas de seleção

Clique em Apply e Ok..

Vamos ao segundo schedule "Envio de log via email"

Name: Envio de log por e-mail
Interval: 06:00:00 (esse é o intelavalo de envio do email,
coloquei no exemplo cada 6 horas + os amigo podem alterar de acordo com a
necessidade)
On Event: /system script run fazer-e-enviar-log
Marque todas as caixinhas de seleção

Clique em Apply e Ok..

---------------

Amigos finalizamos todo o processo, testei no meu MK, funcionou tudo corretamente, acredito que no MK de vocês, funcione perfeitamente também, aqui finalizo meu primeiro passo passo... espero ter ajudado algum de nossos amigos....

FIM

Obs: Meu MK é o v3.30, acredito que funcione apartir do v3.xx pra cima...se algum amigo testar e funcionar postem aqui o resultado....ok...

abs a todos...
Ricardo
avatar
rtbasilio
Baby
Baby

Mensagens : 5
Pontos : 7
Reputação : 0
Data de inscrição : 26/08/2011
Idade : 38
Localização Localização : São Paulo

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum