Conectar-se

Esqueci minha senha

lateral
Estatísticas
Temos 30804 usuários registrados
O último usuário registrado atende pelo nome de tiagogarcezz

Os nossos membros postaram um total de 37897 mensagens em 5713 assuntos

Aviso de Manutenção quando o link cair

Página 2 de 4 Anterior  1, 2, 3, 4  Seguinte

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Aviso de Manutenção quando o link cair

Mensagem por claudinhohw Network em Seg 1 Nov - 9:36

Relembrando a primeira mensagem :

Olá amigos! gostaria de saber como faço pra criar uma regra para quando o link ou a internet cair ou parar de funcionar por algum motivo o mk mande uma mensagem de "sistema em manutenção" seria possivel fazer isso? desde já grato!
avatar
claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2702
Pontos : 3341
Reputação : 582
Data de inscrição : 28/08/2010
Idade : 33
Localização Localização : Goiás

Voltar ao Topo Ir em baixo


Re: Aviso de Manutenção quando o link cair

Mensagem por mwmikrotik em Qua 1 Jun - 12:00

Olá Galera!!!

Vi no under-linux um tuto com os scripts prontos para fazer o aviso de manutenção quando o link cair usando o prório hotspot

Segue o link do fórum:

[Você precisa estar registrado e conectado para ver este link.]

Segue o tuto:

[Você precisa estar registrado e conectado para ver este link.]

Segue o exemplo da página de Manutenção:

[Você precisa estar registrado e conectado para ver este link.]

Testado e aprovado.

Aki funcionou 100%

Os créditos do tuto e dos script`s são do companheiro

Jonas Oliveira
avatar
mwmikrotik
Baby
Baby

Mensagens : 24
Pontos : 40
Reputação : 14
Data de inscrição : 18/05/2011
Idade : 36
Localização Localização : Paraná

Voltar ao Topo Ir em baixo

Re: Aviso de Manutenção quando o link cair

Mensagem por mwmikrotik em Qua 1 Jun - 12:02

Eu aqui aproveitava o thundercache pra hospedar a página de aviso para os clientes,

mas como uso hotspot, ache que assim ficou muito melhor.
avatar
mwmikrotik
Baby
Baby

Mensagens : 24
Pontos : 40
Reputação : 14
Data de inscrição : 18/05/2011
Idade : 36
Localização Localização : Paraná

Voltar ao Topo Ir em baixo

Re: Aviso de Manutenção quando o link cair

Mensagem por sall em Qua 1 Jun - 12:10

Vlw [Você precisa estar registrado e conectado para ver este link.] vai ajudar muito esse tuto...
avatar
sall
Iniciante
Iniciante

Mensagens : 57
Pontos : 86
Reputação : 2
Data de inscrição : 12/02/2011
Idade : 31
Localização Localização : Recife, Pernambuco

Voltar ao Topo Ir em baixo

Re: Aviso de Manutenção quando o link cair

Mensagem por Lucivan em Qua 1 Jun - 12:51

Boa Tarde , amigo eu naum uso hotspot eu uso ip estatico e mac na tabela arp e uso o thunder cache 3.1 a versão do mauro , será que tem como eu fazer essa configuração no meu thunder , tipo hospedar essa pagina no thunder e quando o link caiu ela execultar...

Lucivan
User
User

Mensagens : 181
Pontos : 250
Reputação : 15
Data de inscrição : 11/12/2010

Voltar ao Topo Ir em baixo

Re: Aviso de Manutenção quando o link cair

Mensagem por mwmikrotik em Qua 1 Jun - 13:18

Tem sim!!!

Faz o seguinte:

Hospede sua página de aviso no ThunderCache

Depois use as regras:

/ip firewall nat
add action=passthrough chain=unused-hs-chain comment=\
"place hotspot rules here" disabled=yes
add action=dst-nat chain=dstnat comment=\
"===== Aviso de Manutencao para Todos =====" disabled=yes dst-port=80 \
in-interface=CLIENTES protocol=tcp src-address=192.168.0.0/16 \
to-addresses=50.50.50.2 to-ports=80

/tool netwatch
add comment="-<===== Aviso Falta de Link =====>-" disabled=no down-script="/ip\
\_firewall nat set [find comment="===== Aviso de Manutencao para Todos ==\
==="] disabled=no\r\
\n" host=8.8.8.8 interval=10s timeout=1s up-script="/ip firewall nat set [\
find comment="===== Aviso de Manutencao para Todos ====="] disabled=yes\
\r\
\n"

Faça as seguinte alterações:

CLIENTES mude para o nome da interface onde seus clientes estão ligados no mikrotik.
192.168.0.0/16 mude para faixa de IP`s dos seu clientes.
50.50.50.2 mude para o IP do seu ThunderCache.
8.8.8.8 é o IP de um dos servidores de DNS da google, é nele que será feito o munitoramento, caso prefira mude para um de sua confiaça.

A regra ===== Aviso de Manutencao para Todos ===== em IP / Firewall / Nat

Deixe acima de todas

Com isso toda a vez que seu link "cair" e/ou o IP 8.8.8.8 parar de responder por algum motivo a regra
===== Aviso de Manutencao para Todos ===== será ativada quando o link voltar e/ou o IP 8.8.8.8 voltar
a responder a regra ===== Aviso de Manutencao para Todos ===== será desativada
avatar
mwmikrotik
Baby
Baby

Mensagens : 24
Pontos : 40
Reputação : 14
Data de inscrição : 18/05/2011
Idade : 36
Localização Localização : Paraná

Voltar ao Topo Ir em baixo

Re: Aviso de Manutenção quando o link cair

Mensagem por dsdigital em Qua 1 Jun - 13:19

thunder o squid

__________________________________________________
VocÊ Ja Penso e Ter Servidor DNS. Pro seu próprio provedor?

Acompanha configuração de Servidores.

Mikrotik. Ppoe hospot. Etc.

Verdadeiro load balance pcc Com apenas nat No balance. E rotas sumarizadas.

Servidor multimídia.

Servidor dns unbound você Com seu próprio servidor DNS. Economizando Que cliente Busque Fora da Rede. o Dns.

Contato: [Você precisa estar registrado e conectado para ver este link.]
avatar
dsdigital
Power User
Power User

Mensagens : 862
Pontos : 1131
Reputação : 156
Data de inscrição : 27/11/2010
Idade : 25
Localização Localização : ?

Voltar ao Topo Ir em baixo

Lucivan

Mensagem por mwmikrotik em Qua 1 Jun - 13:32

Vc tb pode fazer uma regra parecida pra “monitorar” o ThunderCache, caso ele pare de responder por algum motivo

o direcionamento para ele é desativado e quando ele voltar a responde o direcionamento é ativado altomáticamente.

Código:
/tool netwatch
add comment="-<===== Monitora ThunderCache =====>-" disabled=no down-script=\
    "/ip firewall nat set [find comment="REDIRECIONAR PROXY"] disabled=yes" \
    host=50.50.50.2 interval=5s timeout=1s up-script=\
    "/ip firewall nat set [find comment="REDIRECIONAR PROXY"] disabled=no"

Faça as seguinte alterações:

50.50.50.2 mude para o IP do seu ThunderCache
REDIRECIONAR PROXY mude para o nome de sua regra que direciona os clientes para o ThunderCache em IP / Firewall / Nat


Última edição por Marcelo em Qua 1 Jun - 20:11, editado 1 vez(es) (Razão : Adição de tag codigo para diminuir a postagem)
avatar
mwmikrotik
Baby
Baby

Mensagens : 24
Pontos : 40
Reputação : 14
Data de inscrição : 18/05/2011
Idade : 36
Localização Localização : Paraná

Voltar ao Topo Ir em baixo

Re: Aviso de Manutenção quando o link cair

Mensagem por claudinhohw Network em Qua 1 Jun - 15:36

eu não uso cash fica como?

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik
avatar
claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2702
Pontos : 3341
Reputação : 582
Data de inscrição : 28/08/2010
Idade : 33
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

claudinhohw

Mensagem por mwmikrotik em Qua 1 Jun - 15:50

Basicamente duas Maneiras:

Se vc usar hotspot, pode usar ele mesmo pra mandar aviso quando o link cair (leia alguns posts atraz).

Se vc não usa hotspot, monta um servidor web (apache ou outro de sua preferência) na sua rede e hospedar uma página só pra isso.

Se vc não usa hotspot, nem web-cache (que tenha o apache instalado) e tb não que montar um servidor web na sua rede

Não tem como mandar aviso para os clientes quando o link cair.
avatar
mwmikrotik
Baby
Baby

Mensagens : 24
Pontos : 40
Reputação : 14
Data de inscrição : 18/05/2011
Idade : 36
Localização Localização : Paraná

Voltar ao Topo Ir em baixo

Re: Aviso de Manutenção quando o link cair

Mensagem por dsdigital em Qua 1 Jun - 15:56

mao na roda


-Alterem onde tiver = 10.100.0.1 = para ip do seu MK, o mesmo da interface dos clientes

-Alterem onde tiver = teste.com.br = para o seu dns-name.

-depois que alterar isso ai é só “(Ctrl+c) e ( Ctrl+v)”!

-a ultima linha do script em tool netwatch = / queue simple remove hs-

é opcional! Eu uso aqui para remover aquela queue simple que o hotspot cria por padrão, pode retirar ela se quiser!

-o restante do script pode deixar como estar que vai fucionar.
Código:
/system script
add name=DOWN-LINK policy=ftp,read,write,winbox source="/ip firewall nat enabl\
    e [find comment="MANUTENCAO"]\r\
    \n/ip hotspot profile set hsprof1 html-directory=manutencao\r\
    \n/ip dns static set [/ip dns static find name=teste.com.br] address=8.8.4\
    .4 comment="" disabled=no name=.* ttl=5s"
add name=LINK-UP policy=ftp,reboot,read,write,winbox source="/ip firewall nat \
    disable [find comment="MANUTENCAO"]\r\
    \n/ip hotspot profile set hsprof1 html-directory=hotspot\r\
    \n/ip dns static set [/ip dns static find name=.*] address=10.100.0.1 comm\
    ent="" disabled=no name=teste.com.br ttl=5s\r\
    \n\r\
    \n"
add name=REMOVER-DNS-DINAMICO-OFF policy=ftp,read,write,winbox source="/ ip dns static remove [/ip dns static find dynamic=yes]\r\
    \n"
add name=REMOVER-DNS-DINAMICO-ON policy=ftp,read,write,winbox source="/ip dns static remove [/ip dns static find dynamic=yes]\r\
    \n/system script run LINK-UP\r\
    \n/system scheduler disable [/system scheduler find name=remover_dns_dinamico_on]\r\
    \n/system scheduler disable [/system scheduler find name=remover_dns_dinamico_off]"

/system scheduler
add comment="" disabled=yes interval=5s name=remover_dns_dinamico_on on-event="/ system script run REMOVER-DNS-DINAMICO-ON" policy=read,write start-time=\
    startup
add comment="" disabled=yes interval=5s name=remover_dns_dinamico_off on-event="/ system script run REMOVER-DNS-DINAMICO-OFF\r\
    \n" policy=read,write start-time=startup
/ip firewall nat
add action=redirect chain=dstnat comment=MANUTENCAO disabled=yes dst-port=80 \
    protocol=tcp to-ports=64873

/ip dns static
add address=10.100.0.1 comment="" disabled=no name=teste.com.br ttl=5s

/tool netwatch
add comment="MONITORAR LINK" disabled=no down-script=\
    "/ system script run DOWN-LINK\r\
    \n/ system scheduler enable [/system scheduler find name=remover_dns_dinamico_off]\r\
    \n" host=8.8.8.8 interval=5s timeout=1s up-script=\
    "/system scheduler enable [/system scheduler find name=remover_dns_dinamico_on]\r\
    \n/ system script run LINK-UP\r\
    \n/ queue simple remove hs-"

sem thunder sem servidor de web o mk fais tudo


Última edição por Marcelo em Qua 1 Jun - 20:10, editado 1 vez(es) (Razão : Adição de tag codigo para diminuir a postagem)

__________________________________________________
VocÊ Ja Penso e Ter Servidor DNS. Pro seu próprio provedor?

Acompanha configuração de Servidores.

Mikrotik. Ppoe hospot. Etc.

Verdadeiro load balance pcc Com apenas nat No balance. E rotas sumarizadas.

Servidor multimídia.

Servidor dns unbound você Com seu próprio servidor DNS. Economizando Que cliente Busque Fora da Rede. o Dns.

Contato: [Você precisa estar registrado e conectado para ver este link.]
avatar
dsdigital
Power User
Power User

Mensagens : 862
Pontos : 1131
Reputação : 156
Data de inscrição : 27/11/2010
Idade : 25
Localização Localização : ?

Voltar ao Topo Ir em baixo

Re: Aviso de Manutenção quando o link cair

Mensagem por mwmikrotik em Qua 1 Jun - 16:28

Isso mesmo dsdigital

É exatamente isso que tem no arquivo do link:

[Você precisa estar registrado e conectado para ver este link.]

Feito pelo companheiro Jonas Oliveira

Acabei de de fazer uns testes aki

E pra quem não usa hotspot mas quer usar essas regras/script`s para mandar aviso quando o link cair

Basta fazer algumas adaptações e criar um hotspot (mas deixa-lo desativado)

Aí quando o link cair, ele ativa o hotspot e "roda" as regras/script`s

Quando o link voltar, o hotspot é desativado.

Vou só conferir as mudanças que eu fiz, pra ver se ta tudo certinho

Aí posto aki tudo pronto.

Só frisando: sem o uso de hotspot não adianta tentar e tb deve-se colocar uma pasta com o nome de manutencao fora da pasta hotspot contendo os arquivos com a tela de aviso para os clientes.

Tem um link aki pra baixar um exemplo pronto:

[Você precisa estar registrado e conectado para ver este link.]
avatar
mwmikrotik
Baby
Baby

Mensagens : 24
Pontos : 40
Reputação : 14
Data de inscrição : 18/05/2011
Idade : 36
Localização Localização : Paraná

Voltar ao Topo Ir em baixo

Re: Aviso de Manutenção quando o link cair

Mensagem por Lucivan em Qua 1 Jun - 20:06

amigo sera que vc poderia mim passa o teu msn

Lucivan
User
User

Mensagens : 181
Pontos : 250
Reputação : 15
Data de inscrição : 11/12/2010

Voltar ao Topo Ir em baixo

Re: Aviso de Manutenção quando o link cair

Mensagem por claudinhohw Network em Qui 2 Jun - 8:41

vou testa aki pra ver se funfa legal

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik
avatar
claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2702
Pontos : 3341
Reputação : 582
Data de inscrição : 28/08/2010
Idade : 33
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Lucivan

Mensagem por mwmikrotik em Qui 2 Jun - 10:18

Lucivan, meu e-Mail/MSN é:

[Você precisa estar registrado e conectado para ver este link.]

Pode me add pra trocarmos umas idéias
avatar
mwmikrotik
Baby
Baby

Mensagens : 24
Pontos : 40
Reputação : 14
Data de inscrição : 18/05/2011
Idade : 36
Localização Localização : Paraná

Voltar ao Topo Ir em baixo

Re: Aviso de Manutenção quando o link cair

Mensagem por Sixagencia Networks em Qui 2 Jun - 12:38

mwmikrotik escreveu:Lucivan, meu e-Mail/MSN é:

[Você precisa estar registrado e conectado para ver este link.]

Pode me add pra trocarmos umas idéias

Boa tarde, fiz o teste aqui e nao funcionou ainda. Lhe add no msn, se poder me ajudar agradeço.
avatar
Sixagencia Networks
Power User
Power User

Mensagens : 1002
Pontos : 1333
Reputação : 281
Data de inscrição : 28/03/2011
Idade : 36
Localização Localização : Feira de Santana

http://www.sixagencia.com.br

Voltar ao Topo Ir em baixo

Re: Aviso de Manutenção quando o link cair

Mensagem por Sixagencia Networks em Qui 2 Jun - 12:41

dsdigital escreveu:mao na roda


-Alterem onde tiver = 10.100.0.1 = para ip do seu MK, o mesmo da interface dos clientes

-Alterem onde tiver = teste.com.br = para o seu dns-name.

-depois que alterar isso ai é só “(Ctrl+c) e ( Ctrl+v)”!

-a ultima linha do script em tool netwatch = / queue simple remove hs-

é opcional! Eu uso aqui para remover aquela queue simple que o hotspot cria por padrão, pode retirar ela se quiser!

-o restante do script pode deixar como estar que vai fucionar.
Código:
/system script
add name=DOWN-LINK policy=ftp,read,write,winbox source="/ip firewall nat enabl\
    e [find comment="MANUTENCAO"]\r\
    \n/ip hotspot profile set hsprof1 html-directory=manutencao\r\
    \n/ip dns static set [/ip dns static find name=teste.com.br] address=8.8.4\
    .4 comment="" disabled=no name=.* ttl=5s"
add name=LINK-UP policy=ftp,reboot,read,write,winbox source="/ip firewall nat \
    disable [find comment="MANUTENCAO"]\r\
    \n/ip hotspot profile set hsprof1 html-directory=hotspot\r\
    \n/ip dns static set [/ip dns static find name=.*] address=10.100.0.1 comm\
    ent="" disabled=no name=teste.com.br ttl=5s\r\
    \n\r\
    \n"
add name=REMOVER-DNS-DINAMICO-OFF policy=ftp,read,write,winbox source="/ ip dns static remove [/ip dns static find dynamic=yes]\r\
    \n"
add name=REMOVER-DNS-DINAMICO-ON policy=ftp,read,write,winbox source="/ip dns static remove [/ip dns static find dynamic=yes]\r\
    \n/system script run LINK-UP\r\
    \n/system scheduler disable [/system scheduler find name=remover_dns_dinamico_on]\r\
    \n/system scheduler disable [/system scheduler find name=remover_dns_dinamico_off]"

/system scheduler
add comment="" disabled=yes interval=5s name=remover_dns_dinamico_on on-event="/ system script run REMOVER-DNS-DINAMICO-ON" policy=read,write start-time=\
    startup
add comment="" disabled=yes interval=5s name=remover_dns_dinamico_off on-event="/ system script run REMOVER-DNS-DINAMICO-OFF\r\
    \n" policy=read,write start-time=startup
/ip firewall nat
add action=redirect chain=dstnat comment=MANUTENCAO disabled=yes dst-port=80 \
    protocol=tcp to-ports=64873

/ip dns static
add address=10.100.0.1 comment="" disabled=no name=teste.com.br ttl=5s

/tool netwatch
add comment="MONITORAR LINK" disabled=no down-script=\
    "/ system script run DOWN-LINK\r\
    \n/ system scheduler enable [/system scheduler find name=remover_dns_dinamico_off]\r\
    \n" host=8.8.8.8 interval=5s timeout=1s up-script=\
    "/system scheduler enable [/system scheduler find name=remover_dns_dinamico_on]\r\
    \n/ system script run LINK-UP\r\
    \n/ queue simple remove hs-"

sem thunder sem servidor de web o mk fais tudo

Pow man, me ajuda ai, no meu dns-name, esta o mesmo endereço do meu MK.
avatar
Sixagencia Networks
Power User
Power User

Mensagens : 1002
Pontos : 1333
Reputação : 281
Data de inscrição : 28/03/2011
Idade : 36
Localização Localização : Feira de Santana

http://www.sixagencia.com.br

Voltar ao Topo Ir em baixo

Sixagencia

Mensagem por mwmikrotik em Qui 2 Jun - 13:12

Já aceitei vc no MSN

Em DNS Static Entry

Em Name vc escolhe um nome

Ex.: teste.com.br

Em Address vc coloca o IP do seu MK

Ex.: 10.100.0.1

Aí em Hotspot Server Profile

No DNS Name vc coloca o name que "criou" no DNS Static Entry

Ex.: teste.com.br

Obs.: se vc não usar teste.com.br mude no script para o name que vc "criou".
avatar
mwmikrotik
Baby
Baby

Mensagens : 24
Pontos : 40
Reputação : 14
Data de inscrição : 18/05/2011
Idade : 36
Localização Localização : Paraná

Voltar ao Topo Ir em baixo

Re: Aviso de Manutenção quando o link cair

Mensagem por Sixagencia Networks em Qui 2 Jun - 15:36

Boa tarde, conforme constatado, estava usando o script para a versão 4.x. Falta de atenção da minha parte. Até ai td bem, mas ao alterar para o script da versao do meu MK 3.30, parece querer funcionar mais esta dando ERRO 400 Bad Request. Alguem conseguiu fazer funcionar na versao 3.30?
avatar
Sixagencia Networks
Power User
Power User

Mensagens : 1002
Pontos : 1333
Reputação : 281
Data de inscrição : 28/03/2011
Idade : 36
Localização Localização : Feira de Santana

http://www.sixagencia.com.br

Voltar ao Topo Ir em baixo

Re: Aviso de Manutenção quando o link cair

Mensagem por mwmikrotik em Qui 2 Jun - 16:12

Segue o script para 3.x

Código:
/system script
add name=down-link policy=ftp,reboot,read,write,policy,test,winbox,password source="/ip firewall nat enable [find comment="manutencao"]\r\
\n/ip hotspot profile set hsprof1 html-directory=manutencao\r\
\n/ip dns static set [/ip dns static find name=provedor.com.br] address=8.8.4.4 disabled=no name=.* ttl=5s"
add name=link-up policy=ftp,reboot,read,write,policy,test,winbox,password source="/ip firewall nat disable [find comment="manutencao"]\r\
\n/ip hotspot profile set hsprof1 html-directory=hotspot\r\
\n/ip dns static set [/ip dns static find name=.*] address=10.100.0.1 disabled=no name=provedor.com.br ttl=5s\r\
\n"
add name=script_remover_dns_dinamico_off policy=ftp,reboot,read,write,policy,test,winbox,password source=\
"/ip dns static remove [/ip dns static find dynamic=yes]\r\
\n"
add name=script_remover_dns_dinamico_on policy=ftp,reboot,read,write,policy,test,winbox,password source="/ip dns static remove [/ip dns static find dynamic=ye\
s]\r\
\n/system script run link-up\r\
\n/system scheduler disable [/system scheduler find name=sched_remover_dns_dinamico_off]\r\
\n/system scheduler disable [/system scheduler find name=sched_remover_dns_dinamico_on]"

/system scheduler
add comment="" disabled=yes interval=5s name=sched_remover_dns_dinamico_on \
on-event=script_remover_dns_dinamico_on policy=\
reboot,read,write,policy,test,password start-time=startup
add comment="" disabled=yes interval=5s name=sched_remover_dns_dinamico_off \
on-event=script_remover_dns_dinamico_off policy=\
reboot,read,write,policy,test,password start-time=startup

/ip firewall nat
add action=redirect chain=dstnat comment=manutencao disabled=yes dst-port=80 protocol=tcp to-ports=64873

/tool netwatch
add comment="monitorar link" disabled=no down-script=\
"/system scheduler enable [/system scheduler find name=sched_remover_dns_dinamico_off]\r\
\n/system script run down-link\r\
\n" host=8.8.8.8 interval=5s timeout=1s up-script="/system scheduler enable [/system scheduler find name=sched_remover_dns_dinamico_on]\r\
\n/system script run link-up\r\
\n/queue simple remove hs-"

/ip dns static
add address=10.100.0.1 disabled=no name=provedor.com.br ttl=5s

Faça as seguintes modificações:

provedor.com.br mude para seu dns estático.

10.100.0.1 mude para o endereço do seu MK (interface que atende os clientes).

Quem usa Proxy, a regra manutencao em IP/Firewall/Nat deve ficar a cima da regra que direciona o trafego para o proxy.

A pasta manutencao deve ficar fora da pasta hotspot e todos os arquivos dela tem que estar com extensão html e não HTML (algumas versões do mk faz confusão entre letras maiúsculas e minúsculas).

Observe em IP/Hotspot/Server Profiles

Se o profile que esta em uso tem o nome de hsprof1

Se for outro nome, mude nos script`s

E se dentro do profile em uso, o DNS Name ta com o mesmo nome criado para dns estático.

Tomando esses cuidados vai funcionar 100%

Eu e o Sixagencia já testamos.
avatar
mwmikrotik
Baby
Baby

Mensagens : 24
Pontos : 40
Reputação : 14
Data de inscrição : 18/05/2011
Idade : 36
Localização Localização : Paraná

Voltar ao Topo Ir em baixo

Re: Aviso de Manutenção quando o link cair

Mensagem por Sixagencia Networks em Qui 2 Jun - 16:23

mwmikrotik escreveu:Segue o script para 3.x

Código:
/system script
add name=down-link policy=ftp,reboot,read,write,policy,test,winbox,password source="/ip firewall nat enable [find comment="manutencao"]\r\
\n/ip hotspot profile set hsprof1 html-directory=manutencao\r\
\n/ip dns static set [/ip dns static find name=provedor.com.br] address=8.8.4.4 disabled=no name=.* ttl=5s"
add name=link-up policy=ftp,reboot,read,write,policy,test,winbox,password source="/ip firewall nat disable [find comment="manutencao"]\r\
\n/ip hotspot profile set hsprof1 html-directory=hotspot\r\
\n/ip dns static set [/ip dns static find name=.*] address=10.100.0.1 disabled=no name=provedor.com.br ttl=5s\r\
\n"
add name=script_remover_dns_dinamico_off policy=ftp,reboot,read,write,policy,test,winbox,password source=\
"/ip dns static remove [/ip dns static find dynamic=yes]\r\
\n"
add name=script_remover_dns_dinamico_on policy=ftp,reboot,read,write,policy,test,winbox,password source="/ip dns static remove [/ip dns static find dynamic=ye\
s]\r\
\n/system script run link-up\r\
\n/system scheduler disable [/system scheduler find name=sched_remover_dns_dinamico_off]\r\
\n/system scheduler disable [/system scheduler find name=sched_remover_dns_dinamico_on]"

/system scheduler
add comment="" disabled=yes interval=5s name=sched_remover_dns_dinamico_on \
on-event=script_remover_dns_dinamico_on policy=\
reboot,read,write,policy,test,password start-time=startup
add comment="" disabled=yes interval=5s name=sched_remover_dns_dinamico_off \
on-event=script_remover_dns_dinamico_off policy=\
reboot,read,write,policy,test,password start-time=startup

/ip firewall nat
add action=redirect chain=dstnat comment=manutencao disabled=yes dst-port=80 protocol=tcp to-ports=64873

/tool netwatch
add comment="monitorar link" disabled=no down-script=\
"/system scheduler enable [/system scheduler find name=sched_remover_dns_dinamico_off]\r\
\n/system script run down-link\r\
\n" host=8.8.8.8 interval=5s timeout=1s up-script="/system scheduler enable [/system scheduler find name=sched_remover_dns_dinamico_on]\r\
\n/system script run link-up\r\
\n/queue simple remove hs-"

/ip dns static
add address=10.100.0.1 disabled=no name=provedor.com.br ttl=5s

Faça as seguintes modificações:

provedor.com.br mude para seu dns estático.

10.100.0.1 mude para o endereço do seu MK (interface que atende os clientes).

Quem usa Proxy, a regra manutencao em IP/Firewall/Nat deve ficar a cima da regra que direciona o trafego para o proxy.

A pasta manutencao deve ficar fora da pasta hotspot e todos os arquivos dela tem que estar com extensão html e não HTML (algumas versões do mk faz confusão entre letras maiúsculas e minúsculas).

Observe em IP/Hotspot/Server Profiles

Se o profile que esta em uso tem o nome de hsprof1

Se for outro nome, mude nos script`s

E se dentro do profile em uso, o DNS Name ta com o mesmo nome criado para dns estático.

Tomando esses cuidados vai funcionar 100%

Eu e o Sixagencia já testamos.

Bom, em primeiro lugar vim aqui agradecer ao mwmikrotik, pela paciencia e gentileza em nos ajudar. Kra, vc é 1000. Obrigado pela força. Ja cliquei no + pois vc merece.
avatar
Sixagencia Networks
Power User
Power User

Mensagens : 1002
Pontos : 1333
Reputação : 281
Data de inscrição : 28/03/2011
Idade : 36
Localização Localização : Feira de Santana

http://www.sixagencia.com.br

Voltar ao Topo Ir em baixo

Sixagencia

Mensagem por mwmikrotik em Qui 2 Jun - 16:26

Valeu kara

estamos aí pra isso
avatar
mwmikrotik
Baby
Baby

Mensagens : 24
Pontos : 40
Reputação : 14
Data de inscrição : 18/05/2011
Idade : 36
Localização Localização : Paraná

Voltar ao Topo Ir em baixo

Re: Aviso de Manutenção quando o link cair

Mensagem por Gerônimo em Ter 7 Jun - 21:58

Ai o link para o ideo pessoal

[Você precisa estar registrado e conectado para ver este link.]

__________________________________________________
A VIDA SO É DIGNA DE SER VIVIDA SE VOCÊ FIZER ALGO PELA VIDA EM VIDA.
MUDE A VIDA DE UMA CRIANÇA APADRINHE COM APENAS R&#36; 50,00 ACESSE [Você precisa estar registrado e conectado para ver este link.]
avatar
Gerônimo
Power User
Power User

Mensagens : 684
Pontos : 1454
Reputação : 722
Data de inscrição : 29/05/2010
Idade : 43
Localização Localização : Brasil

http://www.overnix.com/

Voltar ao Topo Ir em baixo

Re: Aviso de Manutenção quando o link cair

Mensagem por flavio.gd em Qui 9 Jun - 1:15

[Você precisa estar registrado e conectado para ver este link.] valeu pelo vídeo só você mesmo para nos presentear com esse vídeo


Última edição por flavio.gd em Qui 9 Jun - 12:09, editado 1 vez(es)
avatar
flavio.gd
User
User

Mensagens : 134
Pontos : 194
Reputação : 11
Data de inscrição : 06/05/2011
Idade : 37
Localização Localização : laranjal do jari--amapa

Voltar ao Topo Ir em baixo

Re: Aviso de Manutenção quando o link cair

Mensagem por claudinhohw Network em Qui 9 Jun - 7:51

Gerônimo é o cara msm...

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik
avatar
claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2702
Pontos : 3341
Reputação : 582
Data de inscrição : 28/08/2010
Idade : 33
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Re: Aviso de Manutenção quando o link cair

Mensagem por netuai em Qui 9 Jun - 12:57

Este negocio de ser o cara é fria, mas o Geronimo tem dedicado muito do tempo dele para ajudar o forum

__________________________________________________

Suspect Arrow QUEM NÃO TEM NADA A PERDER...
PERDE AMIGOS Exclamation





sunny [Você precisa estar registrado e conectado para ver este link.] sunny
avatar
netuai
Advance user
Advance user

Mensagens : 246
Pontos : 409
Reputação : 123
Data de inscrição : 09/07/2010
Idade : 35
Localização Localização : Lagoa Formosa

http://www.netuai.net

Voltar ao Topo Ir em baixo

Página 2 de 4 Anterior  1, 2, 3, 4  Seguinte

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum