Login

Esqueci minha senha

lateral
Estatísticas
Temos 29277 usuários registrados
O último usuário registrado atende pelo nome de alexandreluizmoulaz

Os nossos membros postaram um total de 37313 mensagens em 5568 assuntos

Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Mensagem por cdanielboy em Sex 27 Set - 21:11

Baixa a iso do debian 7
[Você precisa estar registrado e conectado para ver este link.]


Video de instalação do Debian 7

[Você precisa estar registrado e conectado para ver este link.]


Instalação do Sistema 
Instruções para instalação:


Descompacte a pasta Raptor-Lusca (usando uma maquina on Windows) dentro dessa pasta existe uma sub_pasta chamada configs e o sript de instalação com o nome de instalador.
 
Atenção para aquele apressados e os famosos  ctrl+C e ctrl+V esses passos são de suma importância para que a instalação seja bem sucedida, portanto recomendo uma leitura mínima para entender o assunto.
Acesse seu debian recen instalado (via winsp) o qual devera estar com os ips, conforme descrito nesse tutorial.
Copie os arquivos anexos a este post para dentro da pasta /usr/src
Depois acesse novamente o seu debian (dessa vez utilizando o puty) ou se preferir pode usar o próprio terminal, e digite esses comando (como usuário root)
cd /usr/src
chmod 777 /usr/src/*
./instalador
Nem preciso lembrar que a cada comando precisar pressionar a tecla enter
 
 
para integrar ao mikrotik paralelo
Passo a Passo 

Usaremos seguinte conf.
No RaptorCache
IP Address = 192.168.10.2
Subnet Mask = 255.255.255.252
Default Router = 192.168.10.1

No Mikrotik
Interface ligada ao Raptor = ether2
IP da ether2 = 192.168.10.1/30
Interface ligada ao Link = ether1
Interface ligada aos Clientes = ether3
Range de IP dos Clientes = 10.0.0.0/8


1° Passo
Marcar os pacotes que serão enviados para o cache.

(ATENÇÃO ESSA REGRA TEM QUE FICAR ACIMA DE QUALQUER OUTRA EXISTENTE, CASO CONTRARIO A PAGINA E CORTE NÃO FUNCIONARÁ E O REDIRECIONAMENTO NÃO FICA LEGAL, APANHEI PARA DESCOBRIR ISSO, OBSERVAÇÃO ESTA REGRA TAMBÉM SE APLICA AO THUNDER 7.1 BASTANDO TROCAR A PALAVRA RAPTOR POR THUNDER)

/ip firewall mangle
add action=mark-routing chain=prerouting src-address=10.0.0.0/8 dst-address-list=!Site_fora_do_cache src-address-list=!Cliente_fora_do_cache in-interface=!ether2 comment=RAPTOR-CACHE disabled=yes protocol=tcp dst-port=80 new-routing-mark=to_cache passthrough=yes


2° Passo
Criar a rota que enviará os pacotes marcados ao Raptor

/ip route
add comment=ROTA-RAPTOR disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.10.2 routing-mark=to_cache scope=30 target-scope=10


3° Passo
Iremos aqui criar duas listas.
A dos clientes que não passarão pelo cache e a dos sites que será entregue ao cliente sem passar pelo cache.

/ip firewall address-list
add address=192.168.10.2 list=Cliente_fora_do_cache comment="Cliente Fora do Cache" disabled=no
add address=192.168.10.2 list=Site_fora_do_cache comment="Site Fora do Cache" disabled=no


4° Passo
Redirecionando porta para acesso externo ao servidor RaptorCache, e criando uma nat de saída.

/ip firewall nat
add action=dst-nat chain=dstnat dst-port=2200 protocol=tcp to-addresses=192.168.10.2 to-ports=22 comment=SSH_Raptor disabled=no
add action=dst-nat chain=dstnat dst-port=82 protocol=tcp to-addresses=192.168.10.2 to-ports=82 comment=WEBADMIN_Raptor disabled=no
add action=masquerade chain=srcnat out-interface=ether1 src-address=192.168.10.0/24 comment="NAT_Raptor" disabled=no
 
5° Passo
Marcar pacotes para que fazer o cache full
/ip firewall mangle
add action=mark-connection chain=postrouting comment=\
    "\\\\\\\\\\\\\\\\\\\\Cache Full Lusca//////////" disabled=no dscp=12 \
    new-connection-mark=Lusca-Cache passthrough=yes protocol=tcp \
    src-address-list=""
add action=mark-packet chain=postrouting connection-mark=Lusca-Cache \
    disabled=no new-packet-mark=Cache-Full passthrough=yes
 
 
add action=mark-connection chain=postrouting comment="Cache Full Raptor" \
    content="X-Cache: HIT from Raptor" disabled=no new-connection-mark=\
    raptor-connection passthrough=yes
 
add action=mark-packet chain=postrouting connection-mark=raptor-connection \
    disabled=no new-packet-mark=raptor-packs passthrough=no
 
5° Passo
Criar classes para cache full
 
/queue tree
 
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=10M max-limit=20M name=RaptorCache \
    packet-mark=raptor-packs parent=global-out priority=4 queue=default
 
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=10M max-limit=20M name=LuscaCache \
    packet-mark=Cache-Full parent=global-out priority=4 queue=default
 

ATENÇÃO APENAS FIZ AS ATUALIZAÇÕES, SE HOUVER ALGUM ERRO DURANTE A INSTALAÇÃO  RELACIONE AS DIFICULDADES ENCONTRADAS, ACOMPANHADA DO PRINTS DAS FALHAS APONTADAS.
EM CASO DE ATUALIZAÇÃO BEM SUCEDIDA TEM POSTAR O RELATO .


SCRIPT DO RAPTOR COM O LUSCA
[Você precisa estar registrado e conectado para ver este link.]


Obs: pra baixar o arquivo vc terá que criar uma conta de gratis no 4 shared !
Anexos



    Imagens



























CREDITOS :  FRANCISCO SOUSA

cdanielboy
Power User
Power User

Mensagens : 1012
Pontos : 1333
Reputação : 267
Data de inscrição : 12/05/2011
Idade : 32
Localização Localização : belém

Voltar ao Topo Ir em baixo

Re: Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Mensagem por Pedroh em Seg 30 Set - 15:17

muito bom, irei testar.

Pedroh
Baby
Baby

Mensagens : 2
Pontos : 4
Reputação : 0
Data de inscrição : 17/09/2012
Idade : 28
Localização Localização : Minas Gerais

Voltar ao Topo Ir em baixo

Re: Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Mensagem por lfmonitoramento em Sex 25 Out - 0:14

Amigo como faço pra deixar um site passar fora do cacahe ?

lfmonitoramento
Baby
Baby

Mensagens : 2
Pontos : 4
Reputação : 0
Data de inscrição : 26/06/2011
Idade : 40
Localização Localização : São Paulo

Voltar ao Topo Ir em baixo

Re: Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Mensagem por ZX® em Seg 11 Nov - 3:39

Como adicionar um segundo HD pra cache no raptor e tambem estou com um problema que a memoria esta enchendo rápido demais existe algum script que limpe automaticamente exemplo quando chegar a 80% desde ja obrigado.

ZX®
Iniciante
Iniciante

Mensagens : 77
Pontos : 117
Reputação : 5
Data de inscrição : 14/01/2011

Voltar ao Topo Ir em baixo

Re: Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Mensagem por maxelldj em Seg 16 Dez - 23:37

Parabéns pelo tutorial pelo que vi esta mais claro que um que vi anteriormente , vou ver se consigo configurar por esse

maxelldj
Baby
Baby

Mensagens : 2
Pontos : 4
Reputação : 0
Data de inscrição : 12/08/2012
Idade : 26
Localização Localização : Salvador

Voltar ao Topo Ir em baixo

Re: Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Mensagem por L30nardo em Ter 17 Dez - 6:32

qual as configuração minima da maquina para roda esse cache?

L30nardo
Baby
Baby

Mensagens : 17
Pontos : 27
Reputação : 0
Data de inscrição : 05/10/2013
Idade : 28
Localização Localização : RIO GRANDE DO NORTE

Voltar ao Topo Ir em baixo

Re: Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Mensagem por Arthur Bernardes em Ter 17 Dez - 8:30

Esse cache é bom? Funciona bem até quantos clientes?

Arthur Bernardes
Advance user
Advance user

Mensagens : 266
Pontos : 310
Reputação : 36
Data de inscrição : 01/11/2013
Idade : 19
Localização Localização : Onda Verde - SP

Voltar ao Topo Ir em baixo

Re: Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Mensagem por edu1020 em Ter 21 Jan - 20:51

pessoal esse raptorcache esta me surpreendendo instalei ele a 1 més ta rodando a mil inclusive videos do youtube vale a pena testar, pois eu vejo tanta gente falando mal de caches pagos ai , eo raptorcache gratis batendo de frente ou até ganhando em alguns quesitos.

edu1020
Baby
Baby

Mensagens : 19
Pontos : 28
Reputação : 1
Data de inscrição : 10/05/2012
Idade : 25
Localização Localização : goias

Voltar ao Topo Ir em baixo

Re: Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Mensagem por cszasalp em Sex 31 Jan - 14:46

Aew nao consegui acessar o painel... aki deu que a instalação correu tudo bem mais a pagina nao carrega.. mesmo eu ligando meu pc direto com o lusca nao deu certo  Sad

cszasalp
Baby
Baby

Mensagens : 2
Pontos : 3
Reputação : 1
Data de inscrição : 05/04/2013
Idade : 36
Localização Localização : Mage

Voltar ao Topo Ir em baixo

Re: Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Mensagem por cszasalp em Sab 1 Fev - 19:46

Opa consegui.,.. depois de pesquisar muito eu consegui... o lance é que na hora que ele pede senha do mysql.. tem q por raptor toda vez que ele pedir..... dai no final tem q entrar via ssh e da o comando squid -D, dai ele roda perfeito....

cszasalp
Baby
Baby

Mensagens : 2
Pontos : 3
Reputação : 1
Data de inscrição : 05/04/2013
Idade : 36
Localização Localização : Mage

Voltar ao Topo Ir em baixo

Re: Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Mensagem por stopynfor em Ter 18 Fev - 15:03

instalei só que a tela do cache só fica azul e nada mais.

stopynfor
Baby
Baby

Mensagens : 4
Pontos : 8
Reputação : 0
Data de inscrição : 17/02/2014
Idade : 37
Localização Localização : olinda

Voltar ao Topo Ir em baixo

Re: Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Mensagem por brutosftp em Sab 14 Jun - 21:43

ae amigo obrigado pelo post......
a parte do raptor cache consegui.
Gostaria de saber como faço
pra minha rb 750  ether 2 sai com o ip 
do raptor cache...
meu router tem que esta 192.168.10.1?
pq meu router sai 192.168.25.1
e a faixa de ip dos clientes e 10.0.0.1/24
e não uso pppoe  da certo tmb?
se poder me indicar algum tuto de hotspot 
com autenticação de cliente que da certo com raptor cache....
sem mais obrigado. 

brutosftp
Baby
Baby

Mensagens : 12
Pontos : 25
Reputação : 0
Data de inscrição : 06/10/2011
Idade : 36
Localização Localização : s.p

Voltar ao Topo Ir em baixo

Re: Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Mensagem por edu1020 em Dom 15 Jun - 9:53

copia e cola ai no new terminal, ja ta edtada para sua rede.
/ip firewall mangle
add action=mark-routing chain=prerouting src-address=10.0.0.0/24 dst-address-list=!Site_fora_do_cache src-address-list=!Cliente_fora_do_cache in-interface=!ether2 comment=RAPTOR-CACHE disabled=yes protocol=tcp dst-port=80 new-routing-mark=to_cache passthrough=yes


e as demais são essas mesmo so copiar e colar.

edu1020
Baby
Baby

Mensagens : 19
Pontos : 28
Reputação : 1
Data de inscrição : 10/05/2012
Idade : 25
Localização Localização : goias

Voltar ao Topo Ir em baixo

Re: Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Mensagem por josuel em Sex 10 Out - 19:49

ola colega como eu coloco mais 2 hds para o cache

josuel
Baby
Baby

Mensagens : 28
Pontos : 28
Reputação : 0
Data de inscrição : 01/06/2011
Idade : 40
Localização Localização : estreito maranhão

Voltar ao Topo Ir em baixo

Re: Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Mensagem por josuel em Sex 10 Out - 19:54

fiz tudo serto como no video do youtub ficou show so que instalei so com um hd ssd de 120gb agora como eu faço para colocar mais 2hd de 500gb so para o cache ajuda a gente ai com um video ou script valeu obrigado a atenção

josuel
Baby
Baby

Mensagens : 28
Pontos : 28
Reputação : 0
Data de inscrição : 01/06/2011
Idade : 40
Localização Localização : estreito maranhão

Voltar ao Topo Ir em baixo

Re: Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Mensagem por pedro em Sab 11 Out - 17:50

da uma olhada ai neste tipico la explica.
[Você precisa estar registrado e conectado para ver este link.]

pedro
User
User

Mensagens : 100
Pontos : 134
Reputação : 38
Data de inscrição : 04/05/2011
Idade : 18
Localização Localização : Ba-Br

Voltar ao Topo Ir em baixo

Re: Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Mensagem por josuel em Ter 14 Out - 14:10

ola boa tarde a todos do forum  amigos eu instalei conforme o video e funfou beleza com um hd de 120gb e depois instalei mais um hd de 500gb conforme o video do geronimo que ensina como adicionar mais um hd e funfou 100% agora queria colocar mais um hd de 500 e nao sei fazer esse procedimento alguem pode me dar uma força ou se tem algum video ensinando como montar com 3 hds no meu caso 1 de 120gb para o sistema e 2 de 500gb para o cache agradeço a quem poder me ajudar eu e o forum

josuel
Baby
Baby

Mensagens : 28
Pontos : 28
Reputação : 0
Data de inscrição : 01/06/2011
Idade : 40
Localização Localização : estreito maranhão

Voltar ao Topo Ir em baixo

Re: Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Mensagem por josuel em Ter 14 Out - 14:23

o video mais objetivo que ja vi 
 
Instalação do Raptor Cache com o Lusca
[Você precisa estar registrado e conectado para ver este link.]

e esse outro ensina como adicionar mais um hd 100% objetivo parabens ao gerônimo esse é fera e a todos nois aprendizes 

Adicionando Um segundo Hd ao Thunder Cache

esse é o link do video:  ( [Você precisa estar registrado e conectado para ver este link.]




gostaria que se o geronimo podesse postar o video de como montar esse servidor com 3 hds era de muita ajuda a nois pois esse video serve para o raptorcahe é o mesmo procedimento

josuel
Baby
Baby

Mensagens : 28
Pontos : 28
Reputação : 0
Data de inscrição : 01/06/2011
Idade : 40
Localização Localização : estreito maranhão

Voltar ao Topo Ir em baixo

Re: Raptor Cache e Lusca - script de instalação para debian 7 com redirecionamento via mangle

Mensagem por Conteúdo patrocinado Hoje à(s) 8:35


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum