Login

Esqueci minha senha

lateral
Estatísticas
Temos 29279 usuários registrados
O último usuário registrado atende pelo nome de ronaldog

Os nossos membros postaram um total de 37313 mensagens em 5568 assuntos

Firewall redicionamento x IP dinâmico

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Firewall redicionamento x IP dinâmico

Mensagem por Bhconect em Seg 7 Out - 22:21

Olá pessoal

Hoje tenho o seguinte cenário:

3 pessoas precisam usar a porta 3389, a requisição é direcionada para um IP da rede interna. Uso o firewall do Mikrotik para isto.

Para exemplificar qualquer chamada no IP 200.150.189.23 na porta 3389 é direcionado para o IP 192.168.0.1 na mesma porta.

O problema é que estas 3 pessoas moram em outras cidades e não possuem IP Fixo, usam o NO-IP e com frequencia tenho de ficar alterando o número do IP destas pessoas no Mikrotik para que possam acessar. Pois o IP muda com frequencia.

Não tem possibilidade destas 3 pessoas fazerem aquisição de IP Fixo, o que posso fazer para resolver este problema ?

Tem alguma de fazer o direcionamento ex: meuacesso.no-ip.org em vez do IP ?

Como posso resolver este problema ?

Espero ter conseguido esclarecer minha dúvida, caso necessário mais esclarecimento fiquem a vontade.

Obrigado

Bhconect
Baby
Baby

Mensagens : 4
Pontos : 6
Reputação : 0
Data de inscrição : 07/10/2013
Idade : 36
Localização Localização : BH

Voltar ao Topo Ir em baixo

Re: Firewall redicionamento x IP dinâmico

Mensagem por ivanilsonpacheco em Qua 9 Out - 8:24

Não entendi direito.. as precisam acessar o ip 192.168.0.1:3389 da sua rede? Se sim, n importa qual ip elas vão pegar.. eh so vc n especificar o src-address na regra de redirect..

ivanilsonpacheco
User
User

Mensagens : 166
Pontos : 188
Reputação : 18
Data de inscrição : 04/04/2011
Idade : 32
Localização Localização : Várzea da Roça - Bahia

Voltar ao Topo Ir em baixo

Re: Firewall redicionamento x IP dinâmico

Mensagem por pedro em Qua 9 Out - 10:49

Amigo caso tenha que repassa a mesma porta para mais de um cliente é muito simples,
Basta alterar a porta de entrada por outra qualquer e a de saida vc coloca a porta que o cliente quer, veja exemplos a baixo


Código:
/ip firewall nat
add action=dst-nat chain=dstnat comment="area de trabalho remota cliente 01" disabled=no \
dst-port=3390 protocol=tcp to-addresses=192.168.77.253 to-ports=3389
add action=dst-nat chain=dstnat comment="area de trabalho remota cliente 02" disabled=no \
dst-port=3391 protocol=tcp to-addresses=192.168.77.252 to-ports=3389
add action=dst-nat chain=dstnat comment="area de trabalho remota cliente 03" disabled=no \
dst-port=3392 protocol=tcp to-addresses=192.168.77.251 to-ports=3389
esta porta ai que vc colocou é utilizada pela area de trabalho remota do windows, para acessar a maquina de seus clientes so abrir a area de trabalho remota no local do ip vc adiciona tambem a porta de acesso ex seu-ip-ou-ddns.org:3392

espero ter ajudado.

pedro
User
User

Mensagens : 100
Pontos : 134
Reputação : 38
Data de inscrição : 04/05/2011
Idade : 18
Localização Localização : Ba-Br

Voltar ao Topo Ir em baixo

Re: Firewall redicionamento x IP dinâmico

Mensagem por Bhconect em Qua 9 Out - 12:22

ivanilsonpacheco escreveu:Não entendi direito.. as precisam acessar o ip 192.168.0.1:3389 da sua rede? Se sim, n importa qual ip elas vão pegar.. eh so vc n especificar o src-address na regra de redirect..
Olá, ivanilsonpacheco

Já uso o redirect para fazer isto, porém como o IP destes 3 clientes muda com frequencia tenho de ficar alterando o IP deles no Mikrotik. 

Não posso apenas fazer o redirect indicando que qualquer solicitação da porta 3389 deva ser redicionado para o IP 192.168.0.1

Apenas estes 3 clientes podem ter este acesso, qualquer outra solicitação nesta porta que não seja de um destes 3 IP  destes clientes o acesso é negado.


Olá, Pedro



Código:
Código:
/ip firewall nat
add action=dst-nat chain=dstnat comment="area de trabalho remota cliente 01" disabled=no \
dst-port=3390 protocol=tcp to-addresses=192.168.77.253 to-ports=3389
add action=dst-nat chain=dstnat comment="area de trabalho remota cliente 02" disabled=no \
dst-port=3391 protocol=tcp to-addresses=192.168.77.252 to-ports=3389
add action=dst-nat chain=dstnat comment="area de trabalho remota cliente 03" disabled=no \
dst-port=3392 protocol=tcp to-addresses=192.168.77.251 to-ports=3389
Como posso usar em vez do IP o nome na regra, exemplo  meucadastro.no-ip.org  ( ou seja , o dominio criado no NO-IP ), de modo que não importe se o IP mudou ou não, ele sempre veja o nome do dominio na regra ?

Desta forma posso dizer que toda solicitação na porta 3389 vinda do endereço meucadastro.no-ip.org deverá ser redirecionada para 192.168.01 na porta 3389.


Desde já obrigado aos dois pela ajuda.

Bhconect
Baby
Baby

Mensagens : 4
Pontos : 6
Reputação : 0
Data de inscrição : 07/10/2013
Idade : 36
Localização Localização : BH

Voltar ao Topo Ir em baixo

Re: Firewall redicionamento x IP dinâmico

Mensagem por Bhconect em Sex 11 Out - 12:21

Pessoal,

Depois de várias pesquisas no google, achei algo que parece estar dando certo, ainda estou testando.

Código:
#### Resolver o nome do DNS

### Variaveis

:global DNS "seu.serviço.ddns";
:global LIST "ip-dns";
:global IP [:resolve "$DNS"];


## Comando

/ip firewall address-list set [find list="$LIST"] address="$IP";

## LOG

:log info ("ATUALIZANDO:  $DNS  NA LISTA: $LIST COM O IP: " . $IP);


###################### Fim
Este script atualiza na address-list que foi criada com o nome list="ip-dns" o seu ip real.

Mas como o IP atribuido pelo no-ip muda durante o dia várias vezes, fui em System->Scheduler e criei por lá para ser executado a cada 10 segundos, assim mesmo que o IP do DDNS mude o script é executado e atualiza o IP na address-list.

Criei uma Regra no Firewall para fazer o redirect de acordo com o IP que consta no address-list, desta forma mesmo que o IP do NO-IP mude sempre será atualizada a cada 10 segundos.

Gostaria de saber se os colegas vêem algum problema em deixar este script sendo executado a cada 10 segundos ? 

Tem como desativar o Run Count no Scheduler ?


(*)tentei achar um botão para editar a postagem anterior mais não achei, me desculpem se não for permitido fazer postagem em sequencia.

Bhconect
Baby
Baby

Mensagens : 4
Pontos : 6
Reputação : 0
Data de inscrição : 07/10/2013
Idade : 36
Localização Localização : BH

Voltar ao Topo Ir em baixo

Re: Firewall redicionamento x IP dinâmico

Mensagem por Bhconect em Qui 7 Nov - 20:31

Pessoal,

Depois de várias semanas testando a solução acima, estou me deparando com um problema.

(*) Coloquei o script no System->Scheduler esta agendado para rodar a cada 10 segundos, o problema que as pessoas que fazem o acesso remoto, passaram a reclamar que a conexão fica caindo com frequência.

Então desativei o script por 2 dias, e voltei ao modo antigo, onde a cada momento que o NO-IP muda o IP deles, eles me informam o novo numero e eu atualizo no regra do Firewall do Mikrotik, desta forma não reclamaram mais de queda no decorrer da utilização do acesso remoto.

Preciso de alguma sugestão de como resolver este problema.

Alguém tem alguma idéia ?

Bhconect
Baby
Baby

Mensagens : 4
Pontos : 6
Reputação : 0
Data de inscrição : 07/10/2013
Idade : 36
Localização Localização : BH

Voltar ao Topo Ir em baixo

Re: Firewall redicionamento x IP dinâmico

Mensagem por Conteúdo patrocinado Hoje à(s) 0:53


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum