Conectar-se

Esqueci minha senha

lateral
Estatísticas
Temos 30585 usuários registrados
O último usuário registrado atende pelo nome de fcoelho32

Os nossos membros postaram um total de 37842 mensagens em 5692 assuntos

VPN EM MIKROTIK COM LOAD BALLACE

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

VPN EM MIKROTIK COM LOAD BALLACE

Mensagem por tovar.franca em Ter 8 Out - 19:23

Cenario:

1º - 1 rb750gl fazendo load ballace 2 modems adsl bridge
2º - 1 servidor pc mikrotik 5.18 fazendo controle dos clientes
3º - 1 Servidor pc mikrotik 5.18 em cliente (fazendo controle da rede interna e roteamento com servido de dados dele)

preciso receber chamadas pptp(vpn) no (3º) servidor do cliente. configurei o ddns mas quando faço a discagem vpn externa ela esbarra no load ballace. Quais as regras devo adicionar na rb750 e no meu servidor para rotear as chamadas para o servidor do cliente???? aguardo ajuda de vocês.

tovar.franca
Baby
Baby

Mensagens : 2
Pontos : 4
Reputação : 0
Data de inscrição : 25/05/2012
Idade : 35
Localização Localização : Recife

Voltar ao Topo Ir em baixo

Re: VPN EM MIKROTIK COM LOAD BALLACE

Mensagem por tovar.franca em Ter 15 Out - 23:55

Resolvido....

Quando liguei para uma empresa especializada e me passaram um orçamento de 400 reais.... Tive que colocar tico e teco para brigarem. Resolvi meu problema assim...

1º Regras do Servidor ou RB que faz o Ballace

/ip firewall/nat
add action=dst-nat chain=dstnat comment=\
    "REDIRECIONAMENTO VPN para servidor do cliente" disabled=no dst-
    protocol=tcp to-addresses=192.168.88.254 to-ports=1723 (roteamento para servidor que autentica hotspot e ppoe

/ip firewall/filter
add action=accept chain=input disabled=no dst-port=1723 protocol=tcp(autorização para pcc ballace aceitar a chamada externa, deve estar acima de todas as regras)

2º regra no nat do servidor que autentica os clientes"hotspot e ppoe"
add action=dst-nat chain=dstnat comment=\
    "REDIRECIONAMENTO VPN para servidor do cliente" disabled=no dst-
    protocol=tcp to-addresses="192.168.10.254" to-ports=1723
/ip firewall/filter
add action=accept chain=input disabled=no dst-port=1723 protocol=tcp(autorização para servidor de autenticação aceitar a chamada do PCC ballace, deve estar acima de todas as regras)

Como uso velox em bridge as chamadas são aceitas por qualquer link que estiver no pcc ballace fiz um host dinamico no [Você precisa estar registrado e conectado para ver este link.] segue abaixo as regras que estão funcionando aqui

/system/scripts

# No-IP automatic Dynamic DNS update

#--------------- Change Values in this section to match your setup ------------------

# No-IP User account info
:local noipuser "seu nome no-ip"
:local noippass "sua senha"

# Set the hostname or label of network to be updated.
# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
# To specify multiple hosts, separate them with commas.
:local noiphost "host criado no no-ip"

# Change to the name of interface that gets the dynamic IP address
:local inetinterface "nome da interface que tem internet ex. ppoe-out"

#------------------------------------------------------------------------------------
# No more changes need

:global previousIP

:if ([/interface get $inetinterface value-name=running]) do={
# Get the current IP on the interface
   :local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address]

# Strip the net mask off the IP address
   :for i from=( [:len $currentIP] - 1) to=0 do={
       :if ( [:pick $currentIP $i] = "/") do={ 
           :set currentIP [:pick $currentIP 0 $i]
       } 
   }

   :if ($currentIP != $previousIP) do={
       :log info "No-IP: Current IP $currentIP is not equal to previous IP, update needed"
       :set previousIP $currentIP

# The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands.
       :local url "http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP"
       :local noiphostarray
       :set noiphostarray [:toarray $noiphost]
       :foreach host in=$noiphostarray do={
           :log info "No-IP: Sending update for $host"
           /tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt")
           :log info "No-IP: Host $host updated on No-IP with IP $currentIP"
       }
   }  else={
       :log info "No-IP: Previous IP $previousIP is equal to current IP, no update needed"
   }
} else={
   :log info "No-IP: $inetinterface is not currently running, so therefore will not update."
}

qualquer dificuldade estou as ordens.

tovar.franca
Baby
Baby

Mensagens : 2
Pontos : 4
Reputação : 0
Data de inscrição : 25/05/2012
Idade : 35
Localização Localização : Recife

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum