Login

Esqueci minha senha

lateral
Estatísticas
Temos 29285 usuários registrados
O último usuário registrado atende pelo nome de riccio-rj

Os nossos membros postaram um total de 37314 mensagens em 5568 assuntos

Scritps Mikrotik - Automação

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Scritps Mikrotik - Automação

Mensagem por bracinho2 em Sab 23 Nov - 20:45

Buenas,

Ao ver o título do tópico, muita gente vai pensar que "estou chovendo no molhado". Quem visitar o tópico, creio eu, vai encontra alguns scripts úteis para automatizar as tarefas em seu Mikrotik, tanto para pequenos provedores, como para condomínios, redes pequenas, etc.
Por muitos anos, fui usuário do BFW e sempre relutei em utilizar o MK por várias razões. Não desmereço o BFW em nenhum momento, até porque aprendi muito com ele. Mas hoje, certamente o MK se apresenta como uma solução perfeitamente aplicável, de baixo custo e eficiente.
Vamos aos scripts. Por uma preferência didática, vou postar o script na íntegra, e cada um copie da forma que quiser. Grande parte desses scripts encontrei na rede, alguns prontos, outros adaptei e alguns até escrevi. Espero que seja de utilidade a todos. Estou postando conforme vou documentando as tarefas. Um abraço.
#Script no-ip: para configurar acesso remoto!
# No-IP automatic Dynamic DNS update

#--------------- Change Values in this section to match your setup ------------------

# No-IP User account info
:local noipuser "ACESSO AO NO-IP"
:local noippass "SENHA NO-IP"

# Set the hostname or label of network to be updated.
# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
# To specify multiple hosts, separate them with commas.
:local noiphost "SEU HOST NO NO-IP"

# Change to the name of interface that gets the dynamic IP address
:local inetinterface "SUA INTERFACE DE INTERNET"

#------------------------------------------------------------------------------------
# No more changes need

:global previousIP

:if ([/interface get $inetinterface value-name=running]) do={
# Get the current IP on the interface
   :local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address]

# Strip the net mask off the IP address
   :for i from=( [:len $currentIP] - 1) to=0 do={
       :if ( [:pick $currentIP $i] = "/") do={
           :set currentIP [:pick $currentIP 0 $i]
       }
   }

   :if ($currentIP != $previousIP) do={
       :log info "No-IP: Current IP $currentIP is not equal to previous IP, update needed"
       :set previousIP $currentIP

# The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands.
       :local url "http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP"
       :local noiphostarray
       :set noiphostarray [:toarray $noiphost]
       :foreach host in=$noiphostarray do={
           :log info "No-IP: Sending update for $host"
           /tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt")
           :log info "No-IP: Host $host updated on No-IP with IP $currentIP"
       }
   }  else={
       :log info "No-IP: Previous IP $previousIP is equal to current IP, no update needed"
   }
} else={
   :log info "No-IP: $inetinterface is not currently running, so therefore will not update."
}
Para que o MK envie emails, não esqueça de configurar seus dados em TOOLS, EMAIL;
Não esqueça de agendar no Scheduler a função de envio de backup. Assim o MK se encarrega de lhe enviar o arquivo quantas vezes você quiser ao longo do dia/semana/mês. Eu particularmente faço backup uma vez ao dia.

#Script para backup automático:


/system backup save name=backup-mikrotik.backup
:delay 20s
:log warning message="BackUP Realizado com Sucesso"

#Script para enviar backup via email:

:log warning message="Iniciar envio de BackUP por Email"

:global data [/system clock get date]
:global hora [/system clock get time]
/tool e-mail send to="seu endereço de email" subject="backup-mikrotik $data $hora" file=backup-mikrotik.backup tls=yes

:delay 15s

:log warning message="Email de BackUP enviado com Sucesso"

Monitoramento de rede via email:

No MK existe uma função muito útil chamada NETWATCH. Você a encontra no menu TOOLS. Você pode pedir para o MK pingar seus dispositivos internos da rede, como radios, aps, MKS...etc. Com esse script, você pode configurar o MK para lhe avisar por email quando um radio fica ON ou OFF.

#Script para NETWATCH:
/tool e-mail send to="seu email" password=senha subject="Nome do dispositivo"  body="mensagem de aviso" from=email configurado no MK server=173.194.69.109 tls=yes

log warning "aviso do evento no log mikrotik"

#Acesso remoto à radios atrás do MK:
Uma dica muito legal para gerenciamento remoto de radios, antenas, aps, etc., vem do Rodrigo Meireles; segue o link.

[Você precisa estar registrado e conectado para ver este link.]

Dica muito útil quando não se está com acesso local ao servidor ou à estrutura da rede.

bracinho2
Iniciante
Iniciante

Mensagens : 35
Pontos : 56
Reputação : 9
Data de inscrição : 17/12/2011
Idade : 32
Localização Localização : Toledo/PR

Voltar ao Topo Ir em baixo

Re: Scritps Mikrotik - Automação

Mensagem por cdanielboy em Dom 24 Nov - 6:50

Seja bem vindo amigo....conhecimento nunca é D+ !!!!

cdanielboy
Power User
Power User

Mensagens : 1012
Pontos : 1333
Reputação : 267
Data de inscrição : 12/05/2011
Idade : 32
Localização Localização : belém

Voltar ao Topo Ir em baixo

Re: Scritps Mikrotik - Automação

Mensagem por bracinho2 em Dom 24 Nov - 8:50

Queria colocar tudo que tenho em um só post, mas não deu...hahaha
Estou documentando meu mikrotik e vou aproveitar para postar alguns "testes" que fiz e que deram certo. Muita coisa é "chover no molhado", mas sempre podem ajudar...um abraço.

bracinho2
Iniciante
Iniciante

Mensagens : 35
Pontos : 56
Reputação : 9
Data de inscrição : 17/12/2011
Idade : 32
Localização Localização : Toledo/PR

Voltar ao Topo Ir em baixo

Re: Scritps Mikrotik - Automação

Mensagem por Conteúdo patrocinado Hoje à(s) 7:32


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum