Login

Esqueci minha senha

lateral
Estatísticas
Temos 29300 usuários registrados
O último usuário registrado atende pelo nome de w00t3d

Os nossos membros postaram um total de 37318 mensagens em 5569 assuntos

Scritps para Automação - Boleto no Hotspot

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Scritps para Automação - Boleto no Hotspot

Mensagem por bracinho2 em Sab 23 Nov - 21:36

Buenas,

Após longos dias pensando em uma solução, encontrei um modo de enviar os boletos via hotpost para os clientes.

A solução não é muito difícil. Vamos aos passos:

a) boletos:

Após emitir os boletos, salve-os em arquivos pdf. Em seu diretório Hotspot faça o seguinte:

- crie um diretório chamado "boletos"
Fica assim: hotspot/boletos/

-Insira dentro do diretório "boletos" um novo diretório com o nome exatamente igual do usuário do hotspot:
Fica assim: hotspot/boletos/cliente1/

-Insira dentro do diretório do "cliente1" o arquivo pdf. Observe que o nome do cliente também aparece no nome do PDF:
Fica assim: hotspot/boletos/cliente1/cliente1.boleto.pdf

b) Em seu MK crie um profile chamado "boleto"

Edite a página com a seguinte linha em um link:
Fica assim: hotspot/boletos/$user/$user.boleto.pdf

Edite o profile para enviar o advertise aos cliente no login ou como desejar.

c) enviar boletos via email pelo MK:
como você tem todos os boletos em seu hotspot, pode rodar esse script:

:log warning message=("Iniciar Envio de Boletos Automático - em: " . [/sys cl get date] . " " . [/sys cl get time])


:foreach h in=[/ip hotspot user find] do={
:local user [/ip hotspot user get $h name];
:local email [/ip hotspot user get $h email];
:local comment [/ip hotspot user get [/ip hotspot user find name="$user"] comment]

if ($comment = "Devedor") do={


/tool e-mail send to="$email" password=senha do seu email subject="Boleto Internet de $user"  body="Bom dia, $user!\r\nSegue seu boleto para pagamento.\r\nObrigado.\r\nAtt., SEU NOME\r\n" from=email configurado no MK server=173.194.69.109 tls=yes file="Hotspot/boletos/$user/$user.boleto.pdf"

log warning "Boleto enviado para $user"

delay 2s
}


OBS: Lembre-se: tenha o email do cliente no MK...eu achei muito útil.

um abraço.

bracinho2
Iniciante
Iniciante

Mensagens : 35
Pontos : 56
Reputação : 9
Data de inscrição : 17/12/2011
Idade : 32
Localização Localização : Toledo/PR

Voltar ao Topo Ir em baixo

Re: Scritps para Automação - Boleto no Hotspot

Mensagem por claudinhohw Network em Dom 24 Nov - 15:23

ficou legal uma dica seria vc gravar um vídeo implanto este sistema tem gente que não se da muito bem com scripts.

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik

claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2541
Pontos : 3168
Reputação : 570
Data de inscrição : 28/08/2010
Idade : 32
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Re: Scritps para Automação - Boleto no Hotspot

Mensagem por bracinho2 em Dom 24 Nov - 15:26

claudinhohw Network escreveu:ficou legal uma dica seria vc gravar um vídeo implanto este sistema tem gente que não se da muito bem com scripts.
Grande Claudinho...rapaz, eu nao tenho nada de afinidade com video hahaha...nem camera tenho. rs

mas se a galera tiver dúvida agente via dando alguma explicação.

procurei isso a um bom tempo, e nao achei nada parecido. É a tal da dica "quem não tem cão, caça com gato".

um abraço.

bracinho2
Iniciante
Iniciante

Mensagens : 35
Pontos : 56
Reputação : 9
Data de inscrição : 17/12/2011
Idade : 32
Localização Localização : Toledo/PR

Voltar ao Topo Ir em baixo

Re: Scritps para Automação - Boleto no Hotspot

Mensagem por claudinhohw Network em Seg 25 Nov - 10:23

mais já esta valendo... ajuda baste, pra gravar vc pode usar o cantasia studio ele grava tudo que vc faz na tela e fala, basta ter um microfone, qualquer coisa me manda um mp ai.

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik

claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2541
Pontos : 3168
Reputação : 570
Data de inscrição : 28/08/2010
Idade : 32
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Re: Scritps para Automação - Boleto no Hotspot

Mensagem por Conteúdo patrocinado Hoje à(s) 19:02


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum