Login

Esqueci minha senha

lateral
Estatísticas
Temos 29301 usuários registrados
O último usuário registrado atende pelo nome de isaiasfreitas

Os nossos membros postaram um total de 37318 mensagens em 5569 assuntos

Hotspot com Central do Assinante

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Hotspot com Central do Assinante

Mensagem por bracinho2 em Dom 24 Nov - 16:59

Estou a procura de um Hotspot com central do assinante...alguém tem algo?

bracinho2
Iniciante
Iniciante

Mensagens : 35
Pontos : 56
Reputação : 9
Data de inscrição : 17/12/2011
Idade : 32
Localização Localização : Toledo/PR

Voltar ao Topo Ir em baixo

Re: Hotspot com Central do Assinante

Mensagem por Arthur Bernardes em Dom 24 Nov - 18:45

Acho que o hotspot padrão do MK não faz isso, é necessário trabalhar com "radius" em conjunto com algum tipo MK-Auth ou MyAuth.

Arthur Bernardes
Advance user
Advance user

Mensagens : 266
Pontos : 310
Reputação : 36
Data de inscrição : 01/11/2013
Idade : 19
Localização Localização : Onda Verde - SP

Voltar ao Topo Ir em baixo

Re: Hotspot com Central do Assinante

Mensagem por bracinho2 em Dom 24 Nov - 19:16

Arthur Bernardes escreveu:Acho que o hotspot padrão do MK não faz isso, é necessário trabalhar com "radius" em conjunto com algum tipo MK-Auth ou MyAuth.
Arthur,

Na verdade em tese não precisa trabalhar com servidor fora do MK...o Hotspot Inteligente já mostrou isso.
Eu comprei do Hélio o Hotspot inteligente só para ver se funcionava...é uma beleza de sistema.

O que eu nao gostei é que tem muita função que em redes pequenas não precisa. Estou pensando em algo mais enxuto.

algo assim:

Login;
Aviso;
Atraso;
Bloqueio;
Manutenção;

Central do cliente com 2 coisas:
Mudança de senha;
Boleto para download;

algumas destas coisas já tenho. O que eu nao encontrei solução ainda é a troca de senha.

bracinho2
Iniciante
Iniciante

Mensagens : 35
Pontos : 56
Reputação : 9
Data de inscrição : 17/12/2011
Idade : 32
Localização Localização : Toledo/PR

Voltar ao Topo Ir em baixo

Re: Hotspot com Central do Assinante

Mensagem por bracinho2 em Dom 24 Nov - 19:32

Para dar o Pontapé nas discussões, vou postar 2 Scripts que fiz pensando nessa central.

O primeiro é para criar um txt com os dados do usuário:

:log warning "Creating Users Profiles"

foreach h in=[/ip hotspot user find] do={
local user [/ip hotspot user get $h name];
################################
:if ([:len [/file find name="hotspot/cadastro/$user.txt"]] < 1) do={
################################
local pass [/ip hotspot user get [/ip hotspot user find name="$user"] password]
local profile [/ip hotspot user get [/ip hotspot user find name="$user"] profile]
local comment [/ip hotspot user get [/ip hotspot user find name="$user"] comment]
local email [/ip hotspot user get [/ip hotspot user find name="$user"] email]

/file print file="Hotspot/cadastro/$user.txt"

:log warning "Creating *$user* Profile"

:delay 3s

/file set "Hotspot/cadastro/$user.txt" contents="var usuario=\"$user\";
var senha=\"$pass\";
var profile=\"$profile\";
var venc=\"10\";
var aviso=\"12\";
var bloqueio=\"13\";
var comment=\"$comment\";
var email=\"$email\"";


:log warning "Profile *$user* Sucessfull Created!"

}
}

O Segundo é para ler os dados do usuário no TXT:

:log warning "Start Update Users"


:foreach h in=[/ip hotspot user find] do={

:log warning "Start Update Users"


:foreach h in=[/ip hotspot user find] do={
:local user [/ip hotspot user get $h name];

:if ([:len [/file find name="hotspot/cadastro/$user.txt"]] > 0) do={

delay 5s

:log warning "Reading Data Base Of $user..."

:local inicio
:local profile
:local venc
:local aviso
:local bloqueio
:local comment
:local email

:local content [/file get [/file find name="hotspot/cadastro/$user.txt"] contents] ;

:local pos00 [:find $content "var usuario="]
:local pos01 [:find $content "var senha="]
:local pos02 [:find $content "var profile="]
:local pos03 [:find $content "var venc="]
:local pos04 [:find $content "var aviso="]
:local pos05 [:find $content "var bloqueio="]
:local pos06 [:find $content "var comment="]
:local pos07 [:find $content "var email="]

:set inicio [:pick $content ($pos00) ($pos01 - 2)]
:set profile [:pick $content ($pos02) ($pos03 - 2)]
:set venc [:pick $content ($pos03 + 10) ($pos04 - 4)]
:set aviso [:pick $content ($pos04 + 11) ($pos05 - 4)]
:set bloqueio [:pick $content ($pos05 + 14) ($pos06 - 4)]
:set comment [:pick $content ($pos06 + 13) ($pos07 - 6)]

:log warning "Looking for Values"

:local data [system clock get date]
:local dia
:set dia [:pick $data 4 6]

:log warning "Set $user Profile..."

if ($dia  >= "$aviso") do={

:log warning "Change $user Profile to AVISO"

/ip hotspot user set "$user" profile=AVISO

:log warning "Disable $user Bypass Cell"

/ip hotspot ip-binding set [/ip hotspot ip-binding find comment="$user"] disable=yes


:log warning "Update Finish"
}
}
}

Faltaria o Terceiro: uma págia em java ou qualquer outra linguagem que fizesse a leitura do TXT e alterasse a senha...

vamos avante.

bracinho2
Iniciante
Iniciante

Mensagens : 35
Pontos : 56
Reputação : 9
Data de inscrição : 17/12/2011
Idade : 32
Localização Localização : Toledo/PR

Voltar ao Topo Ir em baixo

Re: Hotspot com Central do Assinante

Mensagem por Arthur Bernardes em Dom 24 Nov - 19:33

Hum! Dessa eu não sabia, parece ótimo e evita a implementação de um servidor secundário para autenticação (MK-Auth ou MyAuth).

Arthur Bernardes
Advance user
Advance user

Mensagens : 266
Pontos : 310
Reputação : 36
Data de inscrição : 01/11/2013
Idade : 19
Localização Localização : Onda Verde - SP

Voltar ao Topo Ir em baixo

Re: Hotspot com Central do Assinante

Mensagem por bracinho2 em Seg 25 Nov - 8:19

Seguindo com as pesquisas, há uma API do MK que fornece acesso para mudança de senha. Inclusive o código da página está disponível para download.

Segue o código:
use PEAR2\Net\RouterOS;
require_once 'PEAR2/Autoload.php';

$errors = array();

try {
    //Adjust NAS RouterOS IP, username and password accordingly.
    $client = new RouterOS\Client('10.5.50.1', 'senha', 'senha');

    $printRequest = new RouterOS\Request(
        '/ip hotspot active print',
        RouterOS\Query::where('address', $_SERVER['REMOTE_ADDR'])
    );
    $hotspotUsername = $client->sendSync($printRequest)->getArgument('user');

    //Adjust AAA RouterOS IP, username and password accordingly.
    $client = new RouterOS\Client('10.5.50.1', 'senha', 'senha');
} catch(Exception $e) {
    $errors[] = $e->getMessage();
}

if (isset($_POST['password']) && isset($_POST['password2'])) {
    if ($_POST['password'] !== $_POST['password2']) {
        $errors[] = 'Passwords do not match.';
    } elseif (empty($errors)) {
        //Here's the fun part - actually changing the password
        $setRequest = new RouterOS\Request('/tool user-manager user set');
        $client($setRequest
            ->setArgument('numbers', $hotspotUsername)
            ->setArgument('password', $_POST['password'])
        );
    }
}

?>"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

   
        Change your hotspot password
       
   
   
       

           
               

We're sorry, but we can't change your password right now.
                Please try again later


           
           

You are currently logged in as "                    echo $hotspotUsername;
                ?>"



           
           

                   
                   

  •                
               

           
           
Your password has been changed.

           

           

               

                       

  •                        
                           
                       

  •                    

  •                        
                           
                       

  •                    

  •                        
                       

  •                

           

           
       

   


Entretanto, eu não sei como fazer a instalação da API para php. Alguém sabe alguma coisa sobre?

bracinho2
Iniciante
Iniciante

Mensagens : 35
Pontos : 56
Reputação : 9
Data de inscrição : 17/12/2011
Idade : 32
Localização Localização : Toledo/PR

Voltar ao Topo Ir em baixo

Re: Hotspot com Central do Assinante

Mensagem por Conteúdo patrocinado Hoje à(s) 2:46


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum