Conectar-se

Esqueci minha senha

lateral
Estatísticas
Temos 30810 usuários registrados
O último usuário registrado atende pelo nome de dimasd

Os nossos membros postaram um total de 37897 mensagens em 5713 assuntos

Configuração, 2 links, 1 única rede.

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Configuração, 2 links, 1 única rede.

Mensagem por mcabrito em Qua 30 Abr - 16:53

Olá amigos, tudo bom?  lol! 

Gostaria da ajuda de vocês para fazer uma configuração um tanto que especial.

Tenho 2 links de internet e uma única rede em minha empresa.
Para contextualizar, tenho alguns servidores na Amazon AWS e devido a um problema de rota da NetVirtua (que eles não corrigem), a minha sincronização com meu banco de dados fica intermitente e não consigo subir meus dados. Por isso, contratei um plano 4G da VIVO, que claro, testei antes com um celular e a sincronização foi mais de dez vezes mais rápida.

O que preciso:
Preciso dedicar a conexão VIVO que entra na interface eth4, para 3 ips diferentes. E manter o link da NetVirtua que esta na eth1 para o restante dos endereços da rede. Vi alguns configurações, porém todos falam para criar uma nova rede, mas preciso manter estes ips em minha subrede.

Tenho a configuração de contingência dos 2 links, mas creio que não vou utiliza-la mais.

Exemplo:

Range de ip: 10.0.0.0 até 10.0.0.254

Os ips 10.0.0.40. 10.0.0.65 e 10.0.0.70 ficaram para o link VIVO na eth4.
O restante dos ips vai continuar saindo pela NetVirtua na eth1.

A porta que uso para os meus swiths é a eth2.

Alguém sabe me dizer como posso fazer esta configuração?

Desde ja, agradeço a ajuda.

mcabrito
Baby
Baby

Mensagens : 1
Pontos : 3
Reputação : 0
Data de inscrição : 16/10/2013
Idade : 33
Localização Localização : brasilia

Voltar ao Topo Ir em baixo

Re: Configuração, 2 links, 1 única rede.

Mensagem por andreopo em Qui 22 Maio - 10:05

Opa amigo blz? uso isto aqui na empresa, marcando as conexoes que entram pelo ip 192.168.2.1-192.168.2.254 para o link adsl de 5mb e outra regra deixando passar todo o resto das conexoes com os demais endereços, ai eu separei da seguinte forma: Quem se conecta pelo PPPOE pega internet de 5mb, e quem se conecta pelo HOTSPOT pega o link de 10mb, assim fica super separado, a unica coisa que pode acontecer, eh que se um link cair, o usuario nem vai perceber pois ira navegar pelo outro que esta online.

Para isto eu uso regras no mangle e algumas configuracoes em ip>routes

andreopo
Baby
Baby

Mensagens : 17
Pontos : 29
Reputação : 0
Data de inscrição : 20/09/2013
Idade : 28
Localização Localização : casa

Voltar ao Topo Ir em baixo

Re: Configuração, 2 links, 1 única rede.

Mensagem por andreopo em Qui 22 Maio - 10:21

ta ai as regras que eu uso


/ip firewall mangle
add action=mark-routing chain=prerouting disabled=no new-routing-mark=link2 \
    passthrough=no src-address-list=link2
add action=mark-routing chain=prerouting disabled=no new-routing-mark=pppoe-adsl \
    passthrough=no src-address-list=pppoe-adsl


/ip firewall filter
add action=add-src-to-address-list address-list=link2 address-list-timeout=0s \
    chain=forward comment="FILTRO DE CLIENTES CONECTADOS" disabled=no protocol=tcp \
    src-address=192.168.2.0/24


/ip firewall filter
add action=add-src-to-address-list address-list=pppoe-adsl address-list-timeout=0s \
    chain=forward comment="FILTRO DE CLIENTES CONECTADOS" disabled=no protocol=tcp \
    src-address=192.168.1.0/24

/ip route
add disabled=no distance=2 dst-address=0.0.0.0/0 gateway=192.168.10.1 routing-mark=\
    link2 scope=30 target-scope=10


So pra esclarecer, este 192.168.10.1 eh o gateway do meu modem que tem o link de 5mb... o link 2 vamos dizer assim, o outro modem esta configurado como bridge e quem faz a conexao com a internet eh o meu mk, entao nas minhas interfaces eu tenho uma conexao pppoe onde se encontra meu provedor de acesso configurado la, e a interface que rece a internet do modem que esta configurado como roteador. Desta forma, eu separei os clientes com um servidor pppoe interno, onde todos os usuarios que se conectam por pppoe pega o endereço 192.168.2.1-192.168.2.254 e quem se conecta pelo hotspot pega endereços aleatorios pois uso sub-redes aqui. Assim, eu separei com as regras, quem vai usar o link de 5mb e quem vai usar o de 10mb, ou seja, os pppoe usam 5mb e os demais que se conectam no hotspot, ou passam fora do hotspot e fora do pppoe, pegam o link de 10mb.

Espero ter ajudado.

andreopo
Baby
Baby

Mensagens : 17
Pontos : 29
Reputação : 0
Data de inscrição : 20/09/2013
Idade : 28
Localização Localização : casa

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum