Conectar-se

Esqueci minha senha

lateral
Estatísticas
Temos 30975 usuários registrados
O último usuário registrado atende pelo nome de VictorHugooo

Os nossos membros postaram um total de 37982 mensagens em 5727 assuntos

Load Balance

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Load Balance

Mensagem por hanytech em Seg 17 Nov - 0:52

Olá Amigos estou precisando da ajuda de vocês ,com um balanceamento de dois link de 10 megas cada que fiz.
Está tudo ok com o balanceamento . O problema esta na queda de um link o outro link não assume a função ou seja a toda rede cai.
Segue minhas regras loadBalance Para que me deem dicas o que mudar ,o que acrescentar pra resolver isto. Obrigado desde já.

Rede:10.10.10.1
Link1: 192.168.2.1    10 megas
Link2:192.168.1.1     10 megas

/ip address
add address=10.10.10.1/24 network=10.10.10.0 broadcast=10.10.10.1 interface=Rede
add address=192.168.2.1/24 network=192.168.1.0 broadcast=192.168.2.1 interface=Link1
add address=192.168.1.1/24 network=192.168.1.0 broadcast=192.168.1.1 interface=Link2

/ip firewall mangle
add chain=input in-interface=Link1 action=mark-connection new-connection-mark=Link1_conn
add chain=input in-interface=Link2 action=mark-connection new-connection-mark=Link2_conn

add chain=output connection-mark=Link1_conn action=mark-routing new-routing-mark=to_Link1
add chain=output connection-mark=Link2_conn action=mark-routing new-routing-mark=to_Link2

add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Rede
add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Rede

add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/0 action=mark-connection new-connection-mark=Link1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:4/1 action=mark-connection new-connection-mark=Link2_conn passthrough=yes

add chain=prerouting connection-mark=Link1_conn in-interface=Rede action=mark-routing new-routing-mark=to_Link1
add chain=prerouting connection-mark=Link2_conn in-interface=Rede action=mark-routing new-routing-mark=to_Link2

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_Link1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_Link2 check-gateway=ping

add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=2 check-gateway=ping

/ip firewall nat
add chain=srcnat out-interface=Link1 action=masquerade
add chain=srcnat out-interface=Link2 action=masquerade

hanytech
Baby
Baby

Mensagens : 2
Pontos : 6
Reputação : 0
Data de inscrição : 20/05/2013
Idade : 31
Localização Localização : minaçu-go

Voltar ao Topo Ir em baixo

Re: Load Balance

Mensagem por claudinhohw Network em Seg 17 Nov - 7:40

coloque assim e dará certo.
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=3 check-gateway=ping

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik
avatar
claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2738
Pontos : 3383
Reputação : 588
Data de inscrição : 28/08/2010
Idade : 33
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum