Login

Esqueci minha senha

lateral
Estatísticas
Temos 29292 usuários registrados
O último usuário registrado atende pelo nome de Ismael azevedo

Os nossos membros postaram um total de 37315 mensagens em 5569 assuntos

Como criar lista de ips de acordo com um determinado profile do hotspot

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Como criar lista de ips de acordo com um determinado profile do hotspot

Mensagem por kfs987 em Qui 11 Dez - 1:50

eu tenho um user profile chamado Pago q eu quero colocar quando um cliente paga adiantado porem no dia do vencimento dele automaticamente o mk muda o perfil de todos cadastrados naquela data pra Avisado com um aviso de cobrança da mensalidade ai já deve imaginar o q acontece no dia seguinte.

então minha ideia é a seguinte, listar todos os usuários com profile pago e gravar o ip deles no andress-lists do firewal, execultar o resto do script normalmente, deixando ir pro perfil avisado más antes do reset pegar os ips da address-lists automaticamente e mudar pro perfil liberado ai em seguida limpar o anddres-list e prosseguir com o reset.

a duvida é,
como eu gravo os ips do profile pago na anddress-lists
como eu carrego essa lista de ips no profile liberado
como eu limpo essa lista.

kfs987
Iniciante
Iniciante

Mensagens : 31
Pontos : 45
Reputação : 0
Data de inscrição : 23/05/2014
Idade : 30
Localização Localização : Caruaru

Voltar ao Topo Ir em baixo

Re: Como criar lista de ips de acordo com um determinado profile do hotspot

Mensagem por pedro em Qui 11 Dez - 7:28

Amigo coloque o mk-auth que vai te atender da melhor forma.
Fazer direto pelo mikrotik é gambiarra pura.

pedro
User
User

Mensagens : 100
Pontos : 134
Reputação : 38
Data de inscrição : 04/05/2011
Idade : 18
Localização Localização : Ba-Br

Voltar ao Topo Ir em baixo

Re: Como criar lista de ips de acordo com um determinado profile do hotspot

Mensagem por kfs987 em Qui 11 Dez - 14:18

mk-auth pra mim agora é sem futuro, minha rede é toda cabeada e n passa de 40 clientes, por enquanto na gambiarra como vc diz é a melhor solução, quando eu queria fazer cache full era todo mundo falando a mesma coisa, q era sem futuro q ia consumir processamento q hd de 80gb n servia, coloquei pra funcionar, tive uma melhora no carregamento das paginas, meu processador n passa de 60% e somente nos finais de semana q atinge essa taxa no restante da semana fica em torno de 10% e o cache está consumindo cerca de 10gb por semana ou seja consigo passar 1mês sem precisar ficar limpando cache.

voltando ao assunto, analisando aqui alguns scripts vi q também é possível exportar dados para um arquivo txt e posteriormente lê-los o q seria uma alternativa a minha ideia de exportar os ip ao anddresslists.

e ai ? alguma ideia ou gambiarra de como faço isso somente no mikrotik ?

kfs987
Iniciante
Iniciante

Mensagens : 31
Pontos : 45
Reputação : 0
Data de inscrição : 23/05/2014
Idade : 30
Localização Localização : Caruaru

Voltar ao Topo Ir em baixo

Re: Como criar lista de ips de acordo com um determinado profile do hotspot

Mensagem por claudinhohw Network em Sex 12 Dez - 9:53

isso e bem simples amigo vc tem que fazer um address-list em ip firewall address-list ai nos planos tipo vc cria um plano 1MB ai vc vai lá em General Address-list e escolhe o que foi criado e dará certinho Very Happy espero ter ajudado.

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik

claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2541
Pontos : 3168
Reputação : 570
Data de inscrição : 28/08/2010
Idade : 32
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Re: Como criar lista de ips de acordo com um determinado profile do hotspot

Mensagem por kfs987 em Sex 12 Dez - 19:52

cara meu script é tipo assim
Código:
:local data [/system clock get date];
:local dia [:pick $data 4 6];
:if ( $dia = "10" ) do={
/ip hotspot user set [find profile=Avisado] profile=Bloqueado;
/ip hotspot user set [find address=192.168.2.25] profile=Avisado;
/ip hotspot user set [find address=192.168.2.5] profile=Avisado;
/ip hotspot user set [find address=192.168.2.26] profile=Avisado;
/ip hotspot user set [find address=192.168.2.28] profile=Avisado;
/ip hotspot user set [find address=192.168.2.15] profile=Avisado;
/ip hotspot active remove [find server=Hotspot];
}

no exemplo esses script é chamado no dia 10 faltando 1 segundo pra 00:00 do dia 11
o cliente me pagou adiantando ou no mesmo dia, a mudança de profille é feita no ip do cliente e eu tenho sempre q ficar colocando manualmente o perfil liberado nesses clientes q pagaram após a chamado desses script, então minha ideia seria criar um perfil exclusivo pra quem já pagou com nome pago e antes do reset carregar o ip desses q estão no perfil pago, mudalos pro perfil liberado e só então meter o reset. n entendi essa tua ideia se possivel um script funcional pra mim estudar e adaptar.

kfs987
Iniciante
Iniciante

Mensagens : 31
Pontos : 45
Reputação : 0
Data de inscrição : 23/05/2014
Idade : 30
Localização Localização : Caruaru

Voltar ao Topo Ir em baixo

Re: Como criar lista de ips de acordo com um determinado profile do hotspot

Mensagem por kfs987 em Sex 12 Dez - 20:42

n era o q eu queria más pelo menos ta funcionando do jeito q eu quero

Código:
:local data [/system clock get date];
:local dia [:pick $data 4 6];
:if ( $dia = "10" ) do={
/ip hotspot user set [find profile=Avisado] profile=Bloqueado;
:local Net 192.168.2.25; :if ([/ip hotspot user get [find address=$Net] profile]="Liberado") do={/ip hotspot user set [find address=$Net] profile=Avisado;}
:local Net 192.168.2.5; :if ([/ip hotspot user get [find address=$Net] profile]="Liberado") do={/ip hotspot user set [find address=$Net] profile=Avisado;}
:local Net 192.168.2.26; :if ([/ip hotspot user get [find address=$Net] profile]="Liberado") do={/ip hotspot user set [find address=$Net] profile=Avisado;}
:local Net 192.168.2.28; :if ([/ip hotspot user get [find address=$Net] profile]="Liberado") do={/ip hotspot user set [find address=$Net] profile=Avisado;}
:local Net 192.168.2.15; :if ([/ip hotspot user get [find address=$Net] profile]="Liberado") do={/ip hotspot user set [find address=$Net] profile=Avisado;}
/ip hotspot user set [find profile=Liberado_PG] profile=Liberado;
/ip hotspot active remove [find server=Hotspot];
}

kfs987
Iniciante
Iniciante

Mensagens : 31
Pontos : 45
Reputação : 0
Data de inscrição : 23/05/2014
Idade : 30
Localização Localização : Caruaru

Voltar ao Topo Ir em baixo

Re: Como criar lista de ips de acordo com um determinado profile do hotspot

Mensagem por claudinhohw Network em Sab 13 Dez - 7:28

coloca o mk-auth que resolve tudo isso, e simplifica.

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik

claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2541
Pontos : 3168
Reputação : 570
Data de inscrição : 28/08/2010
Idade : 32
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Re: Como criar lista de ips de acordo com um determinado profile do hotspot

Mensagem por Arthur Bernardes em Sab 13 Dez - 8:21



Agora se deseja usar Radius é bem melhor, facilita muito sua vida.

Procure o MK-Auth ou o RadiusNet.

Arthur Bernardes
Advance user
Advance user

Mensagens : 266
Pontos : 310
Reputação : 36
Data de inscrição : 01/11/2013
Idade : 19
Localização Localização : Onda Verde - SP

Voltar ao Topo Ir em baixo

Re: Como criar lista de ips de acordo com um determinado profile do hotspot

Mensagem por kfs987 em Sab 27 Dez - 4:14

Arthur Bernardes escreveu:

Agora se deseja usar Radius é bem melhor, facilita muito sua vida.

Procure o MK-Auth ou o RadiusNet.
tem um problema nisso ai pois só começa a listar após remover o cliente da aba active do hotspot
depois de muita gambiarra testada eu consegui motar a melhor forma a minha necessidade.

onde tem $dia = "01" eu defino o dia do vencimento dos clientes e entre as duas barras eu listo o ip dos clientes q vencem naquele dia.
depois eu crio vários scripts desse mudando as datas e os ips depois chamo todos eles no scheduler a cada 24h

Código:
:global Net;
:local data [/system clock get date];
:local dia [:pick $data 4 6];
:if ( $dia = "01" ) do={
:for End from=1 to=31 step=1 do={
:set Net 0.0.0.0;
#-----------------------------------------------------------------------------------
:if ( $End = 1 ) do={ :set Net 192.168.2.2; }
:if ( $End = 2 ) do={ :set Net 192.168.2.3; }
#-----------------------------------------------------------------------------------
:if ([/ip hotspot user get [find address=$Net] profile]="Liberado") do={
/ip hotspot user set [find address=$Net] profile=Avisado;
} else {
:if ([/ip hotspot user get [find address=$Net] profile]="Liberado_PG") do={
/ip hotspot user set [find address=$Net] profile=Liberado;
}
}
:for Block from=0 to=30 step=5 do={  
:if ( $dia = $Block ) do={
/ip hotspot user set [find profile=Avisado] profile=Bloqueado;
}
}
/ip hotspot active remove [find address=$Net];
}
}

kfs987
Iniciante
Iniciante

Mensagens : 31
Pontos : 45
Reputação : 0
Data de inscrição : 23/05/2014
Idade : 30
Localização Localização : Caruaru

Voltar ao Topo Ir em baixo

Re: Como criar lista de ips de acordo com um determinado profile do hotspot

Mensagem por kfs987 em Sab 27 Dez - 18:20

Correção!
Código:
:global Net;
:local data [/system clock get date];
:local dia [:pick $data 4 6];
:for Block from=0 to=30 step=5 do={ 
:if ( $dia = $Block ) do={
/ip hotspot user set [find profile=Avisado] profile=Bloqueado;
}
}
:if ( $dia = "01" ) do={
:for End from=1 to=31 step=1 do={
:set Net 0.0.0.0;
#----------------------------------------------------------------------------------------------------------------------------------------------
:if ( $End = 1 ) do={ :set Net 192.168.2.2; }
:if ( $End = 2 ) do={ :set Net 192.168.2.3; }
#----------------------------------------------------------------------------------------------------------------------------------------------
:if ([/ip hotspot user get [find address=$Net] profile]="Liberado") do={
/ip hotspot user set [find address=$Net] profile=Avisado;
} else {
:if ([/ip hotspot user get [find address=$Net] profile]="Liberado_PG") do={
/ip hotspot user set [find address=$Net] profile=Liberado;
}
}
/ip hotspot active remove [find address=$Net];
}
}

kfs987
Iniciante
Iniciante

Mensagens : 31
Pontos : 45
Reputação : 0
Data de inscrição : 23/05/2014
Idade : 30
Localização Localização : Caruaru

Voltar ao Topo Ir em baixo

Re: Como criar lista de ips de acordo com um determinado profile do hotspot

Mensagem por Conteúdo patrocinado Hoje à(s) 12:57


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum