Conectar-se

Esqueci minha senha

lateral
Estatísticas
Temos 30975 usuários registrados
O último usuário registrado atende pelo nome de VictorHugooo

Os nossos membros postaram um total de 37982 mensagens em 5727 assuntos

enviar ip publico para o dyndns.com

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

enviar ip publico para o dyndns.com

Mensagem por dsalvanhini em Qui 15 Jan - 17:27

Ola pessoal, alguem tem o script para enviar o ip da interface para o dyndns.com?

eu ja achei para outros servidores de DNS mas não achei para o dyndns.


Valeu

dsalvanhini
Baby
Baby

Mensagens : 11
Pontos : 17
Reputação : 0
Data de inscrição : 13/12/2014
Idade : 34
Localização Localização : Santo Andre - SP

http://www.imperiodocomputador.com.br

Voltar ao Topo Ir em baixo

Re: enviar ip publico para o dyndns.com

Mensagem por dsalvanhini em Qui 15 Jan - 17:42

galera atualizando a informação eu consegui enviar o ip para o dyndns, com o codigo abaixo

Código:
# Set needed variables
:local username "YourUsername"
:local password "YourPassword"
:local hostname "nohostset"

:global dyndnsForce
:global previousIP

# print some debug info
:log info ("UpdateDynDNS: username = $username")
:log info ("UpdateDynDNS: hostname = $hostname")
:log info ("UpdateDynDNS: previousIP = $previousIP")

# get the current IP address from the internet (in case of double-nat)
/tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
:local result [/file get dyndns.checkip.html contents]

# parse the current IP result
:local resultLen [:len $result]
:local startLoc [:find $result ": " -1]
:set startLoc ($startLoc + 2)
:local endLoc [:find $result "</body>" -1]
:local currentIP [:pick $result $startLoc $endLoc]
:log info "UpdateDynDNS: currentIP = $currentIP"

# Remove the # on next line to force an update every single time - useful for debugging, but you could end up getting blacklisted by DynDNS!
#:set dyndnsForce true

# Determine if dyndns update is needed
# more dyndns updater request details available at http://www.dyndns.com/developers/specs/syntax.html
:if (($currentIP != $previousIP) || ($dyndnsForce = true)) do={
   :set dyndnsForce false
   :set previousIP $currentIP
    /tool fetch user=$username password=$password mode=http address="members.dyndns.org" src-path="/nic/update?hostname=$hostname&myip=$currentIP" dst-path="/dyndns.txt"
   :local result [/file get dyndns.txt contents]
   :log info ("UpdateDynDNS: Dyndns update needed")
   :log info ("UpdateDynDNS: Dyndns Update Result: ".$result)
   :put ("Dyndns Update Result: ".$result)
} else={
   :log info ("UpdateDynDNS: No dyndns update needed")
}



mas o problema que tenho dois links, como faço apra esse codigo ser aplicado somente para um determinado link?

dsalvanhini
Baby
Baby

Mensagens : 11
Pontos : 17
Reputação : 0
Data de inscrição : 13/12/2014
Idade : 34
Localização Localização : Santo Andre - SP

http://www.imperiodocomputador.com.br

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum