Conectar-se

Esqueci minha senha

lateral
Estatísticas
Temos 30877 usuários registrados
O último usuário registrado atende pelo nome de dornaspdg

Os nossos membros postaram um total de 37935 mensagens em 5718 assuntos

MIKROTIK->MK-AUTH - PAGINA AVISO, CORTE, MANUTENÇÃO, ATRASO

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

MIKROTIK->MK-AUTH - PAGINA AVISO, CORTE, MANUTENÇÃO, ATRASO

Mensagem por rafaelgunes em Qui 20 Ago - 12:38

Boa tarde a todos!

Gostaria de saber se alguem já conseguiu colocar para funcionar a página de Aviso, Corte, Atraso e Manutenção que o MKAUTH oferece para que possa ser exibida pelo microtik quando clientes se encontram nessas situações ou queda de Link... 
Pois já tentei de todas as formas e não consegui... Regras no firewall, DNS, mudança nas ordens das regras, vários vídeos explicando mas nada faz com que funciona na prática, até agora so teoria... 

Mikrotik 5.20 + MKAUTH 4.99 + HOTSPOT
Link Velox roteado, MK com dhcp client ativado!
As portas MKauth 85, 88, 89, 90 estão todas funcionando e testadas ok pelo browser qd digito o ip do mkauth: + porta

Se possível, alguém poderia me ajudar ou explicar detalhado como fazer isso funcionar ???

Grato a todos.
avatar
rafaelgunes
Baby
Baby

Mensagens : 7
Pontos : 21
Reputação : 4
Data de inscrição : 18/08/2015
Idade : 35
Localização Localização : Itabuna

Voltar ao Topo Ir em baixo

Re: MIKROTIK->MK-AUTH - PAGINA AVISO, CORTE, MANUTENÇÃO, ATRASO

Mensagem por cicero araujo em Qui 12 Nov - 10:07

link-Online

local users
foreach int in=[/ip hotspot user find] do={
set users [/ip hotspot user get $int name]
/ip hotspot user set $users profile=[/ip /hotspot user get $users comment]
/ip hotspot user set $users comment=""
/ip hotspot active remove [/ip hotspot active find user=$users]
}

---------------------------------------------------------------------------------------

Link-Offline
local users

foreach int in=[/ip hotspot user find] do={
set users [/ip hotspot user get $int name]

if ([/ip hotspot user get $users comment]="") do={
/ip hotspot user set $users comment=[/ip hotspot user get $users profile]
/ip hotspot user set $users profile =MANUTENCAO
/ip hotspot active remove [/ip hotspot active find user=$users]
/log waming "Antenção o Link Caiu"
/system script run "LIMPAR"
}
}

------------------------------------------------------------------------------------------


local dns "8.8.8.8"

if ([/ping $dns count=5]!= 0) do={
/system script run "link-Online"
}else={
/system script run "link-Offline"
}





TESTADO NA V5.20 E ESTÁ TUDO OK! ESPERO TE AJUDADO.

cicero araujo
Baby
Baby

Mensagens : 1
Pontos : 1
Reputação : 0
Data de inscrição : 11/11/2015
Idade : 31
Localização Localização : tuntum

Voltar ao Topo Ir em baixo

Re: MIKROTIK->MK-AUTH - PAGINA AVISO, CORTE, MANUTENÇÃO, ATRASO

Mensagem por claudinhohw Network em Ter 17 Nov - 16:45

esses scripts funciona pra todas as versões pois são feitos, bela ajuda amigo, cicero.

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik
avatar
claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2720
Pontos : 3363
Reputação : 586
Data de inscrição : 28/08/2010
Idade : 33
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum