Login

Esqueci minha senha

lateral
Estatísticas
Temos 29301 usuários registrados
O último usuário registrado atende pelo nome de isaiasfreitas

Os nossos membros postaram um total de 37318 mensagens em 5569 assuntos

SCRIPT PARA LIMPAR LISTA NO DHCP SERVER EM LEASES

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

SCRIPT PARA LIMPAR LISTA NO DHCP SERVER EM LEASES

Mensagem por LVMS2002 em Sex 4 Set - 23:52

Olá galera,

já vi muito na net script para limpar lista de ips (smartphone, etc) do dhcp server na aba leases, porém não achei para a versao do Mikrotik 5.18

estou limpando manualmente toda hora fico verificando, está complicado.

alguém poderia me ajudar ?

Grato!

LVMS2002
Iniciante
Iniciante

Mensagens : 35
Pontos : 51
Reputação : 0
Data de inscrição : 08/02/2011
Idade : 40
Localização Localização : Januária/MG

Voltar ao Topo Ir em baixo

Re: SCRIPT PARA LIMPAR LISTA NO DHCP SERVER EM LEASES

Mensagem por adeiltonjr em Sex 11 Set - 13:53

:foreach i in=[/ip dhcp-server lease find host-name~"android"] do={/ip dhcp-server lease remove $i; }
:foreach i in=[/ip dhcp-server lease find host-name~"Phone"] do={/ip dhcp-server lease remove $i; }
:foreach i in=[/ip dhcp-server lease find host-name~"Iphone"] do={/ip dhcp-server lease remove $i; }
log error "Removendo DHCP Celulares"

adeiltonjr
Iniciante
Iniciante

Mensagens : 37
Pontos : 47
Reputação : 2
Data de inscrição : 30/05/2012
Idade : 32
Localização Localização : Crato - Ce

Voltar ao Topo Ir em baixo

Re: SCRIPT PARA LIMPAR LISTA NO DHCP SERVER EM LEASES

Mensagem por LVMS2002 em Sex 15 Abr - 15:33

Esse script já tentei acho que só funciona na versão 6.xx do MK, na 5.18 tentei e não deu certo.

LVMS2002
Iniciante
Iniciante

Mensagens : 35
Pontos : 51
Reputação : 0
Data de inscrição : 08/02/2011
Idade : 40
Localização Localização : Januária/MG

Voltar ao Topo Ir em baixo

Re: SCRIPT PARA LIMPAR LISTA NO DHCP SERVER EM LEASES

Mensagem por Alvarenga em Seg 18 Abr - 18:41

LVMS2002, 

Saudações caro colega!

Segue o script, testado e funcional para versões 5xx:

Código:
:foreach i in=[/ip dhcp-server lease find host-name~"android"] do={
:log error ("REMOVENDO ANDROID: " . [/ip dhcp-server lease get $i address]);
/ip dhcp-server lease remove $i;
}
:foreach i in=[/ip dhcp-server lease find host-name~"iPhone"] do={
:log error ("REMOVENDO IPHONE: " . [/ip dhcp-server lease get $i address]);
/ip dhcp-server lease remove $i;
}


Esqueci de colocar os créditos: 

 Eberty Rodrigues em 4 julho 2014 at 21:46
site: http://mk-auth.com.br/forum/topics/remover-entradas-de-android-do-dhcp

Alvarenga
Iniciante
Iniciante

Mensagens : 70
Pontos : 84
Reputação : 2
Data de inscrição : 12/08/2014
Idade : 31
Localização Localização : Vitória da Conquista

http://blog.ticonquista.com.br

Voltar ao Topo Ir em baixo

Re: SCRIPT PARA LIMPAR LISTA NO DHCP SERVER EM LEASES

Mensagem por LVMS2002 em Qua 20 Abr - 16:13

Alvarenga,

tentei inserir no mk 5.20 via new terminal... não consegui.....
confirme se fiz correto,
copiei este código q vc passou. abri new terminal, colei, só que não aparece nem em scripts e nem em scheduler...

me ajuda nao to conseguindo....

LVMS2002
Iniciante
Iniciante

Mensagens : 35
Pontos : 51
Reputação : 0
Data de inscrição : 08/02/2011
Idade : 40
Localização Localização : Januária/MG

Voltar ao Topo Ir em baixo

Re: SCRIPT PARA LIMPAR LISTA NO DHCP SERVER EM LEASES

Mensagem por Alvarenga em Qua 20 Abr - 18:40

Oi, Boa noite meu caro.

Isto é um script, por via de regra você não precisa abrir o terminal. O caminho seria SYSTEM > SCRIPT > NOVO SCRIPT. Copie o código que eu postei e dê um nome, por fim, salve-o clicando em ok.

Vá em Scheduler e crie um novo agendamento e em On Event coloque o mesmo nome dado ao SCRIPT em On Event > clique em ok e pronto!

Alvarenga
Iniciante
Iniciante

Mensagens : 70
Pontos : 84
Reputação : 2
Data de inscrição : 12/08/2014
Idade : 31
Localização Localização : Vitória da Conquista

http://blog.ticonquista.com.br

Voltar ao Topo Ir em baixo

Re: SCRIPT PARA LIMPAR LISTA NO DHCP SERVER EM LEASES

Mensagem por gomesdj em Sex 22 Abr - 17:09

Brother usa assim:

Regra para criar o script de limpar os leases dinâmicos, vá em New Terminal e cole os códigos abaixo:

/system script add name="Reset Leases Dynamic" policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api source="/ ip dhcp-server lease rem\
    ove [find host-name~\"android\" or host-name~\"Iphone\" or host-name~\"Phone\" dynamic=\"yes\"]"

/system scheduler add name="Limpador de Leases" comment="Aciona a Limpeza da lista Lease em DHCP SERVER as 5h da manha" start-time="startup" interval="1d5h" on-event="Reset Leases Dynamic"


Observe o interval adapte-o a seu gosto, esse script ira remover tudo do Leases, existem outros atributops que podem ser adicionados conforme a necessidade como:

*Remover por status
*Remover por nomes
*Remover por tempo de atividade entre outras opções.

Use sempre o New Terminal para fazer os testes de script quando você achar necessidade de criar um evento ou rotina. Assim como uso no hotspot se a net cair alem de direcionar para a pagina de manutenção remove todos os clientes ativos e que estão no cookie forçando a ir a página de login.

gomesdj
Baby
Baby

Mensagens : 26
Pontos : 35
Reputação : 7
Data de inscrição : 24/03/2012
Idade : 34
Localização Localização : GOIAS

Voltar ao Topo Ir em baixo

Re: SCRIPT PARA LIMPAR LISTA NO DHCP SERVER EM LEASES

Mensagem por LVMS2002 em Dom 24 Abr - 13:18

Alvarenga,
agora deu certo como vc falou para implantar....

gomesdj,
usei como vc falou para implantar e não limpou, será algum erro no código... confirmei está dentro do script e scheduler mas não está limpando, poderia tentar modificar o código para testar novamente ?

Seria possível também implementar para limpar na lista do hotspot/hosts... deixando somente a faixa 20.0.0.x
ex: uso a faixa de ip 20.0.0.x porém, esta aparecendo outras faixas, (192.168.1.2, 192.168.1.170, etc...) deixando somente a faixa 20.0.0.x.

LVMS2002
Iniciante
Iniciante

Mensagens : 35
Pontos : 51
Reputação : 0
Data de inscrição : 08/02/2011
Idade : 40
Localização Localização : Januária/MG

Voltar ao Topo Ir em baixo

Re: SCRIPT PARA LIMPAR LISTA NO DHCP SERVER EM LEASES

Mensagem por Alvarenga em Seg 25 Abr - 12:20

Gomes Dj,

Boa tarde!

Só para entender, qual seria a necessidade deste segundo script?

Alvarenga
Iniciante
Iniciante

Mensagens : 70
Pontos : 84
Reputação : 2
Data de inscrição : 12/08/2014
Idade : 31
Localização Localização : Vitória da Conquista

http://blog.ticonquista.com.br

Voltar ao Topo Ir em baixo

Re: SCRIPT PARA LIMPAR LISTA NO DHCP SERVER EM LEASES

Mensagem por gomesdj em Seg 25 Abr - 19:13

Prezados

LVS2002, fiz as correções para que o código o faça:

/system script
add name="Reset Leases Dynamic" policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api source=\
    "/ip dhcp-server lease remove [find active-host~Iphone or active-host~Phone or active-host~android or dynamic=yes]"


Quanto esse range que esta sendo distribuído em sua rede seria necessário verificar quem é esse servidor DHCP de origem, essa range parece vir de seu modem em loop. 
Certifique esse quesito. Segue código para remover ip's da range mencionada

Remoção de ip's de range desconhecida

/system script
add name=RANGE-192.168.1.0 policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    source="/ip hotspot host remove [find address~\"192.168.1\"]"

Agendador de Script, esta configurado com time a cada 5 segundos

/system scheduler
add disabled=no interval=5s name=RANGE-192.168.1.0 on-event=RANGE-192.168.1.0 policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api start-time=startup


Alvarenga, o segundo código é para que o o scheduler execute em tempo agendado a limpeza do lease liberando os ip's da rede para que usa uma range de 254 ip's ou outros fins!

gomesdj
Baby
Baby

Mensagens : 26
Pontos : 35
Reputação : 7
Data de inscrição : 24/03/2012
Idade : 34
Localização Localização : GOIAS

Voltar ao Topo Ir em baixo

Re: SCRIPT PARA LIMPAR LISTA NO DHCP SERVER EM LEASES

Mensagem por Alvarenga em Seg 25 Abr - 20:35

Gomes Dj,

Meu nobre, boa noite!

No penúltimo post, você falou sobre o script referindo-se ao hotspot >> hosts. Agora você aponta sobre um, que seria para limpeza do lease dhcp sobre um range 254. Está tudo confuso. Explique melhor sobre a sua topologia de rede e necessidades para que possamos lhe ajudar melhor.

Alvarenga
Iniciante
Iniciante

Mensagens : 70
Pontos : 84
Reputação : 2
Data de inscrição : 12/08/2014
Idade : 31
Localização Localização : Vitória da Conquista

http://blog.ticonquista.com.br

Voltar ao Topo Ir em baixo

Re: SCRIPT PARA LIMPAR LISTA NO DHCP SERVER EM LEASES

Mensagem por gomesdj em Ter 26 Abr - 20:14

LVMS2002 escreveu:Alvarenga,
agora deu certo como vc falou para implantar....

gomesdj,
usei como vc falou para implantar e não limpou, será algum erro no código... confirmei está dentro do script e scheduler mas não está limpando, poderia tentar modificar o código para testar novamente ?

Seria possível também implementar para limpar na lista do hotspot/hosts... deixando somente a faixa 20.0.0.x
ex: uso a faixa de ip 20.0.0.x porém, esta aparecendo outras faixas, (192.168.1.2, 192.168.1.170, etc...) deixando somente a faixa 20.0.0.x.

Prezado Alvarenga;

Conforme pedido do nosso amigo LVMS2002 para que fosse criado também um script para limpeza de host de uma determinada range foi criado conforme abaixo:

Remoção de ip's de range desconhecida

/system script
add name=RANGE-192.168.1.0 policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    source="/ip hotspot host remove [find address~\"192.168.1\"]"

Agendador de Script, esta configurado com time a cada 5 segundos

/system scheduler
add disabled=no interval=5s name=RANGE-192.168.1.0 on-event=RANGE-192.168.1.0 policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api start-time=startup

gomesdj
Baby
Baby

Mensagens : 26
Pontos : 35
Reputação : 7
Data de inscrição : 24/03/2012
Idade : 34
Localização Localização : GOIAS

Voltar ao Topo Ir em baixo

Re: SCRIPT PARA LIMPAR LISTA NO DHCP SERVER EM LEASES

Mensagem por Conteúdo patrocinado Hoje à(s) 22:57


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum