Conectar-se

Esqueci minha senha

lateral
Estatísticas
Temos 30975 usuários registrados
O último usuário registrado atende pelo nome de VictorHugooo

Os nossos membros postaram um total de 37982 mensagens em 5727 assuntos

Novo Loadbalance HTTPs (substitui do PCC)

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Novo Loadbalance HTTPs (substitui do PCC)

Mensagem por Alvarenga em Qua 23 Dez - 16:42

Saudações caro(s) amigos!

Estou postando as regras de balanceamento que promete substituir o LoadBalance PCC. Vale lembrar que este, está em fase de teste, o intuito é compartilhar melhorá-lo, por isto estou colocando-o de forma gratuita. 

Nomes das Interfaces
Código:
# dec/23/2015 15:24:38 by RouterOS 6.33.3 ALVARENGA
# software id = EIIS-YN0G
# Definindo as Interfaces

/interface ethernet
set [ find default-name=ether1 ] name=ether1-ISP-PPP
set [ find default-name=ether2 ] name=ether2-ISP-ROUTE
set [ find default-name=ether3 ] name=ether3-ISP-SKY
set [ find default-name=ether5 ] master-port=ether4

DEFINIÇÕES IP/DHCP

Código:
/ip address
add address=172.3.2.1/16 interface=ether4 network=172.3.0.0
add address=200.200.10.1/24 interface=ether4 network=200.200.10.0


Código:
/ip pool
add name=Hotspot ranges=19.20.0.2-19.20.255.254
add name=pool_172 ranges=172.200.100.1-172.200.100.254
add name=dhcp_pool1 ranges=172.3.0.1-172.3.2.0,172.3.2.2-172.3.255.254
add name=Newppp ranges=200.200.10.2-200.200.10.100
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=ether4 lease-time=3d name=\
    dhcp1


DEFININDO FIREWALL / ADDRESS-LIST / NAT / 
Código:
/ip firewall address-list
add address=172.200.0.0/16 comment=Allnetwork disabled=yes list=Avisos
add address=172.200.0.0/16 comment="All-Network 172 Avisos" disabled=yes \
    list=Avisos
add address=172.3.0.0/16 list=Allips

Código:
/ip firewall filter
add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=established
add chain=input comment="default configuration" connection-state=related
add action=drop chain=input comment="default configuration" in-interface=\
    ether1-ISP-PPP
add chain=forward comment="default configuration" connection-state=\
    established
add chain=forward comment="default configuration" connection-state=related
add action=drop chain=forward comment="default configuration" \
    connection-state=invalid

Código:
/ip firewall mangle
add chain=prerouting disabled=yes src-address=172.3.0.0/16
add action=mark-connection chain=prerouting comment="Link 1" \
    connection-state=new in-interface=all-ethernet new-connection-mark=\
    ISPCON_1 per-connection-classifier=both-addresses-and-ports:5/0 \
    src-address=172.3.0.0/16 src-address-list=Allips
add action=mark-routing chain=prerouting comment="Link 1 - MUN2014" \
    connection-mark=ISPCON_1 in-interface=all-ethernet new-routing-mark=\
    ISPROTA_1 src-address=172.3.0.0/16 src-address-list=Allips
add action=mark-connection chain=prerouting comment="Link 2 - MUN2014" \
    connection-state=new in-interface=all-ethernet new-connection-mark=\
    ISPCON_2 per-connection-classifier=both-addresses-and-ports:5/1 \
    src-address=172.3.0.0/16 src-address-list=Allips
add action=mark-routing chain=prerouting comment="Link 2 - MUN2014" \
    connection-mark=ISPCON_2 in-interface=all-ethernet new-routing-mark=\
    ISPROTA_2 src-address=172.3.0.0/16 src-address-list=Allips
add action=mark-connection chain=prerouting comment="Link 3 -1/2- MUN2014" \
    connection-state=new in-interface=all-ethernet new-connection-mark=\
    ISPCON_3 per-connection-classifier=both-addresses-and-ports:5/2 \
    src-address=172.3.0.0/16 src-address-list=Allips
add action=mark-routing chain=prerouting comment="Link 3 -2/2- MUN2014" \
    connection-mark=ISPCON_3 in-interface=all-ethernet new-routing-mark=\
    ISPROTA_3 src-address=172.3.0.0/16 src-address-list=Allips
add action=mark-routing chain=prerouting comment=\
    "1 ===SITES HTTPS FORA DO BALANCE===" dst-port=443 new-routing-mark=ISP1 \
    passthrough=no protocol=tcp
add action=mark-routing chain=prerouting comment=\
    "2 ===SITES HTTPS FORA DO BALANCE===" dst-address-list=NO-BALANCE \
    new-routing-mark=ISP1 passthrough=no
add action=add-dst-to-address-list address-list=NO-BALANCE \
    address-list-timeout=10m chain=prerouting comment=\
    "3 ===SITES HTTPS FORA DO BALANCE===" content=bb.com.br
add action=mark-routing chain=prerouting comment=\
    "001 ===SITES CSART FORA DO BALANCE===" dst-port=11000 new-routing-mark=\
    ISP1CS protocol=tcp
add action=mark-routing chain=prerouting comment=\
    "002 ===SITES CSART FORA DO BALANCE===" dst-address-list=NO-BALANCE \
    new-routing-mark=ISP1CS
add action=add-dst-to-address-list address-list=NO-BALANCE \
    address-list-timeout=10m chain=prerouting comment=\
    "003 ===SITES CSART FORA DO BALANCE===" content=satcs.ddns.me

Código:
/ip firewall nat
add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
add action=masquerade chain=srcnat comment="default configuration" \
    to-addresses=0.0.0.0


Código:
/ip route
add check-gateway=ping distance=1 gateway=pppoe-out1 routing-mark=ISPROTA_1
add distance=1 gateway=10.10.32.1 routing-mark=ISPROTA_2
add check-gateway=ping distance=1 gateway=192.168.100.1 routing-mark=\
    ISPROTA_3


Caso falte alguma regra ou não funcione, pode me contatar! 

At. Thiago Alvarenga
whatsapp 77 9 9933-2505
avatar
Alvarenga
Iniciante
Iniciante

Mensagens : 70
Pontos : 87
Reputação : 5
Data de inscrição : 12/08/2014
Idade : 32
Localização Localização : Vitória da Conquista

http://blog.ticonquista.com.br

Voltar ao Topo Ir em baixo

Re: Novo Loadbalance HTTPs (substitui do PCC)

Mensagem por Alvarenga em Qua 23 Dez - 17:25

Vídeo do Loadbalance em ação:

avatar
Alvarenga
Iniciante
Iniciante

Mensagens : 70
Pontos : 87
Reputação : 5
Data de inscrição : 12/08/2014
Idade : 32
Localização Localização : Vitória da Conquista

http://blog.ticonquista.com.br

Voltar ao Topo Ir em baixo

Re: Novo Loadbalance HTTPs (substitui do PCC)

Mensagem por euviciadu em Qui 24 Dez - 12:03

valeu ae broder ...vou testar agora mesmo presentão de natal

euviciadu
Baby
Baby

Mensagens : 12
Pontos : 18
Reputação : 0
Data de inscrição : 02/08/2013
Idade : 38
Localização Localização : castanhal

Voltar ao Topo Ir em baixo

Re: Novo Loadbalance HTTPs (substitui do PCC)

Mensagem por Alvarenga em Qui 24 Dez - 13:41

Disponha meu amigo!

Vale lembrar que este loadbalance só funciona até então, nas versões 6x acima. 

É importante expor também, que devemos os méritos ao Sr. Cleber Aguiar.

Mais um auxílio, está neste vídeo do mum 2014 proposto por Cleber Aguiar. 

avatar
Alvarenga
Iniciante
Iniciante

Mensagens : 70
Pontos : 87
Reputação : 5
Data de inscrição : 12/08/2014
Idade : 32
Localização Localização : Vitória da Conquista

http://blog.ticonquista.com.br

Voltar ao Topo Ir em baixo

Re: Novo Loadbalance HTTPs (substitui do PCC)

Mensagem por euviciadu em Sab 26 Dez - 17:11

Alvarenga aqui deu certo não pois ficou conectando no celular normal mais no PC da rede não identificada quando cobecto no PC mais nao uso o discador no link 1

euviciadu
Baby
Baby

Mensagens : 12
Pontos : 18
Reputação : 0
Data de inscrição : 02/08/2013
Idade : 38
Localização Localização : castanhal

Voltar ao Topo Ir em baixo

Re: Novo Loadbalance HTTPs (substitui do PCC)

Mensagem por Alvarenga em Dom 27 Dez - 0:19

Aqui vai o backup: [Você precisa estar registrado e conectado para ver este link.]

O Backup está criptografado, a senha é: teste

Para acessar, o dados são:

O Usuário é: testando
A senha é: teste
avatar
Alvarenga
Iniciante
Iniciante

Mensagens : 70
Pontos : 87
Reputação : 5
Data de inscrição : 12/08/2014
Idade : 32
Localização Localização : Vitória da Conquista

http://blog.ticonquista.com.br

Voltar ao Topo Ir em baixo

Re: Novo Loadbalance HTTPs (substitui do PCC)

Mensagem por Alvarenga em Dom 27 Dez - 0:21

Os cinco primeiros que solicitar suporte por team view eu irei ajudar. Apenas os cinco primeiros.
avatar
Alvarenga
Iniciante
Iniciante

Mensagens : 70
Pontos : 87
Reputação : 5
Data de inscrição : 12/08/2014
Idade : 32
Localização Localização : Vitória da Conquista

http://blog.ticonquista.com.br

Voltar ao Topo Ir em baixo

Re: Novo Loadbalance HTTPs (substitui do PCC)

Mensagem por euviciadu em Dom 27 Dez - 11:38

se quizer me ajudar eu aceito sua ajuda 
rsrsr

euviciadu
Baby
Baby

Mensagens : 12
Pontos : 18
Reputação : 0
Data de inscrição : 02/08/2013
Idade : 38
Localização Localização : castanhal

Voltar ao Topo Ir em baixo

Re: Novo Loadbalance HTTPs (substitui do PCC)

Mensagem por euviciadu em Dom 27 Dez - 13:15

alvarenga valeu mesmo pela ajuda ae sou muito grato a vc deu suporte 100% acredito que seja pouco foi 1000% o seu suporte auxilio tudo valeu mesmo presente de natal o poster suporte presente de ano kkkk

funciona bom mesmo tudo ok alvarenga ae no 10 abraços valeu mesmo pela força udo ok aqui

euviciadu
Baby
Baby

Mensagens : 12
Pontos : 18
Reputação : 0
Data de inscrição : 02/08/2013
Idade : 38
Localização Localização : castanhal

Voltar ao Topo Ir em baixo

Re: Novo Loadbalance HTTPs (substitui do PCC)

Mensagem por Alvarenga em Dom 27 Dez - 17:37

Por nada meu nobre colega! Poste alguns print de como ficou!!!!


Lembre-se, o sábio de verdade é aquele que não guarda o conhecimento para se mesmo. É aquele que argucia sem onerar, ostentar. Vamos passar o conhecimento a diante.
avatar
Alvarenga
Iniciante
Iniciante

Mensagens : 70
Pontos : 87
Reputação : 5
Data de inscrição : 12/08/2014
Idade : 32
Localização Localização : Vitória da Conquista

http://blog.ticonquista.com.br

Voltar ao Topo Ir em baixo

Re: Novo Loadbalance HTTPs (substitui do PCC)

Mensagem por euviciadu em Dom 27 Dez - 21:12

show de bola tudo ok  [url=]loadbalance alvarenga[/url]

euviciadu
Baby
Baby

Mensagens : 12
Pontos : 18
Reputação : 0
Data de inscrição : 02/08/2013
Idade : 38
Localização Localização : castanhal

Voltar ao Topo Ir em baixo

Re: Novo Loadbalance HTTPs (substitui do PCC)

Mensagem por JuninhoNET em Qui 7 Abr - 12:33

Ola Alvarenga! como faço pra baixar esse Backup pois o mesmo não está disponivel.
avatar
JuninhoNET
Baby
Baby

Mensagens : 1
Pontos : 1
Reputação : 0
Data de inscrição : 30/04/2014
Idade : 31
Localização Localização : Tuntum-MA

Voltar ao Topo Ir em baixo

Re: Novo Loadbalance HTTPs (substitui do PCC)

Mensagem por Alvarenga em Qui 7 Abr - 13:50

Oi,

Saudações Juninho.

Não tenho certeza se é este, acredito que seja: [Você precisa estar registrado e conectado para ver este link.]
avatar
Alvarenga
Iniciante
Iniciante

Mensagens : 70
Pontos : 87
Reputação : 5
Data de inscrição : 12/08/2014
Idade : 32
Localização Localização : Vitória da Conquista

http://blog.ticonquista.com.br

Voltar ao Topo Ir em baixo

Re: Novo Loadbalance HTTPs (substitui do PCC)

Mensagem por claudinhohw Network em Qui 7 Abr - 22:36

já faço o balance com rotas sumarizadas há 2 anos balanceando os sites https assim como os http sem rota especifica pra eles e sem problemas com bancos sites etc... segue o print.

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik
avatar
claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2738
Pontos : 3383
Reputação : 588
Data de inscrição : 28/08/2010
Idade : 33
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

O tempo nos mostra que é possível abrir a mente para o novo.

Mensagem por Alvarenga em Sab 16 Abr - 16:37

claudinhohwetwork escreveu:já faço o balance com rotas sumarizadas há 2 anos balanceando os sites https assim como os http sem rota especifica pra eles e sem problemas com bancos sites etc... segue o print.

Saudações caro colega, 

Apresentei uma solução dentre outras infinitas existentes que o mikrotik dispõe como: Firewall marking, ECMP, PCC, Nth, Bonding, OSPF, BGP e por fim este que eu demonstrei. Cada um pode ser aplicado de maneiras específicas, depende qual cenário e necessidade de cada um.

O nobre amigo usa o PCC, ótimo se atende as suas necessidades. Assim como eu acredito que este tópico ficaria cheio de "print" se cada um decidisse questionar o tipo de loadbalance usado.  O propósito deste tópico como já descrito na inicial, é o de expor o novo loadbalance do MUN (conferência anual sobre o Mikrotik Routers OS) na sua ultima edição. Ainda, melhorará-lo e compartilhar a experiência. Caso você decida experimentá-lo e tiver uma opinião para somar, será de grande valia, no mais vamos nos ater apenas ao enunciado do tópico.

Uma das vantagens deste loadbalance é que ele funciona com hotspot+loadbalance e consome pouquíssimo do hardware.


Última edição por Alvarenga em Sab 16 Abr - 16:44, editado 1 vez(es) (Razão : Ortografia.)
avatar
Alvarenga
Iniciante
Iniciante

Mensagens : 70
Pontos : 87
Reputação : 5
Data de inscrição : 12/08/2014
Idade : 32
Localização Localização : Vitória da Conquista

http://blog.ticonquista.com.br

Voltar ao Topo Ir em baixo

Re: Novo Loadbalance HTTPs (substitui do PCC)

Mensagem por claudinhohw Network em Seg 18 Abr - 19:18

(Y) não quis questionar o qual e melhor até pq o que eu uso não tem como usar hotspot ou pppoe juntos, mais já implantei esse balance que vc compartilho e funciona perfeitamente, tenho 2 rodando um 2 prefeituras. Funciona perfeitamente. parabéns por compartilhar.

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik
avatar
claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2738
Pontos : 3383
Reputação : 588
Data de inscrição : 28/08/2010
Idade : 33
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Re: Novo Loadbalance HTTPs (substitui do PCC)

Mensagem por Alvarenga em Seg 18 Abr - 19:36

Claudinho,

Saudações caro colega,


Obrigado meu nobre...

Á todos colegas, 
Disponha caso precisem.
avatar
Alvarenga
Iniciante
Iniciante

Mensagens : 70
Pontos : 87
Reputação : 5
Data de inscrição : 12/08/2014
Idade : 32
Localização Localização : Vitória da Conquista

http://blog.ticonquista.com.br

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum