Login

Esqueci minha senha

lateral
Estatísticas
Temos 29294 usuários registrados
O último usuário registrado atende pelo nome de gilbertocb

Os nossos membros postaram um total de 37317 mensagens em 5569 assuntos

Como faço umScript para desativar clientes no Hotspot

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Como faço umScript para desativar clientes no Hotspot

Mensagem por RAIJE em Seg 8 Ago - 15:11

Boa tarde a todos

Gostaria de saber dos que sabem como eu faço para criar um script para desativar um user no hotspot depois de 5 dias que ele logou pela primeira vez usando todo ou não seu tempo

Por exemplo

tenho vários cliente cadastrado da seguinte maneira em me sistema o qual eu insiro em new terminal com um aplicativo com seguinte comando

/ip hotspot user
add disabled=no limit-uptime=01:00:00 name=e877129  password=38990890 profile="plano128k/256k" comment="ELY LOTE 11 08/07/2016"


Importante:

Informação: sobre userprofile está configurado da seguinte maneira:

name="plano128k/256k" session-timeout=6h idle-timeout=none
     keepalive-timeout=10s status-autorefresh=10s shared-users=1
     rate-limit="128k/256k"
     on-login=#RAIJE\r\n#23 de junho de 2016\r\n#raije.web@gmail.com\r\n{\r\n:g
         lobal date [ /system clock get date ]\r\n:global strtime [ /system
         clock get time ]\r\n:global cmt [ /ip hotspot user get $user comment]
         \r\n:global uname [/ip hotspot user get $user name]\r\n/log error
         $uname\r\n\r\n:foreach int in=[/ip hotspot active find]
         do={\r\n:local strname [/ip hotspot active get $int user]\r\n:local
         strmac [/ip hotspot active get $int mac]\r\n\r\n:if ($strname =
         $uname ) do={\r\n/ip hotspot user set $user comment=($cmt . ";" .
         "USADO EM: " . $date . "_" . $strtime . "_" . $strmac) \r\n/log error
         ($strname . $strmac)\r\n}\r\n}\r\n}\r\n\r\n



em on já existe o o script para mim saber se o cliente já usou o cartão  mudando o comment do user

RAIJE
Baby
Baby

Mensagens : 11
Pontos : 21
Reputação : 0
Data de inscrição : 01/08/2015
Idade : 49
Localização Localização : SALVADOR

Voltar ao Topo Ir em baixo

Re: Como faço umScript para desativar clientes no Hotspot

Mensagem por claudinhohw Network em Qua 10 Ago - 21:40

melhor usar o radius do mikrotik o user maneger e melhor já faz tudo automatico pra vc.

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik

claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2541
Pontos : 3168
Reputação : 570
Data de inscrição : 28/08/2010
Idade : 32
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Re: Como faço umScript para desativar clientes no Hotspot

Mensagem por RAIJE em Sex 12 Ago - 12:40

Valeu a intenção mais não me ajuda dessa forma, obrigado pelo esforço

RAIJE
Baby
Baby

Mensagens : 11
Pontos : 21
Reputação : 0
Data de inscrição : 01/08/2015
Idade : 49
Localização Localização : SALVADOR

Voltar ao Topo Ir em baixo

Re: Como faço umScript para desativar clientes no Hotspot

Mensagem por claudinhohw Network em Sex 12 Ago - 12:53

vc sabe criar os scripts pra desconectar e desativar os clientes?

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik

claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2541
Pontos : 3168
Reputação : 570
Data de inscrição : 28/08/2010
Idade : 32
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Re: Como faço umScript para desativar clientes no Hotspot

Mensagem por claudinhohw Network em Sex 12 Ago - 12:54

me diga como e seus planos e os ips dos clientes que vou fazer um aqui pra vc.

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik

claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2541
Pontos : 3168
Reputação : 570
Data de inscrição : 28/08/2010
Idade : 32
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Re: Como faço umScript para desativar clientes no Hotspot

Mensagem por RAIJE em Sex 12 Ago - 16:32

Boa tarde Amigo você pode me enviar seu e-mail, tentei te responder mais tive a seguinte resposta na transmissão: A largura da sua mensagem ultrapassa o limite autorizado.
Te agradeço

RAIJE
Baby
Baby

Mensagens : 11
Pontos : 21
Reputação : 0
Data de inscrição : 01/08/2015
Idade : 49
Localização Localização : SALVADOR

Voltar ao Topo Ir em baixo

Re: Como faço umScript para desativar clientes no Hotspot

Mensagem por RAIJE em Sab 13 Ago - 10:22

RAIJE escreveu:Boa tarde Amigo você pode me enviar seu e-mail, tentei te responder mais tive a seguinte resposta na transmissão: A largura da sua mensagem ultrapassa o limite autorizado.
Te agradeço

Eu acho que agora vou conseguir

o plano é o seguinte Lembrando que os ips são por dhc automáticos


Amigo em primeiro lugar quero te agradecer a sua disposição em me ajudar então la vai
 
Eu Vendo Cartões de Wi-fi Prépago
 
Para gerar os cartões e enviar para o microtik uso um sistema adicional  sem ser o user-manager
 
depois de cadastrados ficam assim:
add comment="RAIJE LOTE 01 05/08/16" disabled=no limit-uptime=1h name=r585651 \
    password=80679422 profile=plano128k/256k
add comment=\
    "RAIJE LOTE 01 05/08/16;USADO EM: aug/07/2016_13:45:15_AC:36:13:34:B9:7E" \
    disabled=no limit-uptime=1h name=r587462 password=81038123 profile=\
    plano128k/256k
 
A Profile cadastrada  está da seguinte maneira:
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=10s name=default \
    shared-users=1 status-autorefresh=10s transparent-proxy=no
add idle-timeout=none keepalive-timeout=10s name=plano128k/256k
 
Existe um script  dentro profile que muda o comment dos users mostrando quando se conectou e qual o mac acessou, o script é esse:
{
:global date [ /system clock get date ]
:global strtime [ /system clock get time ]
:global cmt [ /ip hotspot user get $user comment]
:global uname [/ip hotspot user get $user name]
/log error $uname

:foreach int in=[/ip hotspot active find] do={
:local strname [/ip hotspot active get $int user]
:local strmac [/ip hotspot active get $int mac]

:if ($strname = $uname ) do={
/ip hotspot user set $user comment=($cmt . ";" . "USADO EM: " . $date . "_" . $strtime . "_" . $strmac)
/log error ($strname . $strmac)
}
}
}
 
 
 
Então o que eu quero fazer?
Eu quero adicionar mais duas funçoes nesse script e não sei como
1ª Apenas desabilitar tos os user's com limit-uptime igual ao uptime acrescentando no coment Cartão consumido
 
2ª desabilitar todos os users com tempo não consumido dentro de cinco dias a contar da datata de seu 1º acesso  conforme está no script acima
 
 
Amigo deu pra você entender agora o meu objetivo? estou a sua disposição para maiores esclarecimentos.
 
Desde já agradeço a sua paciência e dedicação em me ajudar

RAIJE
Baby
Baby

Mensagens : 11
Pontos : 21
Reputação : 0
Data de inscrição : 01/08/2015
Idade : 49
Localização Localização : SALVADOR

Voltar ao Topo Ir em baixo

Re: Como faço umScript para desativar clientes no Hotspot

Mensagem por claudinhohw Network em Seg 15 Ago - 11:37

se for ip fixo dos clientes que precisam ser assim vc pode fazer um controle do ip no qos simples, com os dias da semana e horario que podem ou não navegar. via scritp vc terá que fazer um pra bloquear e um pra desconectar todos dia, e um pra desbloquear.

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik

claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2541
Pontos : 3168
Reputação : 570
Data de inscrição : 28/08/2010
Idade : 32
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Re: Como faço umScript para desativar clientes no Hotspot

Mensagem por RAIJE em Seg 22 Ago - 15:29

claudinhohw Network escreveu:melhor usar o radius do mikrotik o user maneger e melhor já faz tudo automatico pra vc.
Não Amigos não é nada disso, agradeço as boas intenções mas não é nada disso, vou continuar a desenvolver o scritp como eu preciso um dia irei conseguir  meu muito obrigado e se precisarem de mim também estarei ao inteiro dispor

RAIJE
Baby
Baby

Mensagens : 11
Pontos : 21
Reputação : 0
Data de inscrição : 01/08/2015
Idade : 49
Localização Localização : SALVADOR

Voltar ao Topo Ir em baixo

Re: Como faço umScript para desativar clientes no Hotspot

Mensagem por Conteúdo patrocinado Hoje à(s) 23:02


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum