Login

Esqueci minha senha

lateral
Estatísticas
Temos 29292 usuários registrados
O último usuário registrado atende pelo nome de Ismael azevedo

Os nossos membros postaram um total de 37315 mensagens em 5569 assuntos

Clientes em Débito??? Veja aqui uma forma de Bloquea-los

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Clientes em Débito??? Veja aqui uma forma de Bloquea-los

Mensagem por Lucivan em Sab 30 Jul - 19:58

Bora la galera!

Quem é que em seu provedor não tem aqueles clientes que desde que
assinou a internet só paga a mesma quando é suspenso os serviços?
Seria muito simples você ir la e desabilitar a autenticação dele! Só que
quando o folgado for navegar ira ser exibida "Página não encontrada" ai
o mesmo ira lhe procurar/ligar dizendo que a internet "CAIU"!!!

"Dai-nos paciência"

Cenário testado:

Autenticação: PPPoE
Versão: 3.13 e 3.22
Servidor Web: Apache (Instalado no proxy Debian/Ubuntu)

Vamos ao que interessa...

/ip firewall filter

add action=accept chain=forward comment="Bloqueio de usuarios por falta de pagamento.Suspensao" disabled=no dst-port=81 protocol=tcp src-address-list=\
Bloqueio-Debito-Suspensao
add action=accept chain=forward comment="" disabled=no dst-port=53 protocol=udp src-address-list=Bloqueio-Debito-Suspensao
add action=drop chain=forward comment="" disabled=no src-address-list=Bloqueio-Debito-Suspensao

/ip firewall nat

add action=masquerade chain=srcnat comment="Redirecionamento para pagina de aviso" disabled=no src-address=192.160.1.0/24
add action=same chain=dstnat comment="Controle de clientes por falta de
pagamento.Debito 15 dias de atraso" disabled=no dst-port=80 protocol=tcp
\
same-not-by-dst=no src-address-list=Bloqueio-Debito to-addresses=192.168.10.2 to-ports=81

- Onde esta em verde:
Faixa de ip da sua rede

- Onde esta em vermelho:
Ip da maquina onde esta hospedada a página (Nesse caso,em nosso proxy)

Obs.: As regras de nat,procure deixa-las logo abaixo da regra de nat da internet.

/ip firewall address-list

Name: Bloqueio-Debito-Suspensao (Nome atribuido no src-address-list)
Address: 000.000.000.000 (Ip do cliente que será bloqueado)

Explicando...

Em seu proxy faça o seguinte:

Va até /etc/apache2/ports.conf
Abra e sera exibida as seguintes linhas:

# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz
NameVirtualHost *:80
Listen 80

# SSL name based virtual hosts are not yet supported, therefore no
# NameVirtualHost statement here
Listen 443

Listen 81 # Esse Listen 81 sera adicionado por você!

Salve e feche...

Obs.: Para quem instalou o proxy + thunder através do script,não será necessário esse procedimento!Pois ja vai estar feito...

Próxima etapa:

Va até /etc/apache2/apache2.conf
Abra e la no final acresente a seguinte linha:

ServerName teste.com (nome do seu provedor ou como preferir)

Obs.:
Para quem instalou o proxy + thunder através do script,será necessário
alterar a linha "ServerName conprove" para "ServerName teste.com"


Próximo passo:

Va até /etc/apache2/sites-enabled/000-default
Abra e sera exibida as seguintes linhas:


ServerAdmin webmaster@localhost
DocumentRoot /var/www/

Options FollowSymLinks
AllowOverride None


Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/

AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all

ErrorLog /var/log/apache2/error.log
# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn
CustomLog /var/log/apache2/access.log combined
Alias /doc/ "/usr/share/doc/"

Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128


# Aqui é o ip do seu proxy e a porta onde estara a página.
ServerName aviso.teste.com # Aqui é seu sub-dominio.
DocumentRoot /var/www/teste/aviso/ # Aqui é sua pasta onde colocara a página.


Obs.: Para quem instalou o proxy + thunder através do script,será necessário alterar:
O endereço de ip,caso necessite.
O nome do sub-dominio,caso necessite.
O none/caminho da pasta do diretório,caso necessite.

Continuando...

Agora vá em /var/www e crie a pasta/diretório com o caminho de acordo que esta no DocumentRoot.

Ficará assim: /var/www/teste/aviso , dentro desta pasta "aviso" você pôe
sua página que sera mostrada aos clientes que estiverem bloqueados no /ip firewall address-list.
Código:
Fonte Underlinux - BillGates

Lucivan
User
User

Mensagens : 181
Pontos : 250
Reputação : 15
Data de inscrição : 11/12/2010

Voltar ao Topo Ir em baixo

Re: Clientes em Débito??? Veja aqui uma forma de Bloquea-los

Mensagem por Lucivan em Sab 30 Jul - 19:59

Alguem Já viu isso ae Fucionando:????

Lucivan
User
User

Mensagens : 181
Pontos : 250
Reputação : 15
Data de inscrição : 11/12/2010

Voltar ao Topo Ir em baixo

Re: Clientes em Débito??? Veja aqui uma forma de Bloquea-los

Mensagem por Convidado em Sab 30 Jul - 20:03

acompanhando

Convidado
Convidado


Voltar ao Topo Ir em baixo

Re: Clientes em Débito??? Veja aqui uma forma de Bloquea-los

Mensagem por Lucivan em Sab 30 Jul - 20:04

eu to vendo aqui uma forma de como eu vou testa-lo

Lucivan
User
User

Mensagens : 181
Pontos : 250
Reputação : 15
Data de inscrição : 11/12/2010

Voltar ao Topo Ir em baixo

Re: Clientes em Débito??? Veja aqui uma forma de Bloquea-los

Mensagem por f1969 em Sab 30 Jul - 20:41

Existem formas mil vezes mais simples, postadas aqui mesmo no forum.

f1969
User
User

Mensagens : 129
Pontos : 151
Reputação : 10
Data de inscrição : 19/04/2011
Idade : 47
Localização Localização : Brasilia-DF

Voltar ao Topo Ir em baixo

Re: Clientes em Débito??? Veja aqui uma forma de Bloquea-los

Mensagem por Lucivan em Sab 30 Jul - 20:43

quais seria essas formas?

Lucivan
User
User

Mensagens : 181
Pontos : 250
Reputação : 15
Data de inscrição : 11/12/2010

Voltar ao Topo Ir em baixo

Re: Clientes em Débito??? Veja aqui uma forma de Bloquea-los

Mensagem por f1969 em Sab 30 Jul - 21:01

[Você precisa estar registrado e conectado para ver este link.]

f1969
User
User

Mensagens : 129
Pontos : 151
Reputação : 10
Data de inscrição : 19/04/2011
Idade : 47
Localização Localização : Brasilia-DF

Voltar ao Topo Ir em baixo

Re: Clientes em Débito??? Veja aqui uma forma de Bloquea-los

Mensagem por Conteúdo patrocinado Hoje à(s) 13:02


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum