Conectar-se

Esqueci minha senha

lateral
Estatísticas
Temos 30563 usuários registrados
O último usuário registrado atende pelo nome de assocAIRR

Os nossos membros postaram um total de 37838 mensagens em 5692 assuntos

Script para ack

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Script para ack

Mensagem por samir2 em Ter 6 Set - 23:35

Ola pessoal eu tinha um script para derubar cliente que conectava com o ack alto só que atualizei meu mikrotik e agora não é mais ack é em distancia, alguem tem um script para distancia.

samir2
Baby
Baby

Mensagens : 6
Pontos : 15
Reputação : 1
Data de inscrição : 31/01/2011
Idade : 39
Localização Localização : marau

Voltar ao Topo Ir em baixo

Script para ack

Mensagem por R&RNET em Qui 27 Out - 18:53

/system script
add name=ACK policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\
#Configuracoes das variaveis\r\
\n:local ack 65;\r\
\n:local cut 1;\r\
\n\r\
\n############ Script - NAO ALTERAR #####################################\
\r\
\n:local mac "";\r\
\n:local uack "";\r\
\n:local removido "";\r\
\n:log warning ("[ackchk] Procurando clientes com ACK maior que " . \$ac\
k);\r\
\n#pega a lista de interfaces AP wireless ativas, e que tenham ack dinamic\
o\r\
\n:foreach i in=[ / interface wireless find mode="ap-bridge" ack-timeout\
="dynamic" running] do={\r\
\n :local intname [ / interface wireless get \$i name ];\r\
\n :log warning (" Interface: " . \$intname);\r\
\n :foreach x in=[/interface wireless registration-table find int\
erface=\$intname] do={\r\
\n :set uack [/interface wireless registration-table ge\
t \$x ack-timeout];\r\
\n :set removido "";\r\
\n :if (\$uack > \$ack) do={\r\
\n :set mac [ / interface wireless registration-ta\
ble get \$x mac-address]; \r\
\n :if (\$cut = 1) do= {\r\
\n :set removido " removido...";\r\
\n / interface wireless registration-table re\
move \$x;\r\
\n };\r\
\n :log warning (" mac: " . \$mac . "@" . \
\$intname . " [" . \$uack . "]" . \$removido);\r\
\n }; \r\
\n };\r\
\n};"

R&RNET
Baby
Baby

Mensagens : 2
Pontos : 2
Reputação : 0
Data de inscrição : 19/12/2010

Voltar ao Topo Ir em baixo

Re: Script para ack

Mensagem por Lucivan em Qui 27 Out - 19:57

Boa Noite alguem poderia mim explicar como fuciona esse script? e pra que ele servi... por favor alguem poderia ajudar...

Lucivan
User
User

Mensagens : 181
Pontos : 250
Reputação : 15
Data de inscrição : 11/12/2010

Voltar ao Topo Ir em baixo

Re: Script para ack

Mensagem por claudinhohw Network em Qui 27 Out - 20:26

esse script ai ta falando que clientes com ack até 65 conectam de boa acima disso ai não conecta em sua rede.

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik
avatar
claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2689
Pontos : 3327
Reputação : 581
Data de inscrição : 28/08/2010
Idade : 33
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Re: Script para ack

Mensagem por Lucivan em Qui 27 Out - 22:51

certo .mais o que significa isso?

Lucivan
User
User

Mensagens : 181
Pontos : 250
Reputação : 15
Data de inscrição : 11/12/2010

Voltar ao Topo Ir em baixo

Re: Script para ack

Mensagem por claudinhohw Network em Sex 28 Out - 8:55

Lucivan escreveu:certo .mais o que significa isso?
significa que se o seu cliente não estiver dentro destes parametros ele não vai se conectar a sua rede só isso. lembrando que isso só funciona quem usa rb com cartões 2.4 ou 5.8 se for outro radio com a rb sendo servidor apenas não funciona.

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik
avatar
claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2689
Pontos : 3327
Reputação : 581
Data de inscrição : 28/08/2010
Idade : 33
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Re: Script para ack

Mensagem por Lucivan em Sex 28 Out - 9:27

ok valew....

Lucivan
User
User

Mensagens : 181
Pontos : 250
Reputação : 15
Data de inscrição : 11/12/2010

Voltar ao Topo Ir em baixo

Re: Script para ack

Mensagem por claudinhohw Network em Sex 28 Out - 9:33

e nois ...lol!

__________________________________________________
"Teoria é quando se sabe tudo e nada funciona. Prática é quando funciona e ninguém sabe o porquê?"

LICENÇA THUNDER CACHE PRO 7.1 RÁPIDO E FÁCIL SÓ CLICAR NO LINK: [Você precisa estar registrado e conectado para ver este link.]
Parceiro BM Software | Consultoria em Mikrotik
Consultoria em Mk-Auth e ThunderCache-Pro.
Revenda ThunderCache-Pro
MSN:topmikrotik
@hotmail.com
SKYPE: topmikrotik
avatar
claudinhohw Network
Senior User Admin
Senior User Admin

Mensagens : 2689
Pontos : 3327
Reputação : 581
Data de inscrição : 28/08/2010
Idade : 33
Localização Localização : Goiás

Voltar ao Topo Ir em baixo

Re: Script para ack

Mensagem por PardalNet em Sex 28 Out - 11:02

bom dia

amigos, solicitaria uma ajuda, tenho um mk que controla os cleintes, e bullet 2hp e antena setorial 14dbi, so que em alguns clientes o sinal esta ocilando e nao sao longe tipo 500m, nao sei extamente se o meu bullet esta configurado correto.

alguem poderia me ajudar na configuração correta do mesmo, para nao estar con ocilação de sinal?



grato

PardalNet
Baby
Baby

Mensagens : 3
Pontos : 3
Reputação : 0
Data de inscrição : 28/10/2011
Idade : 50
Localização Localização : Porto Alegre

Voltar ao Topo Ir em baixo

Re: Script para ack

Mensagem por F3RR3LL em Sex 28 Out - 13:47

Olá,

Uma situação que vc tem que avaliar e com quanto de ack vc esta setando no seu bullet, eu não aconselho deixar em automático.

PardaNet, posta as screens da sua config para que possamos avaliar e lhe passar as devidas alterações para o seu perfeito funcionamento.
avatar
F3RR3LL
Iniciante
Iniciante

Mensagens : 85
Pontos : 101
Reputação : 6
Data de inscrição : 08/01/2011
Idade : 37
Localização Localização : Adivinhe

Voltar ao Topo Ir em baixo

Re: Script para ack

Mensagem por spo102 em Dom 30 Out - 1:14

como é q eu coloco essa regras no meu mikrotik e copoi e colo no terminao ???
avatar
spo102
Iniciante
Iniciante

Mensagens : 42
Pontos : 52
Reputação : 4
Data de inscrição : 09/04/2011
Idade : 38
Localização Localização : pernambuco

Voltar ao Topo Ir em baixo

Re: Script para ack

Mensagem por ZBTECK em Dom 30 Out - 12:06

claudinhohw escreveu:lembrando que isso só funciona quem usa rb com cartões 2.4 ou 5.8 se for outro radio com a rb sendo servidor apenas não funciona.

Código:
/system script

add name="Controlar_ ACK_Wlan" policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\
    #Variavel ack -> deve ter o valor do ack MAXIMO permitido.\r\
    \n#Variavel cut -> deve ser 0 ou 1, 0 somente mostra, 1 mostra e desconect\
    a a estacao.\r\
    \n:local ack 50;\r\
    \n:local cut 0;\r\
    \n:local mac \"\";\r\
    \n:local uack \"\";\r\
    \n:local removido \"\";\r\
    \n:log warning (\"[ackchk] Procurando clientes com ACK maior que \" . \$ac\
    k);\r\
    \n:foreach i in=[ / interface wireless find mode=\"ap-bridge\" ack-timeout\
    =\"dynamic\" running] do={\r\
    \n :local intname [ / interface wireless get \$i name ];\r\
    \n :log warning (\" Interface: \" . \$intname);\r\
    \n :foreach x in=[/interface wireless registration-table find interface=\$\
    intname] do={\r\
    \n :set uack [/interface wireless registration-table get \$x ack-timeout];\
    \r\
    \n :set removido \"\";\r\
    \n :if (\$uack > \$ack) do={\r\
    \n :set mac [ / interface wireless registration-table get \$x mac-address]\
    ; \r\
    \n :if (\$cut = 1) do= {\r\
    \n :set removido \" removido...\";\r\
    \n / interface wireless registration-table remove \$x;\r\
    \n };\r\
    \n :log warning (\" mac: \" . \$mac . \"@\" . \$intname . \" [\" . \$uack \
    . \"]\" . \$removido);\r\
    \n }; \r\
    \n };\r\
    \n};"

Código:
/system scheduler

add comment="" disabled=no interval=5s name=ACK_Wlan on-event=\
    "Controlar_ ACK_Wlan" policy=\
    reboot,read,write,policy,test,password,sniff,sensitive start-time=startup


ZBTECK
Power User
Power User

Mensagens : 930
Pontos : 1117
Reputação : 186
Data de inscrição : 11/04/2011
Idade : 29
Localização Localização : São Paulo

Voltar ao Topo Ir em baixo

Re: Script para ack

Mensagem por spo102 em Dom 30 Out - 12:43

blz vou testa aqui a minha aqui é um pc ap com placa s wireles de 600 Mw da Engenius EPI-3601S Wireless G Network Adapter - 108Mbps 802.11g PCI Long Range a versão do meu mikrotik é a 5.5
avatar
spo102
Iniciante
Iniciante

Mensagens : 42
Pontos : 52
Reputação : 4
Data de inscrição : 09/04/2011
Idade : 38
Localização Localização : pernambuco

Voltar ao Topo Ir em baixo

Re: Script para ack

Mensagem por spo102 em Dom 30 Out - 12:53

esse escript ele vai derruba os clientes q estão com Ack alto ?? é
avatar
spo102
Iniciante
Iniciante

Mensagens : 42
Pontos : 52
Reputação : 4
Data de inscrição : 09/04/2011
Idade : 38
Localização Localização : pernambuco

Voltar ao Topo Ir em baixo

Re: Script para ack

Mensagem por ZBTECK em Dom 30 Out - 13:04

spo102 escreveu:esse escript ele vai derruba os clientes q estão com Ack alto ?? é
Do jeito que está, não. Vai ter que mudar o valor das variáveis de acordo com suas necessidades.

ack -> deve ter o valor do ack MAXIMO permitido.
cut -> deve ser 0 ou 1, 0 somente mostra, 1 mostra e desconecta a estacao
:local ack 50;\r\
:local cut 0;

ZBTECK
Power User
Power User

Mensagens : 930
Pontos : 1117
Reputação : 186
Data de inscrição : 11/04/2011
Idade : 29
Localização Localização : São Paulo

Voltar ao Topo Ir em baixo

Re: Script para ack

Mensagem por spo102 em Dom 30 Out - 16:08

esse script q vc postoue é pra quer amigo eu sou leigo no asunto ainda amigo
avatar
spo102
Iniciante
Iniciante

Mensagens : 42
Pontos : 52
Reputação : 4
Data de inscrição : 09/04/2011
Idade : 38
Localização Localização : pernambuco

Voltar ao Topo Ir em baixo

Re: Script para ack

Mensagem por ZBTECK em Dom 30 Out - 16:59

spo102 escreveu:esse script q vc postoue é pra quer amigo eu sou leigo no asunto ainda amigo
Quem postou foi vc! Só coloquei na forma de copiar e colar, como vc pediu!
[Você precisa estar registrado e conectado para ver este link.]

O que ele faz...
[Você precisa estar registrado e conectado para ver este link.]

ZBTECK
Power User
Power User

Mensagens : 930
Pontos : 1117
Reputação : 186
Data de inscrição : 11/04/2011
Idade : 29
Localização Localização : São Paulo

Voltar ao Topo Ir em baixo

Re: Script para ack

Mensagem por Alex- em Qua 21 Dez - 14:35

senhores tem um modo melhor e não precisa de regras , ultilizando o Access list da RB , qualquer coisa min add posso ajudar .
avatar
Alex-
User
User

Mensagens : 144
Pontos : 193
Reputação : 30
Data de inscrição : 19/11/2011
Idade : 26

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum